Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: KVM switch Didn't load on Windows start - err: Sortkey.nlp not found

16 Sep 2014   #1
JLSims

Windows 7 Home Premium-64-bit, Windows 7 Professional-64-bit
 
 
KVM switch Didn't load on Windows start - err: Sortkey.nlp not found

I just found this forum while searching for help.

The mouse and keyboard were non functional after start-up yesterday. The only clue was an errer alert stating that, "Windows can not find the file: Sortkey.nlt. I did a search for this file and had quite a few hits. Some links were to Microft's "FixIt" links and one identified "Sortkey.nlt" to be a component of Net Framework 4. Other links, I believe, stated that a late version of Net Framework did contain a bug. As per Microsoft's instructions, I deleted this file in two locations and ran the FixIt routine that I had downloaded. The process finished by downloading and installing a new update to Net Framework, and my mouse and keyboard work great on the one computer on which I did the FixIt routine - I also have to do this on the other computer as well. Now I am apprehensive about re-connecting the KVM switch - wondering if the KVM did this to my computers. I filled out a "Support Form" on the StarTech Support page but I haven't received a response yet. Has anyone here had this experience when using a KVM to switch from on computer to another?

Additional Info:

Computer 1: Windows 7 Home Premium; Computer 2: Windows 7 Professional
StarTech Model: SC211KUSB, KVM switch (All USB interface)

Any help and suggestions will be appreciated.

I hope I can contribute to this forum but as my age increases, I turned 75 last July, the changes in computers and software seem to be changing more rapidly each year.

Jim Sims
Madison, AL


My System SpecsSystem Spec
.
17 Sep 2014   #2
RickL1

Windows 7 Home 32bit
 
 

Hello,
I could not find the KVM model you mentioned, but I did find model SV211KUSB, is that the one that you have? That is a typical device that goes between the keyboard/video/mouse and one, or more, computers.

A KVM Switch can be a wonderful little thing, and I use a similar one myself. A KVM Switch should not be having ANY effect on the files on your computers. So I think that the error on your screen is not related to your KVM Switch. That error may, or may not, be related to the problem of the computer not responding to the keyboard and mouse.

I recommend that you look at the user manual for your KVM Switch and see if it mentions some way to do a Reset. If it can do a Reset then that is the first thing to try if you have the unresponsive problem in the future. On my KVM Switch it will occasionally do the switch but only the keyboard works, so when I do the Reset then it fixes the mouse port.
My System SpecsSystem Spec
17 Sep 2014   #3
JLSims

Windows 7 Home Premium-64-bit, Windows 7 Professional-64-bit
 
 

RickL1,

You are right in correcting me on the model of my KVM switch (SV211KUSB) - I took typing in the sixth grade but, unfortunately, it didn't take. Also, I'm plagued with a mild form of dyslexia. I try to double-check my post but I don't always see the mistakes.

Thanks, I'll take another look on the Startech support site and look for a way to reset my switch. And hopefully I will receive a response from them today.

Jim
My System SpecsSystem Spec
.

17 Sep 2014   #4
Berton

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP
 
 

I use a 4-port Trendnet TK-407K USB KVM and it does not need software, actually didn't come with any.
My System SpecsSystem Spec
17 Sep 2014   #5
JLSims

Windows 7 Home Premium-64-bit, Windows 7 Professional-64-bit
 
 

Burton,

You are right. As RickL1 had also said. Also, since I still had no response from the service request that I had submitted on the StarTech support site, I called them, this morning, and within about a minute I was talking to an English speaking, knowledgeable tech - imagine that! He also verified what you both had said. He also said that he believed that the errant file, "sortkey.nlp", was unrelated to their SV211KUSB KVM switch. So I made sure that both computers wold work with the keyboard, Video, and mouse connected directly to each computer and then connected these components through the KVM switch. Everything worked.

Thanks, RickL1 and Burton for your spot-on response! PROBLEM SOLVED!
My System SpecsSystem Spec
17 Sep 2014   #6
Berton

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP
 
 

You're welcome, JLSims.

Berton
My System SpecsSystem Spec
Reply

 KVM switch Didn't load on Windows start - err: Sortkey.nlp not found




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Teamviwer 10 on Windows 7 won't/didn't start with Windows
Teamviwer 9 on Windows 7 64 Ultimate stopped starting with Windows. I uninstalled and reinstalled Teamviwer 10.0.36897 and each time I did "test reboots" on the new install it worked fine. Now I need to use it in real world application and it seems on my last reboot the f**king thing did not...
Software
Windows 7 installation: No drivers were found click load
Hi everyone, I get this message while installing a new windows OS on a laptop, "No drives were found. Click Load Drivers to provide a mass storage driver for installation". It's my sisters old laptop and I am not really sure what really happened as she too is not sure. She just said its not...
Installation & Setup
Windows Defender nowhere to be found and will not start
I am unable to to turn on windows defender. When I hit start I get this message: the specified service does not exist as an installed service error code 0x80070424. I believe windows defender is the reason I am getting the error message:Cannot install the driver plugin error: failed to start...
System Security
Windows 7 takes forever to load the select user/switch user screen
Earlier today I turned on my Toshiba laptop (Satellite P855-S5200) and got some sort of error screen, and then it brought me to a screen asking if I wanted to do a system repair or start windows normally. I chose system repair, but then it seemed to get stuck in that process (It was taking forever...
General Discussion
Windows will not start, OS is not able to load drivers.
Hello, I have been trying to use the installer dvd to try and repair windows. At the screen where I can select to load drivers, I don't see an option from the place that says "Select an operating system that you want to repair". I hit next, and I go the startup repair from recovery tools. Every...
BSOD Help and Support
We Didn't Start The Flame War
Here is a little vid you guys might enjoy, it kinda sums up all the 'fake build' threads in one.....:D We Didn't Start the Flame War - CollegeHumor Video *Warning - contains mature content!!" Enjoy! :roflmao:
Chillout Room


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App