Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Connectivity Problem

22 Sep 2014   #1
Dietrich32

Windows 7 Home Premium 64-bit
 
 
USB Connectivity Problem

Recently my Windows 7 Toshiba Satellite L850 laptop has been having issues regarding USB devices. I use a gaming controller that worked just fine until recently (Saturday night to be exact) when the PC did not recognize it once plugged in (when I say did not recognize, I don't mean that the "USB Device Not Recognized" message came up. I mean that it does not show up in Device Manager or under Devices and Printers at all). The cord is not damaged as if I plug it in elsewhere it works just fine. I have also had this issue with a Seagate 1TB external hard drive, as it worked the first time I plugged it in, game me the "USB Device Not Recognized" message a few times then simply was ignored by the PC even though the light still came on the drive. The drive also does not show up in Device Manager or in Disk Management anymore.

I also tried this USB Driver - General Fix for Problems but to no avail

Is there any solution to this issue?


My System SpecsSystem Spec
.
22 Sep 2014   #2
zeamann

Windows 7 Ultimate x64 SP1
 
 

greetings Dietrich32 and welcome to sevenforums.com. i am not sure if i'll be able to help you but at least you can try my tips first and then scold me later, i wouldn't mind. for your info, i've been using toshiba brands (laptops) since 4-5 years ago and my current laptop's detail is attached, if it will provide anything useful in this matter.

anyways, i always faced a problem with usb connectivity with my current laptop, whenever i plugged in "external hdd, usb sticks, and usb hub" all the way in. but also always resolved it when i re-plugged them almost all the way in. surprisingly though, it doesn't matter (no problems) when i plugged in the dongle for my logitech wireless mouse or even a usb keyboard. i only faced problems with those listed before BUT only when plugged in all the way.

if that does not help, try and see if there's any new driver update in "windows installed update" that might have caused a confusion within your system.

last but not least, i am no expert in soft/hard-ware issues but have been a consumer/end-user since the early 90s.

God bless,


Attached Thumbnails
USB Connectivity Problem-toshiba-laptop-details.jpg  
My System SpecsSystem Spec
22 Sep 2014   #3
Dietrich32

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by zeamann View Post
greetings Dietrich32 and welcome to sevenforums.com. i am not sure if i'll be able to help you but at least you can try my tips first and then scold me later, i wouldn't mind. for your info, i've been using toshiba brands (laptops) since 4-5 years ago and my current laptop's detail is attached, if it will provide anything useful in this matter.

anyways, i always faced a problem with usb connectivity with my current laptop, whenever i plugged in "external hdd, usb sticks, and usb hub" all the way in. but also always resolved it when i re-plugged them almost all the way in. surprisingly though, it doesn't matter (no problems) when i plugged in the dongle for my logitech wireless mouse or even a usb keyboard. i only faced problems with those listed before BUT only when plugged in all the way.

if that does not help, try and see if there's any new driver update in "windows installed update" that might have caused a confusion within your system.

last but not least, i am no expert in soft/hard-ware issues but have been a consumer/end-user since the early 90s.

God bless,
Thank you for your reply

The issue does not seem to be that the USB devices are plugged in all the way as that is how they were before. Like I previously said, the gaming controller was working just fine Friday afternoon into Saturday but when I went to use my laptop that night it stopped working and no USB devices were seen in any way by the computer. I recently updated my USB drivers to see if that might be it but again to no avail.
My System SpecsSystem Spec
.

22 Sep 2014   #4
zeamann

Windows 7 Ultimate x64 SP1
 
 

ok. i hope both someone and yourself will eventually be able to resolve your issue. just a thought though, will you be interested in using "system restore" to Friday's okay status?

and no disrespect meant, i just have the feeling that pooch's tutorial should have helped you. anyways, i've just deleted the infa... file and will will reboot now to check if this will help me solve my long forgotten (given up on it) issue with a usb wireless antennae.

good luck and God bless,
My System SpecsSystem Spec
22 Sep 2014   #5
Dietrich32

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by zeamann View Post
ok. i hope both someone and yourself will eventually be able to resolve your issue. just a thought though, will you be interested in using "system restore" to Friday's okay status?

and no disrespect meant, i just have the feeling that pooch's tutorial should have helped you. anyways, i've just deleted the infa... file and will will reboot now to check if this will help me solve my long forgotten (given up on it) issue with a usb wireless antennae.

good luck and God bless,
I tried a system restore to the last day everything worked (September 12) and the restore failed unfortunately.
My System SpecsSystem Spec
22 Sep 2014   #6
zeamann

Windows 7 Ultimate x64 SP1
 
 

you mean "system restore" did not run completely/successfully? or it runs successfully but did not solve your problem? sorry but i can't absolutely certain to which you meant by "the restore failed unfortunately."

if you don't mind me asking, how long have you used that laptop? i can't help thinking that your issue maybe related to the number of times of plugging/unplugging things in and out of your usb ports! which brings me to ask you again to try and play around with your plugging-in depth. i ask you this because, as far as i can recall, i never had usb connectivity issues with brand new toshiba laptops except after many months later.

i would kindly ask any one of our forum's gurus to butt in whenever they are free.

God bless,
My System SpecsSystem Spec
22 Sep 2014   #7
Dietrich32

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by zeamann View Post
you mean "system restore" did not run completely/successfully? or it runs successfully but did not solve your problem? sorry but i can't absolutely certain to which you meant by "the restore failed unfortunately."

if you don't mind me asking, how long have you used that laptop? i can't help thinking that your issue maybe related to the number of times of plugging/unplugging things in and out of your usb ports! which brings me to ask you again to try and play around with your plugging-in depth. i ask you this because, as far as i can recall, i never had usb connectivity issues with brand new toshiba laptops except after many months later.

i would kindly ask any one of our forum's gurus to butt in whenever they are free.

God bless,
This laptop has been in use for about two years, so maybe something is just worn out. Sorry about my lack of clarity, what I meant was that the system restore did not complete successfully, meaning even if I wanted to restore it nothing would have happened.
My System SpecsSystem Spec
23 Sep 2014   #8
zeamann

Windows 7 Ultimate x64 SP1
 
 

okay. Have you tried plugging your gaming controller and seagate external hdd into other computers? if you have, did you have any connectivity issues or not? And if there's a possibility of something being worn out, try plugging in your devices using other same cords that are known/proved to have no connectivity issues. I have a Seagate Goflex 2TB external hdd that for some unknown reasons it just gave up on showing in windows explorer or devices manager and not even its light lit. So I just swap the usb 3 cable with a longer one (which is for a 1TB Verbatim external hdd) and it works flawlessly.

good luck and God bless,
My System SpecsSystem Spec
23 Sep 2014   #9
zeamann

Windows 7 Ultimate x64 SP1
 
 

oh! And you might also want to search for a way to troubleshoot your issue with "system restore". It might be your second last resort prior clean installing, but I hate to think it will come to the latter.

good luck and God bless,
My System SpecsSystem Spec
23 Sep 2014   #10
Dietrich32

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by zeamann View Post
okay. Have you tried plugging your gaming controller and seagate external hdd into other computers? if you have, did you have any connectivity issues or not? And if there's a possibility of something being worn out, try plugging in your devices using other same cords that are known/proved to have no connectivity issues. I have a Seagate Goflex 2TB external hdd that for some unknown reasons it just gave up on showing in windows explorer or devices manager and not even its light lit. So I just swap the usb 3 cable with a longer one (which is for a 1TB Verbatim external hdd) and it works flawlessly.

good luck and God bless,
I tried both suggestions that you listed here, The only other computer in my house is a Mac so the Seagate 1TB hard drive worked just fine but the gaming controller requires special drivers so it would only work on Windows. I switched out the cable for a different one regarding the hard drive and it still does not show up anywhere on my computer even though the light is on.
My System SpecsSystem Spec
Reply

 USB Connectivity Problem




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
USB Connectivity Problem
My laptop containing 4USB Ports to which three of them are connected to usb keyboard,usb mouse and nokia mobile via usb cable(For internet dialup access Through nokia PC Suite). When i tried to update my nokia software through Nokia software updater,its showing message notification as below. ...
Hardware & Devices
wifi connectivity problem
i am facing problem in wifi connectivity. drivers are installed ..it shows the network . fails to connect any server.:mad:
Network & Sharing
Internet Connectivity Problem
Hello I'm Facing Internet Connectivity problem since 3 months:shock: I Re-Installed my OS 7-8 times:confused: But Still my net bullies me a lot:cry: I'm using Windows 7 Ultimate 32 Bit Any Help Please!!!
Network & Sharing
internet connectivity problem
m using toshiba satellite L640 when i try 2 connect 2 internet it keeps on acquiring network address and shows limited connectivity in windows 7 home premium... plz help me out guyz....!!!:confused::confused::confused::confused::confused::confused:
Network & Sharing
firewall connectivity problem
hi guys, this is my first post and its quite urgent.. i just got a new laptop(packardbell easynote TJ68) it runs windows 7 64-bit i am trying to run 4 different programs and seem to be having the same problem with all 4. cake poker windows live messenger pokerstars itunes
System Security
Wireless connectivity problem
I have 2.7 dual core, 1 GB ram running windows 7 32-bit.I am using Tenda mini usb adapter W541U V2.0.Whenever i connect to internet it gives good speed but after a while "no internet access appears" or sometimes dont appear and internet speed drops down to almost none.I cantacted Tenda support...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:03.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App