Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB 3.0 no longer works

13 Oct 2014   #1
RT1036

Windows 7 Home Premium
 
 
USB 3.0 no longer works

I bought an HP Pavilion 2 years ago. AMD A-10 proc with 8gig mem. Worked fine for 6 months. HDMI quit working. Started using VGA. Bought Seagate USB 3.0 2 TByte for backup. Worked fine. 18 months later MSI MS-7778 motherboard started giving me trouble on start up. I'd push the power button and the computer would lock up before getting to the point where I could enter 'setup'. I'd restart a few times and it would work okay from there. The problem kept getting worse over time until I would have to try to restart 50 to 100 times. It finally got to the point where it wouldn't boot up at all, no matter how many times I tried. I bought a new ASUS mother board and that problem was solved. But, the USB 3.0 ports would not work. Took the board back and bought the upgraded ASUS A88XM-A mother board. Still, I can't get the rear panel USB 3.0 ports to work as USB 3.0. They only work as 2.0. The front panel USB 3.0 ports don't work at all. I have downloaded the latest drivers from ASUS and re-installed them several times. I've also tried an USB 3.0 thumb drive in all ports. It isn't recognized by any of the ports. As a side note, the front panel card reader no longer works either.

Any help would be appreciated.

Thanks

Rick


My System SpecsSystem Spec
.
20 Oct 2014   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello and welcome RT mate run these first

http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html

http://www.sevenforums.com/tutorials/433-disk-check.html < use the /f and /r options in Option2 if necessary

http://www.superantispyware.com/

http://www.malwarebytes.org/products/malwarebytes_free/

http://www.bleepingcomputer.com/download/adwcleaner/

download from bleeping computer – delete any rubbishthese find.

Then if no go run this sounds a bit drastic but it will scan everything from power up and doesn't involve Windows Download Kaspersky Rescue Disk 10

My System SpecsSystem Spec
20 Oct 2014   #3
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Can you also post a screenshot of Device Manager with USB Controllers expanded.
My System SpecsSystem Spec
.

20 Oct 2014   #4
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Yep I will agree with Boozad and for some really in depth stuff do this

Using HW Info general components

DownloadHW Info and pick the right bit version - HWiNFO, HWiNFO32/64 - Download - (copy andpaste this site into the search bar) If you do not need the running informationin the smaller right hand panel close it. In the left hand window click on the+ for the individual device groupings and they will open out to the variouscomponents.

Go onopening out further until you get to the device itself. click on it and it willhighlight. In the right hand window there will be a very detailed descriptionof that device as in brand, speeds model number etc etc These are very detailedand are just what is needed for searching for drivers etc.

See my picfor an example - in this I have opened out one my components and then highlighted one of the one you need andyou can see the detail.

My pic is only an example and you should open out "Ports"


Attached Thumbnails
USB 3.0 no longer works-hw-devices-info-ram.png  
My System SpecsSystem Spec
20 Oct 2014   #5
RT1036

Windows 7 Home Premium
 
 
USB controllers screenshot

Quote   Quote: Originally Posted by Boozad View Post
Can you also post a screenshot of Device Manager with USB Controllers expanded.
The screenshot is attached. Sorry. I don't know how to embed it in a message.


Attached Thumbnails
USB 3.0 no longer works-usb-controllers.gif  
My System SpecsSystem Spec
21 Oct 2014   #6
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Can you check the driver dates for all USB 3.0 entries (Right click > Properties > Driver). The latest chipset drivers (2014/06/10) contain the latest USB 3.0 drivers. If you need it it's linked below.

download

I don't see an eXtensible Host Controller which would be your front USB 3.0 ports, I'll have to go and fire up my AMD rig to check the Device Manager. You did connect the front ports up to the USB 3.0 midboard header header yes? I believe this is it.

USB 3.0 no longer works-asus_a88xm-plus_01.jpg


My System SpecsSystem Spec
21 Oct 2014   #7
RT1036

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by Boozad View Post
Can you check the driver dates for all USB 3.0 entries (Right click > Properties > Driver). The latest chipset drivers (2014/06/10) contain the latest USB 3.0 drivers. If you need it it's linked below.

download

I don't see an eXtensible Host Controller which would be your front USB 3.0 ports, I'll have to go and fire up my AMD rig to check the Device Manager. You did connect the front ports up to the USB 3.0 midboard header header yes? I believe this is it.

Attachment 337579
The dates on the drivers are 5/28/2013. I am guessing that AMD uses amdxhc.sys for an eXtensensible Host Controller that's at C:\windows\system32\DRIVERS\amdxhc.sys. Of course, I could be wrong. I was wrong once.

I followed your link and downloaded the chipset. I drilled down until I found the amdxhc.sys and it's dated the same as what I have installed. Yes, I do have the front panel plugged into the USB3_34 socket. Don't forget that the rear panel USB 3.0 connectors, the Blue ones, only work as USB 2.0. I've also discovered that the front panel card reader doesn't work, either. Fun time with 'puters.
My System SpecsSystem Spec
21 Oct 2014   #8
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

ASUS AMD boards usually use ASMedia for their midboard headers so I couldn't answer that one definitively. I'm usually wrong at least once per thread.
My System SpecsSystem Spec
Reply

 USB 3.0 no longer works




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Sound no longer works
After the last update from MS, my sound no longer works. I rolled back to the last restore point, and then to the one just prior to that. Still doesn't work. I've changed no drivers in a long, long time. Suggestions?
Sound & Audio
Flash no longer works
It seems my Flash no longer works. When I go to a site that uses Flash, there is a blank screen where the Flash player is located. I am using IE8 (32 bit). When I go to download Flash from the Adobe site, I get an error that there was a GUI error. Any ideas what is happening? BTW, I assumed...
Browsers & Mail
Xp Internet no longer works under win 7
Ok I just made the switch from xp to win 7 ultimate (64) and everything is working great exept the Internet, inside my computer I have a dlink DGE-530t I installed the driver on the cd, I also have a cable modem from videotron plugged in a dlink wireless router (with good win7 64 bit driver! ...
Network & Sharing
Backup no longer works
Haven't run a backup with Backup and Restore for a while as I've been using Geniesoft Timeline, but I like to keep 2 backups and run B&R occasionally to an external drive M:. Today, I have the problem shown in screenshot attached. Not sure what it means. The external drive is accessible as I can...
Backup and Restore
Mute no longer Works
Well I had an issue with my volume randomly turning itself down it seems to have solved itself I dunno how but i am not questioning it... now my mute on my quick launch buttons no longer functions would this be an indication of a driver issue with the quick launch or the sound device driver??
Sound & Audio
Why AutoRun no Longer Works for Some USB Devices
Complete article: Understand why AutoRun no Longer Works for Some USB Devices I was very happy this change was made.
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App