Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 500GB hardrive not showing up

10 Dec 2014   #1
timotb

windows 7 home premium 64 bit
 
 
500GB hardrive not showing up

I have an external USB Western Digital 500GB hdd that will not show up and read on this windows 7 home premium 64 bit generic machine. Reads just fine on another windows seven machine.

On this generic machine, light comes on the hdd indicating good power and the windows music jingle plays after a few seconds suggesting it acknowledged the new hardware. No show under computer drives or in disk management.


My System SpecsSystem Spec
.
10 Dec 2014   #2
gregrocker

 

Is it possible it's there in Disk Mgmt but just not assigned a letter? Scroll down to see if there are any unlettered drives, right click to issue it a letter and it will show up in Computer.

If not then is it detected in BIOS setup?
My System SpecsSystem Spec
10 Dec 2014   #3
timotb

windows 7 home premium 64 bit
 
 

Definitely not hiding under disk management. Went to Bios setup and it appears to be seen. USB harddrive WD500 GB
My System SpecsSystem Spec
.

10 Dec 2014   #4
gregrocker

 

Type CMD in Start button Search box, rightclick result to Run as Admin, type:

DISKPART
List Disk
Sel disk # (replace # with the drive's disk number shown)
Assign
Exit
My System SpecsSystem Spec
10 Dec 2014   #5
CKWD

Windows 7 Home Premium x64
 
 

Hello timotb!

Is this drive an external or internal? Is it yours and was it first set up on that windows 7 home premium system? If it shows somewhere else, on other systems and in that system's BIOS, then the problem is in that certain computer and its OS.
This may be an ownership problem. You could use the built-in Diskpart tool and check the status of that drive.
Do you have the latest drivers for your hard disks (SATA/RAID controller)?

CK_WD
My System SpecsSystem Spec
10 Dec 2014   #6
timotb

windows 7 home premium 64 bit
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Type CMD in Start button Search box, rightclick result to Run as Admin, type:

DISKPART
List Disk
Sel disk # (replace # with the drive's disk number shown)
Assign
Exit
DISKPART> list disk

Disk 0 online 465GB 0B (internal HDD also is 500GB)
Disk 1 no media 0 0

DISKPART> sel disk 1

disk 1 is now the selected disk

DISKPART> assign

there is no volume specified.
please select a volume and try again
My System SpecsSystem Spec
10 Dec 2014   #7
timotb

windows 7 home premium 64 bit
 
 

Quote   Quote: Originally Posted by CKWD View Post
Hello timotb!

Is this drive an external or internal? Is it yours and was it first set up on that windows 7 home premium system? If it shows somewhere else, on other systems and in that system's BIOS, then the problem is in that certain computer and its OS.
This may be an ownership problem. You could use the built-in Diskpart tool and check the status of that drive.
Do you have the latest drivers for your hard disks (SATA/RAID controller)?

CK_WD
External USB plug and play
I own the HDD.....I think I originally formatted the disk on another computer
checking now for latest drivers.
My System SpecsSystem Spec
10 Dec 2014   #8
timotb

windows 7 home premium 64 bit
 
 

on further investigation, it appears there are no drivers installed for this WD5000ME passport hdd.....I have to find some.
My System SpecsSystem Spec
10 Dec 2014   #9
gregrocker

 

What is listed in Device Manager for the drive?

There should be no need for any HD drivers to be supplied for Win7.

Do you have all Important and Optional Windows Updates installed, after enabling Automatically deliver drivers via Windows Update (Step 3)?

Check Automatically for driver then in Device Manager.
My System SpecsSystem Spec
10 Dec 2014   #10
timotb

windows 7 home premium 64 bit
 
 

found the button to update driver.....simple but hidden...fixed
My System SpecsSystem Spec
Reply

 500GB hardrive not showing up




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Seagate 500GB HD showing 2TB, Unknown, Unallocated, Read Only Bad disk
Hi. I have a Seagate Goflex 500GB external hard disk. When I connect it to my laptop, it doesn't appear in my computer, and I have attached the screenshots of Disk Management and MiniTool Partition Wizard. The hard disk is behaving this way when I removed it from my laptop while it was copying a...
Hardware & Devices
Windows failing to start/install- no hardrive showing
Basically, a friend came to me asking for help. He has an Aspire one d260 netbook and it randomly stopped working. I took a look at it and whenever I try and turn it on it says No bootable device- insert boot disk and press any key. I've tried installing windows from a USB, and it doesn't show...
Installation & Setup
500GB hard drive showing 100mb space when formatting
So i managed to kinda mess up my hard drive that was in my old laptop and i got a new hard drive. The old hard drive i took to a technican and he fixed it. When i hooked up the old hard drive using one of those "thingies"(forgive my ignorance) that make the hard drive like an external one. so i...
Hardware & Devices
New sata secondary hardrive not showing up in Windows
New member here, In the process of completing and setting up a new build. As recommended installed windows 7 prof on Samsung 830 256gb SSD with no problems. During installation was only hard drive hooked up. Now I am trying to install a Seagate 320gb sata drive to use as a storage drive. The...
Installation & Setup
second Hardrive not showing in bios/disk management
Hi there, So I am here because I am having some hard drive problems. Firstly for my Primary drive i am still running my old 250gb Hard drive (with windows already installed on this drive). Secondly, for my slave drive i have a Samsung Spinpoint 1TB Hard drive that wont display in my bios or in...
Hardware & Devices
Adding another 500Gb
I want to add another 500Gb to the system, should I get rid of the 320Gb, I mean power consumption and all? I'm also a little concerned over the heat build up if I add another HDD, India's not a very pc friendly country as far as pc temps go!
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:03.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App