Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Second Hard Drive Not Appearing in Explorer

16 Dec 2014   #1
dw85745

Win 7 Pro x32
 
 
Second Hard Drive Not Appearing in Explorer

In my BIOS (which is a new American Megatrends GUI which I dislike with a passion) I show three physical drives.
I have adjusted the boot order for my primary (SATA), my second hard drive (IDE with an IDE to SATA convertor running through USB), and my CD.

When I go into Explorer, I see my Primary Drive and My CD (if a disk is in the carriage).

However, my second drive does NOT show in Explorer.

-------------------------------------------------
QUESTON:

How do I get my second drive to show in Explorer?


My System SpecsSystem Spec
.
16 Dec 2014   #2
alexgrossman

Windows 7 Home X86
 
 

Well, try connecting the second hard drive externally and see if you may able to see it in Explorer. Also, keep your spy eye under Disk Management and see if the second hard drive is seen. If so, consider formatting it (do check your backup first) and see if that helps you access second hard drive in explorer.

Do let us know your progress!!
My System SpecsSystem Spec
16 Dec 2014   #3
dw85745

Win 7 Pro x32
 
 

Quote:
try connecting the second hard drive externally
That is how it is connected.

And it shows under CP > Device Manager > Disk Drives

Quote:
consider formatting it
No way, one of my backups. I used this to install the new drive.
Will try setting drive in legacy mode in the BIOS and see what happens.
My System SpecsSystem Spec
.

17 Dec 2014   #4
CKWD

Windows 7 Home Premium x64
 
 

Hello dw85745!

Can you post a screenshot from Disk Management? If the drive is shown there and says it's Unallocated, that means it needs reformatting.
Since that drive already contains information, then it could have lost its partition(s).
Also, can you try to connect the drive internally?
Additionally, check if you have all of your USB and chipset drivers.

Hope any of this helps!

CK_WD
My System SpecsSystem Spec
17 Dec 2014   #5
dw85745

Win 7 Pro x32
 
 

CKWD thanks for the help.

-------------------------------------------------------------

Quote:
Can you post a screenshot
Drive shows offline so I'm pretty sure that is why Explorer does Not see it.

If need can post pictures -- but info is a follows:

Tab General: Device is Working Properly
Tab Policies: Quick Removal
Tab Volumes: (after populating show)
Disk : Disk1
Type : Basic
Status: Offline "<<< Most like reason Not showing in Explorer
Partition Style: MBR

Tab Driver: Microsoft dated 6/21/2006 version 6.1.7600.16385
Tab Details: Clicking up some of the properties bring up some value -- to many properties to list

Quote:
Since that drive already contains information, then it could have lost its partition(s).
I doubt is as copied from it a few days ago to do a new Windows 7 install

Quote:
you try to connect the drive internally?
As stated this is an IDE drive which has an IDE to Sata convertor. No IDE connector this board.
So whether Externally or Internally mounted doesn't matter.

Quote:
Additionally, check if you have all of your USB and chipset drivers.
Am running through a USB 3.0 which should also support USB 2.0. And USB 3.0 driver is installed.
Will try moving to USB 2.0 and post back unless you know why offline?
My System SpecsSystem Spec
17 Dec 2014   #6
CKWD

Windows 7 Home Premium x64
 
 

I assumed lost partition(s) as this is most often the cause for the problem you're having, or at least as I have seen, and it usually happens quite suddenly, today it's working – tomorrow it's not. So the new Windows install from a few days ago is not that big of a factor in this case. But then the disk would be given as Unallocated, not as Offline as it is yours.

Can you click on the spot where it says the disk is Offline, in Disk Management, does it have the option Online?

Cheers!

CK_WD
My System SpecsSystem Spec
17 Dec 2014   #7
dw85745

Win 7 Pro x32
 
 

Quote:
Can you click on the spot where it says the disk is Offline, in Disk Management, does it have the option Online?
Clicking the work "Offline" {I assume this is what you want} does not change it to "Online"

Quote:
Regarding Screen shots
-- did them in "*.bmp" format since smaller than jpg but see forum doesn't support.
If needed will convert.

==========================

QUESTION:

Will WD tools from CD allow me to see the drive and evaluate it since it is running through a USB and then the IDE {drive} to SATA {MOBO} convertor?

Had tried the other day to download the other WD tools but something was blocking the download.
With all this new security UEFI and UAC, not sure what the system is doing most of the time.
My System SpecsSystem Spec
17 Dec 2014   #8
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

Did you right click the area in Disk Management where Offline is displayed? It will preset a menu to allow setting it to online.
My System SpecsSystem Spec
17 Dec 2014   #9
CKWD

Windows 7 Home Premium x64
 
 

I did actually mean right clicking on the Offline drive in Disk Management, that's where the options usually are.
Sorry, perhaps I should've been more specific.
It should have the Online option.

If you don't have that option you could do the following:

1. Open an elevated command prompt
2. Type diskpart
3. In it type list disk
4. Then type select disk 1 and then enter
6. You should see Disk 1 is now the selected disk.
7. Now type online and enter

Well, the WD tools are there to work usually no matter how your drive's connected. But I doubt you'll be able to do something with them to make your drive visible again. There's a scanning tool, a back up tool etc., depends which you have.

Good luck!

CK_WD
My System SpecsSystem Spec
17 Dec 2014   #10
dw85745

Win 7 Pro x32
 
 

CKWD:

Thank you for staying with me on this.
Followed the CMD instructions

Shows Disk 0 Online
Disk 1 Offline

Shows: Disk 1 is now the selected disk.

After typing online I get:

Quote:
Microsoft DiskPart version 6.1.7601

DISK - Online a disk that is currently marked as offline
VOLUME -Online a volume that is currently marked as offline
Going into CP again and repopulating, the drive is still offline.

=======================
BTW I'm running the drives from the BIOS in legacy mode not UEFI when I followed your CMD instructions

QUESTIONS.
Will it make any difference?
Will updating the driver help since it is stamped "2006"

COMMENT
Maybe I need to move to a different OS. Had nothing but problems since upgrading from XP.



.
My System SpecsSystem Spec
Reply

 Second Hard Drive Not Appearing in Explorer




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Random Locked Files Appearing in Hard Drive?
Hey everyone, While I was updating my laptop using the Windows Update, I see a Locked file appear randomly in my 2nd Hard Drive (the one without the OS). I am not sure if it's from the Windows Update as it is installing, but I see it appear, and then disappear. There were two locked files...
General Discussion
Can't see hard drive or DVD drive in Computer or Windows Explorer
I reinstalled Windows 7 and everything went well. I can access the internal drive and the DVD drive through Open on Disk Management and a shortcut for the hard drive on the desktop that I created after the install but can't see the hard drive or the DVD drive in Computer or Windows Explorer. I...
Hardware & Devices
Hard Drive Memory disappearing and c:\END appearing in c drive
First, sorry if I'm a little slow with some of this as I'm moderate with my computer knowledge. Earlier today I had 517 gb of memory available in the C drive. I restarted my computer earlier today and once it restarted I saw I was down to 1.84 gb. I ran crap cleaner already and did a quick scan...
Performance & Maintenance
Hard Drive Suddenly appearing as "Unallocated Space"
I have been running a Dual-Boot Setup of XP Pro and WIN 7 successfully for some weeks while I get familiar with WIN 7. Recently I have almost exclusively been booting into WIN 7. In this D.B. Setup The booted OS appers as Primary Partition on the C: drive with the non-active OS as "Unallocated...
General Discussion
Hard Drive Disappears from Explorer
I have this problem regarding one of my hard drives. Every so often I lose access to it in Windows Explorer for no apparent reason. Also I have now put it in a caddy and if I pull the drive out and back in, I also lose the drive! Even if I click on 'Scan for Hardware Changes'. I don't know whether...
Hardware & Devices
2nd Hard drive not appearing...
It worked fine on Windows Vista. I just formated the first and installed Windows Seven on it. Now when loading up Seven, it says the 2nd is installed and working, but its not accessible and doesnt even appear. *FIXED* Finally found the search forum button -.-, sorry for the repost.
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App