Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Installed Secondary HDD, Screen Now Flickers on Startup

25 Feb 2015   #21
ItchyAlgae

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by TVeblen View Post
Quote   Quote: Originally Posted by ItchyAlgae View Post
I doubt it's the monitor. It did the same thing with the newer monitor last night.
Test 1: No, it takes quite a while to come up. It never used to.
Test 2: It comes on immediately.
Did you write that backwards? Because Test 1 result above shows a problem with the monitor.
If the PC is up and running and you can see the image on the monitor, then you turn off the monitor and wait for it to cool down, and it takes a long time to show that same image again when you turn the monitor back on - that's a problem with the monitor.

That's what I would have thought too, but it did the same thing with a brand new monitor (tests 1 and 2), which also flickered.


My System SpecsSystem Spec
.
25 Feb 2015   #22
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

The common factor is the cable. I assume HDMI? Have you tried a different cable?
My System SpecsSystem Spec
25 Feb 2015   #23
ItchyAlgae

Windows 7 Home Premium 64-bit
 
 

Thought of that one too. I tried a mix of old and new DVI and HDMI cables on both monitors and it didn't change anything.
My System SpecsSystem Spec
.

25 Feb 2015   #24
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Mmmm. Odd.

I suppose it could still be the video card (and/or driver) causing that. Just can't wrap my head around the "how".
My System SpecsSystem Spec
25 Feb 2015   #25
ItchyAlgae

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by TVeblen View Post
Well that narrows it down a bit to EITHER the graphics card or the graphics driver.

So let's try this. I"m going to have you do a 2-part clean install of the driver.
  • First, go to the AMD website and download the most current known good driver for your video card. Save the file where you can find it.
  • Next, go into Windows Explorer and in the (usually) C: drive find the Program Files > ATI folder (inside will be Drivers > and your driver version) and delete it (the whole folder).
  • Next, Go into Start > Control Panel > Remove a Program and uninstall all programs for the video card. Do the actual driver last. For AMD, you may be able to select “AMD Catalyst Install Manager” and click on “Change”, then “Uninstall All Components”.
  • Restart the computer.
  • When the computer reboots to the desktop Windows will install it's own generic WDDM1.1 driver and you will be asked to restart again. You must do so in order to install the new Drivers > Restart.
At this point you should run the computer with the Windows generic driver for a while. See if the flickering stops.

If it does, then you could try installing the newest AMD driver from your download.

Let's see what you find.

AMD Instructions > go to Windows 7 section:
How-To Uninstall AMD Catalyst Drivers From A Windows Based System

So I uninstalled everything through Catalyst Install Manager, deleted the AMD folders, and it asked me to restart. I did, the flickering was a little less pronounced but still there upon start up, and when it booted to the desktop it didn't do anything else. If it was installing generic drivers, it didn't alert me. It didn't ask me to restart again. I searched the system for WDDM1.1 but the system didn't find it.
My System SpecsSystem Spec
25 Feb 2015   #26
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

If the drivers completely uninstalled, and the generic Windows driver did not install, then you should be in VGA mode (poor resolution - 640x480) with no options for display on the desktop (just like Safe Mode).

If the desktop looks normal resolution then you have still got some driver installed.
Go to Device Manager > Display Adapters > and see what it lists for a graphics card. If the Windows driver is installed it will say WDDM1.1 there. If it says AMD then the original driver did not uninstall or reinstalled itself from a backup folder.

If you are in VGA mode you could go to Windows Update and see if Windows is offering you the generic driver there. That driver may have never been installed on your PC previously.

Otherwise, go ahead and install the AMD driver.
My System SpecsSystem Spec
25 Feb 2015   #27
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

I've got to leave now for meetings. I will check back to see what you've found later today.
My System SpecsSystem Spec
25 Feb 2015   #28
ItchyAlgae

Windows 7 Home Premium 64-bit
 
 

Here's what I've got. No WDDM1.1 but both an AMD and ATI driver listed. There's no option in Windows Update to download WDDM1.1 either. I also want to extend an in-progress thank-you to you and everyone else who's taken the time to help me out with this. Absolutely the right way to grow a real community here and I very much appreciate it.


Attached Thumbnails
Installed Secondary HDD, Screen Now Flickers on Startup-capture.jpg  
My System SpecsSystem Spec
25 Feb 2015   #29
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

When you go to Control Panel > Programs, do you see the AMD driver listed? Any AMD software?

Could I also see what is under that "Update Driver Software" window?

BTW - That window just says it recognizes a AMD Radeon 5800 Series video card. It's asking you if you want to find a driver to install for it.

Is your desktop VGA or normal?
My System SpecsSystem Spec
25 Feb 2015   #30
ItchyAlgae

Windows 7 Home Premium 64-bit
 
 

Nothing is up with that second one that says ATI Radeon HD 5800 Series? I thought it might mean something is redundant or duplicated where it shouldn't be, since AMD retired the ATI brand sometime after I bought my card
My System SpecsSystem Spec
Reply

 Installed Secondary HDD, Screen Now Flickers on Startup




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 Jumplist flickers and Chrome menu flickers
Hello, does anybody when clicking the bookmark arrow or a folder with bookmarks in chrome gets a small (i mean very fast!) black flickering??? Also in Windows 7 Jumplist sometimes when opening it will show aero glass before populating with icons (also very fast) Can someone check this out to...
General Discussion
BSOD 15 mins after startup. Screen flickers multicolours?!
Hi there, I really need some help getting to the bottom of an issue with my PC. About 15 minutes after switching it on it suddenly crashes, but instead of the monitor showing the BSOD it goes to a multi-coloured flickering type of static, as if it's having a fit or something. Really...
BSOD Help and Support
Desktop screen flickers and crashes
Been running Windows 7 32-bit for a while now with no problems. Yesterday though i've found that whenever I boot up the OS, the desktop screen flickers with little purple and green dots along the program bar at the bottom of the screen and on any icons. The main wallpaper does not. Everything...
BSOD Help and Support
just got new mobo but the screen flickers/flashes....
I just got an Asus M4A785-M mobo because my original mobo fried which is now being RMA'd back to Asus so they can send me a new one. However, the mobo I now have installed fine (i didnt reformat my HD when i installed this new mobo) but after trying new and old drivers, ALL windows updates and...
Drivers
Screen Flickers under Windows 7
Hello everyone, A buddy of mine is having a very strange issue that didn't appear in windows Vista... He is running an HP Pavilion Entertainment PC, Exact specs I can't get at this tiime, but I know he is running an Integrated Graphics Chip. The issue he is having is during gameplay, his...
Gaming
Screen flickers then minimizes.
1st post here and is a negative one :( Anyway, I'm running Sims 2 and Age of mythology of virtual drives. Whenever I start them I have to battle with the laptop to keep them open. When it starts loading it just flickers then minimizes, I then have to click it about 10-12 times before it...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App