Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Installed Secondary HDD, Screen Now Flickers on Startup

25 Feb 2015   #31
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

No, I don't think so. That is just the way the hardware ID is being seen by Windows.

See the Standard VGA Graphics Adapter? That is also the same video card, just being seen by the system as a generic video card.
Might be interesting to see what it offers up for a driver if you clicked next. Since you deleted the folders you can be assured it won't find those old drivers.


My System SpecsSystem Spec
.
26 Feb 2015   #32
ItchyAlgae

Windows 7 Home Premium 64-bit
 
 

Tried again. There's nothing AMD or ATI listed under Control Panel/Programs, but everything still looked normal after the restart. Under Device Manager it no longer says AMD Radeon... but it still lists ATI Radeon HD 5800 Series. When I clicked Next on ATI Radeon..., it said something to effect of "Drivers updated/loaded successfully."
My System SpecsSystem Spec
26 Feb 2015   #33
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Could you post a screenshot of Device Manager with the Display Adapters expanded?

Then another showing what is in the window when you right click on the Display Adapter > Properties > Driver TAB?
My System SpecsSystem Spec
.

26 Feb 2015   #34
ItchyAlgae

Windows 7 Home Premium 64-bit
 
 

Sure. The original and only hard drive died in December, so I bought a new one and did a clean install of Windows a couple of months ago


Attached Thumbnails
Installed Secondary HDD, Screen Now Flickers on Startup-capture.jpg  
My System SpecsSystem Spec
26 Feb 2015   #35
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Yeah, that is showing me that an ATI driver has been installed for that display adapter. If you did not install that manually then you have not achieved a true clean (Un)installation.
The adapter should say either "Standard VGA Graphics Adapter" or "Windows Adapter WDDM1.1" (or similar).

If you did not do it manually then that means that Windows is finding the driver and installing it automatically. For our purposes we do not want it doing that.

One thing you can check: Start > type: Device Installation Settings > click on that > select "No, Let me choose what to do", and then check "Never install driver software from Windows Update". (You can change this back to whatever you like later).

Then do a search in Windows Explorer to find any folder from ATI or AMD. Make note of their location. Then the next time you attempt the clean installation you can delete these before you start. Otherwise Windows will find them and install the old driver again.

Check to see if the ATI Driver is listed in the Programs removal list in Control Panel. If there is no CCC available, and no entries in the Programs uninstall folder, to do the clean install this time you will need to select the Display Adapter in Device Manager and uninstall it, then restart the computer. If you are asked to remove the driver also say Yes.
My System SpecsSystem Spec
26 Feb 2015   #36
ItchyAlgae

Windows 7 Home Premium 64-bit
 
 

Ok, so I set Device Installation Setings to "Never install driver software from Windows Update." I uninstalled through the Catalyst program. I searched for and deleted all AMD and ATI folders. I went back to Device Manager and uninstalled the "ATI Radeon HD 5800 Series" driver that still somehow remained. When I did, the screen flicked to 600x800 and said it needed to reboot. I did and everything seemed fine. No flickering on startup and it booted to a 600x800 screen. I downloaded the newest driver and Catalyst program from AMD. It said it needed to restart to take effect, so I clicked OK. When the computer rebooted to the (now 1920x1080) desktop, I got a ton of flickering.
My System SpecsSystem Spec
26 Feb 2015   #37
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Does not look good for that video card.

It seems that the card will function fine at low graphics and no load, but the minute you push it to run on the higher settings it is failing. Is it possible to borrow another video card just to test to see if it is indeed a bad card?

Keep in mind that a power problem could be the reason that the video card can not perform, so that part is not completely ruled out yet.

Did you ever get the generic Windows driver to load? It would be a good test to see if the card could work without flickering using a plain vanilla driver. I wonder why that driver is not being offered on your PC? It always has on the PCs I've worked on.
My System SpecsSystem Spec
26 Feb 2015   #38
ItchyAlgae

Windows 7 Home Premium 64-bit
 
 

The VGA driver? That one did load, 600x800 and everything and seemed to work fine. Anything labeled WDDM1.1, no, I haven't seen anything named that appear
My System SpecsSystem Spec
27 Feb 2015   #39
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

The standard VGA driver only runs at low resolution. The generic Windows driver I am talking about will run in normal resolution. It gives the card pretty much the same functionality as the AMD driver, just without all the higher end functions (for gaming) and the bells and whistles. It is a good test to try and determine whether the problem is actually the card or just the driver.

I think that it might come through Windows Update if you wait long enough while in VGA graphics (24 hours or so). But I can't be sure where it originally comes from. I thought it was native to the Windows installation, but I could be wrong about that.

Another thing people try is to find and download an older version of the AMD driver, under the assumption that the newest driver may be causing the problem and the older driver won't.
My System SpecsSystem Spec
Reply

 Installed Secondary HDD, Screen Now Flickers on Startup




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 Jumplist flickers and Chrome menu flickers
Hello, does anybody when clicking the bookmark arrow or a folder with bookmarks in chrome gets a small (i mean very fast!) black flickering??? Also in Windows 7 Jumplist sometimes when opening it will show aero glass before populating with icons (also very fast) Can someone check this out to...
General Discussion
BSOD 15 mins after startup. Screen flickers multicolours?!
Hi there, I really need some help getting to the bottom of an issue with my PC. About 15 minutes after switching it on it suddenly crashes, but instead of the monitor showing the BSOD it goes to a multi-coloured flickering type of static, as if it's having a fit or something. Really...
BSOD Help and Support
Desktop screen flickers and crashes
Been running Windows 7 32-bit for a while now with no problems. Yesterday though i've found that whenever I boot up the OS, the desktop screen flickers with little purple and green dots along the program bar at the bottom of the screen and on any icons. The main wallpaper does not. Everything...
BSOD Help and Support
just got new mobo but the screen flickers/flashes....
I just got an Asus M4A785-M mobo because my original mobo fried which is now being RMA'd back to Asus so they can send me a new one. However, the mobo I now have installed fine (i didnt reformat my HD when i installed this new mobo) but after trying new and old drivers, ALL windows updates and...
Drivers
Screen Flickers under Windows 7
Hello everyone, A buddy of mine is having a very strange issue that didn't appear in windows Vista... He is running an HP Pavilion Entertainment PC, Exact specs I can't get at this tiime, but I know he is running an Integrated Graphics Chip. The issue he is having is during gameplay, his...
Gaming
Screen flickers then minimizes.
1st post here and is a negative one :( Anyway, I'm running Sims 2 and Age of mythology of virtual drives. Whenever I start them I have to battle with the laptop to keep them open. When it starts loading it just flickers then minimizes, I then have to click it about 10-12 times before it...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App