Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New second hdd disappears after every reboot, appears after rescan

21 Jan 2015   #1
benjamin4

Windows 7 Home Premium 64bit
 
 
New second hdd disappears after every reboot, appears after rescan

Hi

Firstly my specs are

Windows 7 Home Premium 64bit
Intel Core 2 Quad Q8300 @ 2.5GHz
Foxconn G31MX motherboard
4 GB installed memory
The current hdd is a WDC WD7500AADS

The hdd i'm trying to add as an additional drive and having trouble with is WDC WD40EZRX

I have just installed a new Western Digital 4TB green internal sata hard drive on my windows 7 PC

The drive is always visible in BIOS but whenever I start the Windows the new hard drive doesnít show up in explorer or Disk Management. It will be visible in both after either scan for hardware changes in device manager or rescan in diskpart but when windows restarts I have to do this again for the drive to be visible. If I leave any data on the drive then once I have rescanned for the drive all the data is visible and intact.

Apparently this bug or similar issues are common in windows 7 but none of the potential solutions that have worked for other people have worked for me.

Other people seem to have a problem where the drive letter needs to be reassigned after reboot but for me once I have rescanned for the drive the drive letter I have previously assigned to drive persists and doesnít need to be reassigned. I donít know whether there is any relationship between these issues.

Iíve tried changing the sata port on the motherboard.

In diskpart hidden is set to no as is no default drive letter. I have tried setting volume to hidden and then changing back to not hidden.

I have tried a selection of drive letters.

Iíve tried formatting the drive again in windows.

Iíve tried Error checking the drive in windows and no problem was found.

I read that this might be a solution (http://support.microsoft.com/kb/978980) but it hasnít worked.

I have automount enabled.

I tried starting the computer in safe mode and the drive shows up. I then tried starting the computer with all non windows services turned off and the drive did not show up.

I've tried completely uninstalling my antivirus(AVG) and it didn't help.

I read in a couple of places that several people had had success solving this issue using a Western Digital utility to write zeros to start and end of the volume. Iíve tried this and it didnít work for me. Also although people who had tried it claimed that their data was inexplicably still intact on the drive my drive was erased and needed to be formatted after I tried this.

I have been into explorer>Organize>folder and search options>view> and unchecked hide empty drives in the computer folder.

I ran Microsoft Fix It and it said hardware changes might not have been detected, scanned for hardware changes, the drive appeared and it marked as fixed but the drive disappeared again after reboot

I tried making it a new volume and formatting on another computer and then moving it back to my computer but this hasnít worked. I had read that some people had fixed the problem by formatting the drive on an xp machine and then moving the drive back to their windows 7 machine. I donít have access to an xp machine but I used another 7 machine. Incidentally the drive showed up immediately and as expected when I plugged it into the other windows 7 computer.


I've spent over a week trying to find a solution to this and I can't find any more suggestions so I'd be extremely grateful if anyone could suggest a solution.

Thanks for reading
Ben


My System SpecsSystem Spec
.
22 Jan 2015   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello and welcome Ben mate the board is getting on a bit and I was going to suggest you update the drivers for the SATA and / or the chipset but the support site is very vague and my next thought was to run this
https://www.slimwareutilities.com/slimdrivers.php now if you use this utility then do it with caution because like a lot of these types of programs they do carry some clutterware - plus when you have used it then uninstall it. If you are unsure of which to update post back and ask - no one here bites LOL!!
By the way getting rid of AVG to me was a good move as I used it years ago and found it rather lacking and intrusive.

But for starters it would not hurt to run these
http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html
http://www.sevenforums.com/tutorials/433-disk-check.html < if necessary include the /f and /r in the command line as per Option2
http://www.superantispyware.com/
http://www.malwarebytes.org/products/malwarebytes_free/
http://www.bleepingcomputer.com/download/adwcleaner/
ADW download from bleeping computer delete any rubbish found with the malware scans

the first two are the most important the other three you can ignore if you don't think it is a malware problem. But if it were me I would as it takes very little time to use them and they are handy for future use.
My System SpecsSystem Spec
22 Jan 2015   #3
benjamin4

Windows 7 Home Premium 64bit
 
 

Hi ICIT2LOL, Thanks for your time.

I've run the System File Checker which said it had made some changes and I've run the 3 anti malware programs you suggested and removed everything that they flagged.

Unfortunately the problem still persists.

I've run Slimdrivers but wasn't sure which updates were relevant so I've posted some images so hopefully I can get some advice on which are likely to be useful.

I'm going to work soon so before I go I'll start disk check on my C drive.

Thanks again
Ben


Attached Thumbnails
New second hdd disappears after every reboot, appears after rescan-1.png   New second hdd disappears after every reboot, appears after rescan-2.png   New second hdd disappears after every reboot, appears after rescan-4.png  
Attached Images
New second hdd disappears after every reboot, appears after rescan-3.png 
My System SpecsSystem Spec
.

22 Jan 2015   #4
benjamin4

Windows 7 Home Premium 64bit
 
 

I ran disk check including /r and unfortunately it hasn't helped.

Ben
My System SpecsSystem Spec
22 Jan 2015   #5
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok Ben now in the returned pic I have marked the ones I would start with and when the Slim Drivers runs those updates just makes sure the Intel update ones go to the Intel site - it will appear as a black through to white pic of a road going ? somewhere and will have the official Intel logo too.

Try this mate and lets see what goes.


Attached Thumbnails
New second hdd disappears after every reboot, appears after rescan-slim-1.png  
My System SpecsSystem Spec
23 Jan 2015   #6
benjamin4

Windows 7 Home Premium 64bit
 
 

Thanks,

All up to date, when I updated one of the updates from System Devices they all updated so that was easy. Unfortunately no fix though.

Ben.
My System SpecsSystem Spec
23 Jan 2015   #7
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

That's ok then Ben I just take it you used the Windows feature which I am not great fan of I much prefer going to the manufacturers sites for them as Windows I think is a bit shallow.

If you used that Slim Drivers do get rid of it though otherwise it will pester the life out of you.

Anyway mate it is late and I must hit the sack and return tomorrow to take a another look.
John
My System SpecsSystem Spec
28 Jan 2015   #8
benjamin4

Windows 7 Home Premium 64bit
 
 

I seem to have solved this. I was trying another potential solution and changed On-chip serial ATA to enhanced mode in BIOS and this step seems to fixed the problem.

Just wanted to double check whether anyone could tell me if changing this setting was likely to cause me any further trouble.

Also thanks John for your time.

Ben.
My System SpecsSystem Spec
28 Jan 2015   #9
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

No worries Ben and you might like this too now you are up and running

Optimize Windows 7
My System SpecsSystem Spec
Reply

 New second hdd disappears after every reboot, appears after rescan




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Network adapter disappears after reboot
I just recently bought a gaming laptop to replace my custom tower since my job requires a bit more portability. I just installed the important windows updates and now my network adapter disappears after I restart my computer. there are a few seconds when my desktop appears where I can quickly hit...
Network & Sharing
right click menu appears for a second and disappears.
Hello all, windows 7 64 bit, when i highlight any text, and then right click to copy, i get a menu with, bing, google, translate, etc. It appears for one second and then my regular menu appears. I was suspicious it was from open office so i deleted that but the menu still appears. I...
General Discussion
Have to rescan drives almost all the time
Win 7, 3 SATA drives, 1 IDE drive, no restore points available :( Since about 2 weeks I have to refresh/rescan my HDs almost every time I boot. Unfortunately there is no pattern. Occasionally all partitions can be seen then there are times where I have to rescan using the Disk Management. ...
Hardware & Devices
Reboot and my default gateway IP disappears?
So every time I reboot. I have to change my gateway IP in my Network settings. It is getting so annoying can someone please help me? everything saves but not my gateway IP. And my router does have the latest full version on firewall. I didn't want to upload a beta. My old router worked...
Network & Sharing
command prompt appears then disappears
when i try to open a .bat file command prompt quickly opens and closes
General Discussion
DVD drive disappears while using it, reappears after reboot
Whether it's watching a movie or playing a game, it often stops and I can't see my drive in the system. After I restart the computer, it's back. I don't know if it has anything to do with it, but it first happened while I was playing TES III: Morrowind (vanilla), when it tried to load a...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App