Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Lexmark P3120 don't have a connection in XP mode

07 Nov 2009   #1
TheR

Windows 7 64-Bit Ultimate Edition
 
 
Lexmark P3120 don't have a connection in XP mode

Hello all!

I've a little problem with my All-In-One device P3120 from Lexmark. I've managed to install the device in XP mode, since I found out that there are no Windows 7 or Vista drivers available. The installing progress had finished without any problems and I can also use the scanner unit - but the printer don't print anything! I get always a message that the printer don't have a connection with the computer, but that's of course wrong.
I've tried also the newest XP driver from the Lexmark homepage, but the problem is still there.

Now I have the question to the community here: Have somebody else here the same device with the same problem and maybe found out a solution? Or some general tips to get the printer printing?

OS: Windows 7 64-Bit Ultimate Edition
Device: Lexmark P3120 (also called Lexmark 3100 Series in the device manager)

Thanks to all upcoming answers and I'm hoping that someone can help me with the problem!

Best regards, René


My System SpecsSystem Spec
.

07 Nov 2009   #2
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

I think when I had my lexmark it required me to install the driver then plug the printer in. Did you try this?
My System SpecsSystem Spec
09 Nov 2009   #3
TheR

Windows 7 64-Bit Ultimate Edition
 
 

Thanks for your answer, thefabe!
I tried your advice, but unfortuntly it didn't worked.

After all, I got the printer working.
In the device manager were three "Virtual PC Integration Device" devices with question marks as icons. First I thought, that this devices don't have to do anything with my printer, because the printer already shown up right in device manager.
So I just tried to install for all three devices the printer driver and after a restart, the printer worked.

I'm hoping that the solution is helpfully for others!

Thanks anyway, thefabe!

Best regards
My System SpecsSystem Spec
.


19 Nov 2010   #4
TechOutsider

Windows XP
 
 

Hi guys, I have exact same PrinTrio P3120 printer and I finally got it to work today.

This isn't a joke, and I'm a trusted member here at sevenforums - although I haven't been on for quite a while .

I got nothing here to promote, I have been looking for a solution since I downloaded and installed the first Windows 7 pre-beta version.

Here's how:


If you can't figure it out with all the pictures, your looking to untick "Enable advanced printing functions"

That's it.

Thanks, and report back if it works.
My System SpecsSystem Spec
20 Nov 2010   #5
TheR

Windows 7 64-Bit Ultimate Edition
 
 

Hi TechOutsider,

thank you for your answer!
Since I've got the device working in XP-mode, I'm happy with it. But a native solution would be awesome!

I can't try your solution, without Vista / W7 drivers, so which one did you install?

Best regards and thanks again!
My System SpecsSystem Spec
Reply

 Lexmark P3120 don't have a connection in XP mode




Thread Tools





Similar help and support threads
Thread Forum
XP Mode secure if no network connection?
I've seen a lot of discussion on how insecure an XP Mode VM will be now that MS security updates are no longer being released; MS themselves say on their installation page for Windows XP Mode: "Therefore, to keep your Windows 7 PC secure after support ends, we recommend that you only use Windows...
Virtualization
Internet Connection on Virtual PC XP Mode in Win 7
Hello Friends I have the latest (with all necessary updates) version of Virtual PC and XP Mode. I am running Windows 7 Enterprise. The XP virtual machine seems to work fine, except for the internet :( I tried the VPN connection, and tried the network adapter card, but still I can not get...
Virtualization
No Connection in Windows XP Mode
Hello There seems to be a problem with Windows XP Mode. I can't get it to connect to the Internet. I've tried it Full Screen with Integration enabled, with Intergration disabled, went to Tools and tried changing it's connection, but I still can't connect to the Internet via XP Mode. I don't...
Virtualization
XP Mode disconnects host wireless connection
I have Windows 7 Pro with XP Mode. When I start the virtual machine, my wireless connection disconnects. Rather, it remains connected except it reports that there is no internet connection. Shutting down the XP Mode virtual machine does not allow me to regain my internet connection. Repair...
Virtualization
No Internet Connection except in Safe Mode
Greetings, I purchased my new computer two weeks ago, and hooked up the same DSL modem from my old computer. Once I got the modem hooked up and connected to the internet, I immediately installed Kaspersky Anti-Virus (the six-months free anti-virus software that came with the computer). I...
Network & Sharing
VPN connection in XP mode
I've read several posts of others using the Cisco VPN Client in XP mode and are having success, hopefully someone can help point me in the right direction to solve my connection issues. I have Windows 7 64bit with XP mode installed. I installed the Cisco Client, version 4.8.xxxx. The VPN...
Virtualization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App