Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mouse freeze on some sites

19 Apr 2015   #1
kithra

Windows 7 Home Premium 32 bit
 
 
Mouse freeze on some sites

I run Windows 7 Home Premium 32 bit on my desktop, with a 5 button Trust mouse. And I use the latest version of Firefox.

On some sites, (e.g. Digital Spy - which I visit every day), the mouse can totally freeze and all I can do is a reboot to get the computer working properly again. It doesn't happen every time, and sometimes it also happens on other sites that I don't regularly visit. If it's going to happen it's often when I'm using CoolPreviews.

During this I cannot do anything as the mouse won't move. I can't even use Ctrl Alt Delete, Esc, or get to the Task Manager. All scans come back clean. Does anyone know what causes it, and how to get out of it?

Many thanks.


My System SpecsSystem Spec
.
20 Apr 2015   #2
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

Hello kithra, I will admit, I don't know the answer to your question. However it does sound like there are some driver conflicts with your mouse drivers and the web site you visit and the programs you are using. You may try and update the mouse drivers and if that does not work, consider getting a different brand of mouse.
My System SpecsSystem Spec
20 Apr 2015   #3
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

My mouse works fine on Digital Spy.
Logitech M705
My System SpecsSystem Spec
.

21 Apr 2015   #4
kithra

Windows 7 Home Premium 32 bit
 
 

Thanks for the replies. My mouse drivers are up to date. And I'm starting to think that I've just over-used the mouse. I often find I have to replace them more often than is "guaranteed." As for trying a different mouse I think I'll stick with the Trust brand. I've always used it and I like the way the 5-buttons are laid out. Visiting Digital Spy today I didn't have any problems at all. So I just wonder if some sites, like that one, are so bloated with stuff that it messes with my mouse.
My System SpecsSystem Spec
Reply

 Mouse freeze on some sites




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Mouse freeze
Hi all, just come back from my honymoon, overseas and i now have a problem i can't locate. My mouse keeps freezing, only for a few seconds at a time (very annoying). I can't go back to an earlier date by system restore as the earliest point is after i came back.. I have uninstalled mouse via...
General Discussion
Mouse Freeze on startup
When i start the computer i usually need to give between 1 and 5 restarts for the mouse to work. The keyboard ctrl+alt+delete,arrow keys,enter work,but the alt+tab i saw it didn't work. No potential harmful applications running at start(not in startup folder/msconfig/registry). Tried disabling...
Hardware & Devices
Mouse freeze - shut down freeze - BSOD
Hi! My not very technical brother bought a brand new ASUS G74S laptop a week ago. Two BSODs have occured since. First time: All we had done was changing the anti virus program in to avast! and installing all Windows updates. When my brother started Windows Media Player, it hanged during the...
BSOD Help and Support
mouse lag/freeze
every time i move my mouse, my mouse will freeze for few sec. Also while it' freezes, the plug and play sound is played. info logitec 518mx gaming mouse
General Discussion
Problem with left mouse button on web-sites
When I'm on-line, in order to open a link or file, I have to use the right mouse button and then select "open" from the menu to access the link or file. This just started happening recently. I also can't check boxes on forms on-line either. I have Windows 7 on-board, I've restored my system, but...
BSOD Help and Support
USB Mouse Freeze Issues
I've read through various other similar threads, but unfortunately none seem to have a definitive solution, so I apologize if this thread is repetitious. I recently built a new computer (build date 09/2009). The computer ran fine with my initial build using Vista 64-bit. Last week, I...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:40.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App