Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Ports not functioning properly

09 May 2015   #1
Riff88

Microsoft Windows 7 Professional 32-bit 7601 Multiprocessor Free Service Pack 1
 
 
USB Ports not functioning properly

Hi there,

I have a Toshiba Laptop 1.86Ghz with Windows 7, 32-bit with 2 GB ram.

I recently had a new CPU installed in my computer. When I got my PC back, my 2 USB ports donít function properly anymore.

The main problem seems to be with my USB Internet modem. (HUWAEI Mobile Connect)

Firstly I checked that the Modem works fine on other computers. I have all the latest drivers installed on my laptop for this modem.

What happens is the following: I put my modem into USB slot 1, and it works for 5 minutes, then disconnects on its own. Then it would work for 30 minutes, and then disconnect on its own, etc.

Worst happens when I put it in USB slot 2, it only connects for a few seconds, then disconnects.

I also cannot put any other items such as a USB memory stick or USB cable into one USB port while the Modem is in another slot. It simply doesn't function.

IN SHORT, I can only use one USB port at a time if I use my Internet Modem, and then my Internet Modem doesnít even function properly. I can however, use both USB ports if I use other items such as a memory stick or USB cable for printer, other devices. Then the USB porst work fine.

Any help is appreciated. THank You!


My System SpecsSystem Spec
.
09 May 2015   #2
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

You were asked a long time ago to fill in your specs and you still haven't.

Laptop screen freezes constantly / screensaver doesn't run

We need your system specs.

System Info - See Your System Specs

Your system specs now are this; which tell us nothing.
Quote:
OS don't know
My System SpecsSystem Spec
10 May 2015   #3
Riff88

Microsoft Windows 7 Professional 32-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Layback Bear View Post
You were asked a long time ago to fill in your specs and you still haven't.

Laptop screen freezes constantly / screensaver doesn't run

We need your system specs.

System Info - See Your System Specs

Your system specs now are this; which tell us nothing.
Quote:
OS don't know
Apologies for that. I updated most of my System Specs. Just don't know where to find the PSU, CASE and COOLING information.
My System SpecsSystem Spec
.

11 May 2015   #4
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

We're the closet drivers installed for the new CPU? Open Device Manager and expand the Universal Serial Bus section to see if there are any there. Post a screenshot of Device Manager with the USB section expanded.
My System SpecsSystem Spec
12 May 2015   #5
Riff88

Microsoft Windows 7 Professional 32-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Boozad View Post
We're the closet drivers installed for the new CPU? Open Device Manager and expand the Universal Serial Bus section to see if there are any there. Post a screenshot of Device Manager with the USB section expanded.
I honestly don't know. I have no way of getting in contact with the guys who installed the CPU.

My System SpecsSystem Spec
12 May 2015   #6
GokAy

Windows 7 Ultimate x64 SP1
 
 

Hey, your picture doesn't display.

Follow Screenshots and Files - Upload and Post in Seven Forums please.
My System SpecsSystem Spec
12 May 2015   #7
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

My last post was meant to say chipset drivers not closet drivers. iPhone autocorrect strikes again.
My System SpecsSystem Spec
13 May 2015   #8
Riff88

Microsoft Windows 7 Professional 32-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by gokay View Post
hey, your picture doesn't display.

Follow Screenshots and Files - Upload and Post in Seven Forums please.
USB Ports not functioning properly-device-manager.jpg


My System SpecsSystem Spec
15 May 2015   #9
Riff88

Microsoft Windows 7 Professional 32-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Boozad View Post
My last post was meant to say chipset drivers not closet drivers. iPhone autocorrect strikes again.
Yes, it is the 965 Express Chipset family from Mobile Intel. They are correctly installed.
My System SpecsSystem Spec
Reply

 USB Ports not functioning properly




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
AMD Graphics Card is not functioning properly error
So, recently i downloaded the latest Catalyst Driver (14.12) from the AMD website Desktop But after installing it and rebooted my PC, my monitor's resolution became smaller (like 800x600 something) and an error showed up "No AMD graphics driver installed or the AMD driver is not functioning...
Graphic Cards
Acer laptop keyboard not functioning properly
Hi, We have Windows 7 64 bit with an Acer older laptop. We are not sure what we did but our keyboard has changed in that we cannot use Ctrl + C to copy or Ctrl + V for paste and other functions. Also our mouse pad does not work anymore. We are using an external USB keyboard and it works fine...
Hardware & Devices
E8600 not functioning properly, I think.
I jus took out my E8200 2.6 and dropped in a E8600 3.33 This is what it`s showing in CPU-z. Whay isn`t the core spedd at 3333 ? The fsb is at the stock 1333, is something wrong , here ? Thanks
Hardware & Devices
Laptop Graphics Card not functioning properly?
I am not really good with computers, I know something is wrong but not really sure how to fix it I use Windows 7 Ultimate with a dedicated graphics card 2GB GDDR5 AMD Radeon HD 7970M and a intergrated graphics card Intel HD Graphics 4000 installed in my laptop I used to be able to play Total...
Graphic Cards
themes are not functioning properly.
hi, i recently decided to use themes again. for some reason i cant install any custom theme properly. whenever i install it, the background, right click menu etc work except the boarders on any open window and my taskbar(toolbar). i noticed the taskbar tool bar stays on classic. additional...
Themes and Styles
Stereo Mix not functioning properly in Win7
OK, so I've got a Conexant sound card, a CX20671, and since Microsoft removed the StereoMix from W7, I used a tweak which would let me use it again. The thing is, it works fine, but it's awfully quiet (It's almost inaudible). How can I fix this? Thanks for the help!
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:54.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App