Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Segate usb external drive not detected at startup

21 May 2015   #1
wokka

Windows 7 PRO
 
 
Segate usb external drive not detected at startup

If i plugin the drive it is detected by win7 and everything works. However next time i start the pc the drive isn't detected any more. I then have to unplug the drive do a re start and plug in again and the drive will be detected. However this is a pain to do each time. The Renesas electronic s usb 3.0 root hub is always missing from the device manager on start up. I have tried everything to fix and updating the driver for the usb but no luck. Also if i do a re boot while the drive is still plug in it will take longer for the windows to load even though the drive isn't still detected.


My System SpecsSystem Spec
.
21 May 2015   #2
GokAy

Windows 7 Ultimate x64 SP1
 
 

Hmm, on my motherboard usb 3 is not native and like yours it uses renesas drivers. It is possible that it needs the windows drivers to load before being able to detect. (just a guess here)

Would it get detected if you scan for hardware changes in device manager? Try that please.
My System SpecsSystem Spec
21 May 2015   #3
wokka

Windows 7 PRO
 
 

Quote   Quote: Originally Posted by GokAy View Post
Hmm, on my motherboard usb 3 is not native and like yours it uses renesas drivers. It is possible that it needs the windows drivers to load before being able to detect. (just a guess here)

Would it get detected if you scan for hardware changes in device manager? Try that please.
No it doesn't get detctecd when i scan for hardware changes.
My System SpecsSystem Spec
.

21 May 2015   #4
GokAy

Windows 7 Ultimate x64 SP1
 
 

Ok, couple of others

I guess the root hub is missing only when drive is plugged in?

- Would it work after a restart if it is connected to the usb 2 port?
- Do you have any other usb3 stick/harddisk?
- Tried the other port?
My System SpecsSystem Spec
21 May 2015   #5
wokka

Windows 7 PRO
 
 

Quote   Quote: Originally Posted by GokAy View Post
Ok, couple of others

I guess the root hub is missing only when drive is plugged in?

- Would it work after a restart if it is connected to the usb 2 port?
- Do you have any other usb3 stick/harddisk?
- Tried the other port?
Same problem with port 2. USB sticks work with out any problems. It seems that Seagate is for some reason dropping out the usb driver.
My System SpecsSystem Spec
Reply

 Segate usb external drive not detected at startup




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
External Hard Drive Not Detected
I have a western digital mybook (WD5000C032-002) that for some reason is not being detected by Windows 7 RC. It is a USB connection straight from the mybook to one of the motherboard's usb ports. All my device drivers are up-to-date. If I go into "Devices and Printers" and click on "Add a...
Hardware & Devices
External Hard Drive not Detected
I have a small 50gb HHD powered from USB It will connect to my laptop running windows 7 home premium but not my pc running windows 7 professional When plugged into my pc by usb the Disk does not power up and spin (the light does come on) There is no recognition of it in my computer, device...
Hardware & Devices
External hard drive not detected---again
I have an 1T external drive plugged into esata port. It used to work and now it doesn't? When I boot up bios correctly identifies the drive as a seagate sata drive. When I look at device manager is says its a seagate SCSI drive and therefore the system doesn't recognize it at all? In device manager...
Hardware & Devices
External hard drive not detected
Hi guys, My computer cannot detect my 250GB external hard drive and I'm having a hard time fixing this issue, and I've been searching for the problem to be fixed in the internet, unfortunately nothing was found. Before this issue happened, there was no problem, it was working fine until I did...
Hardware & Devices
External hard drive not being detected
Hi, I have been using my Iomega HDD for a while now and have never had any problems before today. It worked fine when connected to my Acer Netbook running windows 7 starter 32 bit. I connected to a friends laptop and it said to access it it must be formatted, so i bought it home and it said the...
Hardware & Devices
windows 7 doesnt like my segate drive
when i have my drive plugged into my computer multiple things happen, A: trnd micro will be picky about their auto run services, B: my computer periodicaly wont hut down, it will stay on the "shutting down" screen for hours on end, and C: my computer says the device is working properly but when i...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App