Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Devices and Printers Icons won't update

29 May 2015   #11
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Could you post a shot please.

I just love my PC icon




Attached Images
Devices and Printers Icons won't update-capture.jpg 
My System SpecsSystem Spec
.
29 May 2015   #12
elbeasto

Windows 7 Home Premium x64
 
 

I get that icon when I install the driver from the CD but not when I install the driver from the Asus website.

but yeah I'll post a screenie later.
My System SpecsSystem Spec
29 May 2015   #13
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

What driver, chipset ?

I`d really like to fix it, only thing wrong with my install. Weirdest thing I`ve ever seen
My System SpecsSystem Spec
.

29 May 2015   #14
elbeasto

Windows 7 Home Premium x64
 
 

That icon comes from the Asus Probe II driver, in device manager it's listed as "AMDA00 Interface" in the System Devices section.

Since you posted I tried again to get the website driver icon to work since it's newer than the one on the CD & I did!

Download the driver, extract it and run the installer. The file needed is in the extracted stuff but doesn't get copied during the install for some reason.

Look in the "Metadata" folder of the extracted driver and then copy the .devicemetadata-ms file to: C:\ProgramData\Microsoft\Windows\DeviceMetadataStore\en-US

and bingo.

The file name for me is: dbd4d4a2-c08c-46ea-9996-57094e1547ac.devicemetadata-ms but it might be different for your board, not sure on that one.

For me the mouse, receiver and AverTV worked out of the box. The Dell monitor, keyboard and PC didn't. The Keyboard was weird since the receiver, mouse and keyboard are all in the same Logitech driver!
But anyway I have mine showing now.

All this used to work automagically so IDK WTF it doesn't now...

EDIT: that probe II driver is really hard to uninstall if you ever want to, there's no uninstaller in Programs and Features and it installs services that are always running. I only think you need it if you're using their AI Suite software.


Attached Thumbnails
Devices and Printers Icons won't update-d-picons.png  
My System SpecsSystem Spec
29 May 2015   #15
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Device Manager also shows 2 mice and 2 keyboards. Puzzling

I also have that AMDA00 Interface listed.


Attached Thumbnails
Devices and Printers Icons won't update-capture1.jpg  
Attached Images
Devices and Printers Icons won't update-capture.jpg 
My System SpecsSystem Spec
29 May 2015   #16
GokAy

Windows 7 Ultimate x64 SP1
 
 

Those should be different devices, although 1 physical mouse.

In Device Manager
On my system there are 3. Properties show: Location:
- on Logitech Gaming Virtual Mouse (HID-compliant mouse)
- on Logitech Virtual Hid Device (HID-compliant mouse)
- on USB Input Device (Logitech HID-compliant G500 Gaming Mouse)

Got 5 keyboards - HID Keyboard Device

In Devices
4 Keyboards
3 Mouse
My System SpecsSystem Spec
29 May 2015   #17
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

That`s it I`m going back to Windows XP
My System SpecsSystem Spec
30 May 2015   #18
elbeasto

Windows 7 Home Premium x64
 
 

I wonder if you could extract the driver for those devices and copy the .devicemetadata-ms file to: C:\ProgramData\Microsoft\Windows\DeviceMetadataStore\en-US like I did with the Asus blue cude.
My System SpecsSystem Spec
30 May 2015   #19
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

I never installed the Probe 2 driver, so it`s not from that.

I just did an install on an Intel ssd, changed device configuration to get realistic icons, got all the drivers directly from Asus, no windows updates and it still put just a blue cube there.

Ran windows update fully, still a blue cube

I did exactly what you instructed, but that metadata file is already listed there.
My System SpecsSystem Spec
30 May 2015   #20
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Nothing like that here.

Devices and Printers Icons won't update-capture.jpg


My System SpecsSystem Spec
Reply

 Devices and Printers Icons won't update




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Devices and Printers - Change Device Icons with Custom Icons
How to Change Icons in "Devices and Printers" with Custom Icons This tutorial will cover how to change the icons in Devices and Printers with a custom icon of your choosing and be device specific, eliminating resource hacking and/or overwriting Windows 7 default icons. You'll need to be...
Tutorials
Devices and Printers icons (Device Stage)
Hi everybody. Quick question. Are the icons in the Devices and Printers window (Device Stage) replaced immediately upon any system update, or do they just show up and get replaced at random whenever Win7 feels like doing it? I recently did a fresh install of Win7 on two different...
General Discussion
Devices and Printers Icons
As you can see fromt he attachments. The icon for the webcam, monitor, Keyboard use to look like the real thing. now it shows some generic icons, how can I change it or restore it back to the better icons? Also you can see I have two mice and keyboards showing up. This only happened when I...
Hardware & Devices
changing devices and printers Icons..
Hiya, have created my custom icon librarys, opened DDores.dll with Anolis.Resourcer 0.8.8 an found the icons i wish to replace but it wont change the icons.. help please..
Customization
Customizing Devices and Printers icons
I want to be able to customize icons that appear in Devices and Printers. I also want to hide or reclassify some of the items appearing there. I want to customize how icons appear without modifying the DDores.dll which holds all the generic device images. I am well aware of...
Customization
Devices and Printers Icons
Hi guys, I have noticed that half of the icons under Devices and Printers have vanished http://imgur.com/fwThQ.png I have the 'yes automatically' option clicked in this option screen http://www.sevenforums.com/attachments/tutorials/3533d1241331630-device-installation-settings-settings.jpg ...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App