Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: AKASA AK-ICR-08 (usb hub) - device not recognized

17 Jun 2015   #1
playandwin

Windows 7 64bit PRO
 
 
AKASA AK-ICR-08 (usb hub) - device not recognized

Hello,

I bought this USB hub for 5.25". I connected it with front USB input on motherboard.



Everything seems to be working ,but

When I connect first usb device , it is automatically recognised by windows.
However then I connect second usb device and this device is not recognised ,even if I manually set drivers path then it is still same.

So only one of 5 USB ports is really working at same time.

I would like to use all 5 USB ports. Does anyone have any advice what to do ?


My System SpecsSystem Spec
.
17 Jun 2015   #2
GokAy

Windows 7 Ultimate x64 SP1
 
 

AKASA INTERCONNECT AC-ICR-08 INSTALLATION MANUAL Pdf Download.

Did you connect the power plug?

The right most port is being marked as pass through to motherboard, no idea what that means. Are you connecting the first to that one?
My System SpecsSystem Spec
18 Jun 2015   #3
playandwin

Windows 7 64bit PRO
 
 

Quote   Quote: Originally Posted by GokAy View Post
AKASA INTERCONNECT AC-ICR-08 INSTALLATION MANUAL Pdf Download.

Did you connect the power plug?

The right most port is being marked as pass through to motherboard, no idea what that means. Are you connecting the first to that one?
Hello,

Yes I connected power plug:


And yes I connect first device to first USB port from right. And then to other devices to other USB ports that are markrked as "pass through"
.
My System SpecsSystem Spec
.

18 Jun 2015   #4
GokAy

Windows 7 Ultimate x64 SP1
 
 

The pass through port may be disabling the hub of Akasa, please try using the 4 other ports. Keep right most port free. Only the right most is pass through according to manual.
My System SpecsSystem Spec
18 Jun 2015   #5
playandwin

Windows 7 64bit PRO
 
 

Quote   Quote: Originally Posted by GokAy View Post
The pass through port may be disabling the hub of Akasa, please try using the 4 other ports. Keep right most port free. Only the right most is pass through according to manual.

Hello,

I tried to connect device to other USB expect most right one, but still same no driver found for any device.
My System SpecsSystem Spec
18 Jun 2015   #6
GokAy

Windows 7 Ultimate x64 SP1
 
 

Do you have another internal USB port that you can connect Akasa cable to? Are you sure device is getting powered? Any lights/LEDs to confirm? Sometimes molex pins come lose while trying to connect. Try another molex power if possible.
My System SpecsSystem Spec
Reply

 AKASA AK-ICR-08 (usb hub) - device not recognized




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
USB device not recognized - Help!
I'm recieving the following error "USB device not recognized". I have attempted many fix recommendations I have seen posted aroun the internet with no luck. My usb ports were working fine previously with xp and vista installed on my system. I installed windows 7 and they were working fine until the...
Drivers
USB device not recognized.
I'm pretty sure that it isn't the first subject about it, but I didn't find any threads wich looked like mine, so I'm doing a new one. Yesterday, I was browsing the Internet like everyday of the week, and my mouse stopped working, for no reason. It just does the "tadam" (sound wich is done when we...
Hardware & Devices
USB Device not recognized
:cry: plz see attached file, i have to bear the notification sound continuosly, i have tried uninstalling and reinstalling, updating but still problem not resolved.
Hardware & Devices
USB device not recognized - but there is no usb device connected
It's recognized in device manager as "Unknown device". But I've not connected anything to pc. Also all of my usb ports are working at 1.1 speed. When I try to connect any device, I get the message "that it could work faster, if i connect it to hi-speed usb port". Any suggestions?
Hardware & Devices
USB Device not recognized
Hey all, I'm running win 7 64bit on a P6X58D premium mobo I just build the computer and had a brand new SSD that i loaded windows onto. now none of my USB stuff will work mouse/keyboard/thumbdrives/anything none of them work, but when I plug them in windows detects them and just goes...
Hardware & Devices
USB Device Not Recognized
Hi guys!! I've been meaning to ask some help regarding the issue that I am having however I was reluctant because of the fact that I fix computers for a living(I'm not that good at it though..:(). I need help!! I've been getting "USB device not recognized". I got the issue after...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:13.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App