Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Drives will not connect to USB3 host controller

16 Jul 2015   #1
fractaL

Windows XP SP2 (upgrading to W7)
 
 
Drives will not connect to USB3 host controller

I just got a new Dell Precision T7810 at work. When I plug in USB3.0 external hard drives to the SS USB 3.0 ports, they connect as USB2, and get the balloon popup "This device can perform faster". I have tried everything - uninstalling and re-installing the latest USB3.0 controller drivers and chipset drivers (from both Dell and Intel), using ports in the front and back, unplugging all other USB hardware, with no luck. I am confirming the drives are connecting in USB2 mode with USBTreeView software. The drives connect as USB3.0 on my laptop (also confirmed with USBTreeView).

I am running Windows 7 64-bit Enterprise.

Any help would be appreciated.


My System SpecsSystem Spec
.
16 Jul 2015   #2
GokAy

Windows 7 Ultimate x64 SP1
 
 

Tried a USB 3.0 port (blue ones) at the back of the PC yet?
My System SpecsSystem Spec
16 Jul 2015   #3
fractaL

Windows XP SP2 (upgrading to W7)
 
 

Quote   Quote: Originally Posted by GokAy View Post
Tried a USB 3.0 port (blue ones) at the back of the PC yet?
Yes, every single one, with no other devices attached, while monitoring the USB tree in USBTreeView. The drive gets put on the regular USB Root Hub every time. I can see the USB3.0 tree, but nothing ever connects to it.
My System SpecsSystem Spec
.

16 Jul 2015   #4
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Which version of the eXtensible Host Controller driver do you have installed?
My System SpecsSystem Spec
16 Jul 2015   #5
fractaL

Windows XP SP2 (upgrading to W7)
 
 

Quote   Quote: Originally Posted by Boozad View Post
Which version of the eXtensible Host Controller driver do you have installed?
3.0.5.69, dated 3/23/2015. Downloaded from Intel. The one available from Dell is a little older, and has the same problem. No yellow triangles anywhere in device manager, all devices are "working properly".
My System SpecsSystem Spec
16 Jul 2015   #6
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Is the firmware up to date?
My System SpecsSystem Spec
16 Jul 2015   #7
fractaL

Windows XP SP2 (upgrading to W7)
 
 

Quote   Quote: Originally Posted by Boozad View Post
Is the firmware up to date?
That I don't know. How do I check? Where is the new firmware available for download? Thanks for the help.
My System SpecsSystem Spec
16 Jul 2015   #8
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

I've been looking at the Dell support page for that model and there doesn't seem to be a firmware update that I can find to be honest. Have you uninstalled the XHCI through Device Manager and let Windows find a driver? Sometimes this can work (any peripherals won't work until the drivers are installed after rebooting of course), I know I tried it when I had trouble with my XHCI when I first bought my PC, I'm racking my brains trying to remember how I fixed it.
My System SpecsSystem Spec
16 Jul 2015   #9
fractaL

Windows XP SP2 (upgrading to W7)
 
 

Quote   Quote: Originally Posted by Boozad View Post
I've been looking at the Dell support page for that model and there doesn't seem to be a firmware update that I can find to be honest. Have you uninstalled the XHCI through Device Manager and let Windows find a driver? Sometimes this can work (any peripherals won't work until the drivers are installed after rebooting of course), I know I tried it when I had trouble with my XHCI when I first bought my PC, I'm racking my brains trying to remember how I fixed it.
I did try that, it installs as XCHI PCI Bus Host Controller, or something similar. It installs fine, with no yellow triangles, working properly, but has the same issue.
My System SpecsSystem Spec
16 Jul 2015   #10
Pauly

Win7 Ultimate X64
 
 

Have you tried any other USB3 devices, I have similar problems with particular flash drives and not with others
My System SpecsSystem Spec
Reply

 Drives will not connect to USB3 host controller




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Updating USB3 controller driver
I tried to update my USB3 controller to the latest level of driver, using the update from the ASUS site for my motherboard (as recommended by the supplier of my PC). The install was an Intel program, which left me without a driver for my mouse/keyboard, requiring a System Restore... Is it a good...
Drivers
USB 3.0 Host Controller Not Found
I know this is a well documented situation and I have seen and read a lot of information about the problems others have had with the USB 3.0 Host controller. My situation is that I have followed several different solutions only to wind up with USB's on the 3.0 hub not working after reboot. I have...
Drivers
USB3.0 Hard Drives Keep Self Ejecting
Hey guys. I am having the weirdest problem. I tried "Googling" for solutions to no avail. Even searched this forum. My USB3.0 Hard Drives keep self ejecting. Now let me elaborate on my problem. I own 2 USB3.0 external drives, one is an Apacer 500gb drive the other is a WD elements 2tb...
Hardware & Devices
The mysterious case of the dissapearing USB3 external drives ...
G'day, I've spent the past few days tryng to help a friend sort out a mysterious case of dissapearing USB3 external drives, but it has me stumped. Computer: LGA1155 Gigabyte GAZ68A-D3H-B3 Rev 1.0 motherboard with latest F13 BIOS Etron EJ168 USB3.0 chip with 2nd from latest driver (version...
Hardware & Devices
USB3 Drives don't work
I put in a SSD drive and now my two USB3 drives don’t work. I hook up the 2 USB3 drives and installed the drivers and one work for a little while but the other wouldn’t work at all. With the other hard drive I had in before that my Windows 7 was on both USB3 drives work just find. I called up...
Hardware & Devices
USB 3.0 host controller not found
Yesterday, my usb 3.0 host controller seems to have stopped working. I have tried enabling/disabling controller from BIOS, reinstalling drivers, finding different drivers, and reinstalling my mobo CD, but to no avail. (Yes, i already tried searching). It does not show up in windows device...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:26.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App