Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: How can I disable "autostart" from ALL external devices?

01 Sep 2015   #1
SJLPHI

W7 Pro 64 and 32 bit, 2 laptops
 
 
How can I disable "autostart" from ALL external devices?

Hello,

I am EXTREMELY annoyed after using W7Pro for few years and everytime I plug in a USB HDD, flashdrive, DVD or etc. Windows prompting me asking me for actions.

I even tried to use the GODMODE to disable it but no luck.

Any idea what else I can do?




Attached Thumbnails
How can I disable "autostart" from ALL external devices?-up.jpg  
My System SpecsSystem Spec
.
01 Sep 2015   #2
carwiz

Windows 7 Pro-x64
 
 

Uncheck "Use Autoplay for all devices" at the top of your example page. (You don't show it.)

This will allow you to set individual devices.


Attached Thumbnails
How can I disable "autostart" from ALL external devices?-auto-play2.jpg  
My System SpecsSystem Spec
02 Sep 2015   #3
SJLPHI

W7 Pro 64 and 32 bit, 2 laptops
 
 

Hello,

I've just tried that, no dice. It still prompts me for scanning to "fix" the external drives and also asks me what to do with it after
My System SpecsSystem Spec
.

02 Sep 2015   #4
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
You will always get that prompt if you don't disconnect the drive properly
Mostly win-8-8.1 & 10 will cause it because of fast start/ really fake shut down features that are mostly Hibernation.

Personally in window 7 and earlier I would completely shut down then disconnect a external or internal drive or use safely remove device which doesn't always list external drives.
My System SpecsSystem Spec
02 Sep 2015   #5
carwiz

Windows 7 Pro-x64
 
 

Yeah, the "fix" is a totally different problem. Insert a CD and see what AutoPlay does. You did click Save after changing auto play options, right?
My System SpecsSystem Spec
03 Sep 2015   #6
SJLPHI

W7 Pro 64 and 32 bit, 2 laptops
 
 

I did save it, it now seems to have stopped prompting me for auto play.

Now, how shall I fix the "fix" prompt?

I share external HDD, flashdrives and SD cards from a linux computer to W7 computer, I ALWAYS get asked if I want to "fix" my external storage.
My System SpecsSystem Spec
03 Sep 2015   #7
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi
I can't remember where the setting in Linux is but look for auto mounting of drives and disable it.
My System SpecsSystem Spec
03 Sep 2015   #8
SJLPHI

W7 Pro 64 and 32 bit, 2 laptops
 
 

well this worked:
Disable Scan and Fix for Removable Drives in Windows

for scan and fix, linux, depending on distro, by default, it doesn't prompt me anything. I actually prefer and allow it to show me on my "alert" because it doesn't show up in the middle of the screen and active, because if it were in the middle (as in Windows 7) I end up clicking on something/pressing enter without knowing it. I once "fixed" and entire 500GB of data of a back up HDD, needless to say, I was grumpy re-downloading everything from cloud servers.
My System SpecsSystem Spec
03 Sep 2015   #9
SJLPHI

W7 Pro 64 and 32 bit, 2 laptops
 
 

well scan and fix removal drives worked for flash drives,
but not external HDD.
My System SpecsSystem Spec
03 Sep 2015   #10
carwiz

Windows 7 Pro-x64
 
 

How did you initially format the devices--On Windows or Linux? What file system--FAT32 or NTFS?

I'm not familiar with Linux but doesn't it have a different file system and need a special driver to support NTFS?

Also, keep in mind the file limits for FAT32.
My System SpecsSystem Spec
Reply

 How can I disable "autostart" from ALL external devices?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
WD EXTERNAL HARD DISK 1TB suddenly "unallocated" and "not initialized"
Hi guys. I'm new here. I've tried to read all the discussion about how to fix the unallocated hard drive but I just can't understand it as the cases were pretty much different than I'm facing of. Here's my problem. Yesterday my external hard drive seems normal, everything is fine, until...
Hardware & Devices
Can't ID driverless devices "Base System Device" and "Broadcom USH"
There are 2 devices in the "Device Manager" that do not have drivers installed. I just did a clean install of Window 7 SP1 32-bit to a Dell Latitude E6500. I have uploaded all the Windows updates and all seems to be performing well. However, there are two devices in the "device manager" that do...
Drivers
Hiding unused "removable storage" devices from "Computer" folder
Not a major issue, of course, purely cosmetic, but still a minor annoyance none-the-less: I have a number of card reader drives that I never use (haven't even removed that plastic cover tape from them to help keep the dust out) that show when viewing the "Computer" window that displays drives. ...
Customization
Both "System reserved" and "C" partition cloned to external HDD: boot?
With EaseUS Backup Tool, I've cloned these two partitions ("System Reserved" and "C") to same-sized partitions on a external HDD ("X" and "Y"). Picture tells it concisely: How to make drives "X" and "Y" boot-able? In "Disk Management", I've noticed these partition labels missing: "X" (or...
Installation & Setup
Windows Event Log causing "win403700" to autostart at boot
Hello. I'm having a peculiar problem that just started yesterday out of the blue. Suddenly when I boot up in Windows 7 (64-bit), there's always an open dat file titled "win403700" that greets me on my desktop. It's of no use to me, since it's filled with lines and lines of code that are...
Performance & Maintenance
change start menu icons "devices and printers" and "recorded tv"
Hello Ive managed to change all the icons on my system to custom ones apart from devices and printers and recorded tv on the right of the start menu.(the ones that appear over your user picture when you hover over them) Ive searched everywhere for their location in the registry but cant find them...
Customization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App