Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Secondary hard drive vanishing

05 Sep 2015   #1
IronWill98

Win 7
 
 
Secondary hard drive vanishing

Hey, so after installing my second hard drive, it likes to vanish. It isn't in My Computer or under Device Manager anymore. It seems to vanish during use and restarting usually fixes it, but its getting quite annoying having files corrupted because of it. Any clues why this is happening/how to fix it? Switching cables/ports does not help.


My System SpecsSystem Spec
.
06 Sep 2015   #2
GokAy

Windows 7 Ultimate x64 SP1
 
 

Can you test it on another PC? Since it is new, maybe it is faulty.

You can also test it with booting into Linux Mint MATE (no installation needed).

Loading defaults in BIOS may help too.

For the sake of testing, try Safe Mode and also another user account - User Account - Create
My System SpecsSystem Spec
07 Sep 2015   #3
IronWill98

Win 7
 
 

On a different PC and on Linux it works fine. It is already set to the default BIOS settings, and when I try to boot to safe mode it gets stuck loading classpnp.sys. I'm trying to fix that right now.
My System SpecsSystem Spec
.

07 Sep 2015   #4
IronWill98

Win 7
 
 

When it is on USB it works fine, but when its internal it disconnects. I was wondering if it has something to do with power or if its setup to turn off but I'm not sure how to check.
My System SpecsSystem Spec
08 Sep 2015   #5
GokAy

Windows 7 Ultimate x64 SP1
 
 

My System SpecsSystem Spec
08 Sep 2015   #6
CKWD

Windows 7 Home Premium x64
 
 

Hello IronWill98!

When you say you switched cables, do you mean only the SATA cables? Did you use the same SATA and power cables on the other system? For how long?

I would suggest switching also the power cables. Check in BIOS, is the drive correctly shown, what's the setting there?

When yous ay the motherboard is already set to the defaults, do you mean you've just reset it, or it's like this? How long has it been hosting this drive?

If you actually mean the BIOS has never been updated, thus it's with the default settings, or if it has been reset from the menu, I would suggest manually resetting it through the CMOS battery. Pull it for 15 sec, then press the power button for another 10 to discharge any left power. Then put the CMOS back on place.

Also, does the vanishing happen while performing some sort of task, action? Please describe, is it random, etc.?

Post back!

CK_WD
My System SpecsSystem Spec
12 Sep 2015   #7
IronWill98

Win 7
 
 

GokAy- Its a Segate STBD1000400 1TB Laptop SSHD. Could this be caused by it being for a laptop? Running the System File Checker always says that there are no problems "Windows Resource Protection did not find any integrity violations."
Also the clean startup didn't change anything.

CKWD- I switched the SATA cables, not power, because I don't have any other power cables to try. The other system had different power and SATA cables. In BIOS it's shown correctly when it does show. Sometimes after a crash, a restart doesn't fix it and that's when it doesn't show up. It's set to hot pluggable. The hard drive has been connected to the computer internally for about 3 months, but it was connected through USB since I got the drive. In those 3 months, it was disconnecting. The vanishing only happens when it's working on something. I just did the manual reset to the BIOS and it only changed the time. If it was just sitting there it would be fine. It seems to happen after something has been using it for 10-20 minutes.
My System SpecsSystem Spec
12 Sep 2015   #8
GokAy

Windows 7 Ultimate x64 SP1
 
 

Laptop and desktop, only difference is form. And all SSDs are laptop sized any way.
What's your first HDD/SSD? Is it Samsung perhaps?

I believe you should first try a Repair Install - Repair Install

(If Repair Install fail), the following is an intrusive method (be warned)

- Make sure you either create a manual System Restore point - System Restore
- or image backup (I advice this for your case, as we will mess with HDD) - Imaging with free Macrium
- delete the upper and lower filters for HDD Class - How to Delete the UpperFilters and LowerFilters Registry Values
- HDD GUID - 4D36E967-E325-11CE-BFC1-08002BE10318
- and later Hard Drive Controllers if it doesn't work - 4D36E96A-E325-11CE-BFC1-08002BE10318

If you lose the OS due to these steps, recall the image you took
My System SpecsSystem Spec
Reply

 Secondary hard drive vanishing




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Secondary Hard Drive Disappears
I would like to apologize if this is not up to standards for the forum. Please let me know what other info I need to provide in order to help resolve this issue. This issue is really perplexing me. The hard drive just vanishes while I am using the computer. There are no error messages, or anything...
Hardware & Devices
OEM Partition on secondary hard drive?
I am setting up a secondary slave drive for photo storage and want to know if it is normal to have it automatically create an area of 181mgs for the (Healthy (active, OEM partition). I wanted all the drive space dedicated to it. Its only 181 megs out of 1.3TB, but just wanted to know if that is...
Hardware & Devices
Secondary hard drive disappeared after install of Blu Ray DVD drive
Hello, I hope someone can help me with an issue I've just come across. I bought an LG BH14 Blu Ray DVD drive to replace my old LG drive. I unplugged my pc, pulled out the old unit, disconnected the two wires, connected them to my new unit, and popped it back in. Too easy, right? After...
Hardware & Devices
HELP! Secondary Hard Drive Issue
I am currently running Windows 7 Ultimate 64 Bit. I installed a secondary drive (Western Digital WD Black WD1002FAEX) today. The secondary drive shows up on the device manager and bios, but does not appear in my windows explorer. I've also included a picture of the disk management below. ...
Hardware & Devices
Slow computer and vanishing hard drive
Hi Guys, I went out a bought a Roku adapter in order to view movies from Net Fliks. Due to the result of adding this piece of hardware my E drive vanished and my computers speed dropped appreciably. I took my PC to an expert and the "missing drive" appeared but when I re-hooked it up at home my...
Hardware & Devices
Vanishing hard drive post W7 install
Hi all, I'm just finishing a nearly fault free clean install of W7. However, I've one major problem. I've got three hard drives inside my desktop. One which I've installed w7 on, a second used to store pics and documents and a third for music. Unfortunately, the third, which is full of...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App