Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Asus Exhibits Glorious TUF Sabertooth Z170 Symbol 1 Motherboard

11 Oct 2015   #1
Imtiaz Mohammed

window 8
 
 
Asus Exhibits Glorious TUF Sabertooth Z170 Symbol 1 Motherboard

Together with its Z170 lineup, Asus unveiled its TUF Sabertooth Z170 Symbol 1 motherboard. Asus's TUF lineup of motherboards are built to be as tough as they can. "TUF" is a play to the word "tough, " but it surely actually stands for "The Quintessential Force, " with the plan behind the boards being that they are built with the highest-quality pieces, and thoroughly tested.

To know more information click this link:

Latest Motherboard


My System SpecsSystem Spec
.
11 Oct 2015   #2
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
Yep the sabertooth series is awesome I have a x99 and it is pretty stout
The back plate makes it very heavy but pretty impossible to bend the board with heavy gpu's

Issue with the Z170 boards coming out is win-7 and the cpu's being used on them might not be able to install win-7 on them.
Unless the board has a 2p2 "If I referred to that correctly"? mouse and keyboard connection (Non usb) which I haven't seen a sabertooth with those connections on them
So if that is the case the Z170 lineup and compatible cpu's for it will be primarily for win-8.. and 10 only installs

This one seems to have the old style keyboard or mouse port on it
Microsoft republishes KB3035583 (Get Win X App)
Asus Exhibits Glorious TUF Sabertooth Z170 Symbol 1 Motherboard-old-style-port.jpg


My System SpecsSystem Spec
11 Oct 2015   #3
Lady Fitzgerald

Win 7 Ultimate 64 bit
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi and welcome to SevenForums,
Yep the sabertooth series is awesome I have a x99 and it is pretty stout
The back plate makes it very heavy but pretty impossible to bend the board with heavy gpu's

Issue with the Z170 boards coming out is win-7 and the cpu's being used on them might not be able to install win-7 on them.
Unless the board has a 2p2 "If I referred to that correctly"? mouse and keyboard connection (Non usb) which I haven't seen a sabertooth with those connections on them
So if that is the case the Z170 lineup and compatible cpu's for it will be primarily for win-8.. and 10 only installs

This one seems to have the old style keyboard or mouse port on it
Microsoft republishes KB3035583 (Get Win X App)
Attachment 373430
The specs for this board says it will work will with Win 7. It doesn't list a PS/2 port in the specs.
My System SpecsSystem Spec
.

11 Oct 2015   #4
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
I found the thread that I've been going by
Is Win7 running on LGA1151 + Skylake Motherboards?
My System SpecsSystem Spec
11 Oct 2015   #5
Lady Fitzgerald

Win 7 Ultimate 64 bit
 
 

From what I've been reading, the issue may be just for installing Win 7 from USB 2.0. I'm thinking you should be able to use USB 3.0. The two Asus Z170 boards I've checked out clearly say they support Win 7. Why would Asus say that if it couldn't be installed?
My System SpecsSystem Spec
11 Oct 2015   #6
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Not sure interesting though I assumed it was referring to disk installs
Seeing as most are now downloaded iso files :/
My System SpecsSystem Spec
11 Oct 2015   #7
Lady Fitzgerald

Win 7 Ultimate 64 bit
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Not sure interesting though I assumed it was referring to disk installs
Seeing as most are now downloaded iso files :/
The issue I was seeing was a lack of a certain kind of USB 2.0 support that would make installing from a USB 2.0 stick impossible. I checked the manual for the Asus board and it says to use a DVD to install both Win 7 and Win 8.x; no mention was made about Win 10. That may be a problem for a lot of people who no longer include ODDs in their builds. Even an external ODD may be a problem unless it can be used with USB 3.0 during the initial installation.

Frankly, though I'm watching this, I'm not going to worry about it since I will only be using the X boards from now on (I'm a greedy PCIe lane hog). If a X board comes out with this kind of issue for using Win 7, I'll just upgrade to the previous board instead of waiting until 6-12 months before Win 7's EOL to upgrade since I'm currently planning on continuing to run Win 7 and just isolate it from the internet and I will want the newest hardware possible to help ensure it will last me the rest of my life (at my age, that won't be all that long).
My System SpecsSystem Spec
11 Oct 2015   #8
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Thanks,
Yep I don't see a Z170 in my near future either unless my Acer mother board relocation project fails soon which it's doing quite well so far and it was the next mobo... upgrade candidate

I was thinking just dropping ahci was the real issue but that stuff is way over my head
My System SpecsSystem Spec
11 Oct 2015   #9
Lady Fitzgerald

Win 7 Ultimate 64 bit
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
...I was thinking just dropping ahci was the real issue but that stuff is way over my head
Yikes! And you know more than I do.

I can't see AHCI being dropped anytime soon. IDE, yes, but most, if not all, HDDs won't run on NVMe, as far as I know. If so, and if AHCI was dropped, server farms and everyone else who still uses HDDs would be raising a mighty ruction.
My System SpecsSystem Spec
11 Oct 2015   #10
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

It's turning into a uefi only world it seems :/
Problem I see every feature that lets a person or os or performance program/ app access the bios opens security holes for bad guys to access them also = enter the new bios killing malware world.

I see a lot of large paperweights used to be known as perfectly good mother boards
My System SpecsSystem Spec
Reply

 Asus Exhibits Glorious TUF Sabertooth Z170 Symbol 1 Motherboard




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
ASUS Motherboard H97 Plus
I just installed the ASUS board. I'm getting an "i" in device manager for: 1) Ethernet Controller 2) PCI Simple Communications Controller 3) Unknown device I have the DVD, but NOT sure where or if the drivers reside on this disk as No Table of Contents is provides only directories with...
Drivers
BSOD After using ASUS Sabertooth 990FX MOBO OC Utility.
Hello all, I am new to OC. I just wanted to see what my system could do. The motherboard has a built in OC utility in BIOS. The motherboard has three settings you can click on, Energy Efficient, Normal, and OCBurner(or something of that nature). I have Open Hardware Monitor always running. My temps...
BSOD Help and Support
My Asus Sabertooth 990fx reading RAM wrong and Video card issues.
My Motherboard reads the RAM lower than the speed it is suppose to go, when I have installed G-Skill Sniper 8GB 2x4GB 1600 Mhz. But when I manually choose it too 1600Mhz it wont boot. Also my EVGA GTX 660 SC 2GB's FPS has been dropping from like 100 - 30 in some Source games like GMOD. I have never...
Hardware & Devices
Help enabling wake on lan for Sabertooth Z77 motherboard
I am trying to wake my computer on lan, but I can't find the setting in the bios.
Performance & Maintenance
16 GBs of RAM not working on ASUS motherboard
Hey guys, I'm new here and I've been having a lot of trouble with my ASUS M4A785TD-V EVO motherboard. It's rated to be compatible with 16 Gbs of RAM but the last two sets I've purchased from newegg haven't worked at all! :( I tried mixing old RAM with new and it still won't work. It only works...
Hardware & Devices
Asus Sabertooth X58 sound driver
Sabertooth X58 motherboard- When I install the latest sound driver for my motherboard from Asus, the sound quality deteriorates, and the recording has a loud fuzzy ghosting sound in the background. Anyone else experience this problem?
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:40.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App