Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Stick & Memory Card Not Showing in My Computer !


14 Nov 2009   #1

Windows 7 Ultimate SP1 x64
 
 
USB Stick & Memory Card Not Showing in My Computer !

I have this problem for a few days now, i tried searching on other topics but didn't find exactly my issue.

When i connect the first USB Stick (1 GB Kingston) everything it's ok, it shows up in Explorer, but when i try to connect the other one (i have two) it wont show up, but i can access it if i just type the drive letter in the address bar (J:\).
Also if i try to connect my phone as a USB device or any other memory stick, same problem...not showing up in Computer window.
I can see just 1 device (I:\), all the others are not there !

Help ?!

My System SpecsSystem Spec
.

14 Nov 2009   #2

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by maranello View Post
I have this problem for a few days now, i tried searching on other topics but didn't find exactly my issue.

When i connect the first USB Stick (1 GB Kingston) everything it's ok, it shows up in Explorer, but when i try to connect the other one (i have two) it wont show up, but i can access it if i just type the drive letter in the address bar (J:\).
Also if i try to connect my phone as a USB device or any other memory stick, same problem...not showing up in Computer window.
I can see just 1 device (I:\), all the others are not there !

Help ?!
Have you tried to use System Restore to go back before this issue occured...

If you can't then do a repair install

Repair Install

Backup your data first to be safe
My System SpecsSystem Spec
14 Nov 2009   #3

Windows 7 Ultimate SP1 x64
 
 

the first thing i tried was system restore and i get the same problem
i want to find a stable fix for this issue, using repair would be too easy...and might not work as well

i have the RTM version installed and I'm thinking of installing the final release in near future, but first i want to get this issue fixed, don't want leaving it this way...
My System SpecsSystem Spec
.


14 Nov 2009   #4

Windows 7 Professional x64
 
 

Are you connecting the drives to the front panel? Have you tried plugging them into the back?

I would try a different USB hub. Even plug the front panel lead into another header and see if it makes a difference.

It may be a power issue also. The board may not be pushing enough milliamps.

You've probably tried all this but a different header on the motherboard might be something to try.
My System SpecsSystem Spec
15 Nov 2009   #5

Windows 7 Ultimate SP1 x64
 
 

i tried all the USB ports from the motherboard (i don't use a hub), i even bought a separate USB to PCI adapter and same problem...

i don't think it has something to do with the output power from the motherboard because i can access them by typing the drive letter in the address bar

well, maybe someone will have a brainstorming idea and help me get this fixed...

thanks for you support guys
My System SpecsSystem Spec
15 Nov 2009   #6

Windows 7 Professional x64
 
 

Sorry I couldn't be more helpful.

It sounds like the drives are hidden or "drives with removable storage" is not expanded, but I know this probably isn't the case here. If I think of anything I will post it here.
My System SpecsSystem Spec
15 Nov 2009   #7

Windows 7 Ultimate SP1 x64
 
 

thanks nate, any idea is welcomed...

solved it: Clean Windows 7 Install. not the best solution but the network also stopped working and i had to do it...
My System SpecsSystem Spec
19 Jun 2012   #8

Win 7
 
 
Solved Without Reinstall or Rewind

I have solved this problem, just as I got it a few minutes ago.

No body had stated that to uninstall and reinstall the driver of the usb that is not working. So here's how you do it:

1. Goto Device Manager [right-click my Computer from start menu -> select Device Man].

2. At the bottom of window expand Universal Serial Bus controllers.

3. Select and double-left-click on the name of the USB that is not working [not a USB root HUB nor an ATI I/O Communications Processor USB...].

4. Goto Driver tab [in the window that has just popped up]

5. Click Unistall [to unistall the driver of your USB stick]

6. Then unplug your UBS stick

7. Plug it back in and windows 7 automatically installs the driver

Easy as cake!
My System SpecsSystem Spec
19 Jun 2012   #9

Windows 7 and MAC
 
 

Was this Drive Ever used with a Mac Computer with Mac OSX Installed { Could be any Version of Mac OSX }
My System SpecsSystem Spec
Reply

 USB Stick & Memory Card Not Showing in My Computer !




Thread Tools



Similar help and support threads for2: USB Stick & Memory Card Not Showing in My Computer !
Thread Forum
Card Reader Not Showing IN My Computer Hardware & Devices
Ricoh 5 in 1 memory card reader not showing drives Hardware & Devices
Sony Vaio VGN-N130G Memory Stick and SD Card Ports Not Working Hardware & Devices
4gb Memory stick Hardware & Devices
Memory Stick Question Hardware & Devices
USB memory stick help Hardware & Devices
SD memory card not showing in my computer Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:03 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33