Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: PnP USB 3.0 Hub Doesn't Work!

14 Dec 2015   #1
stuckstuck

Microsoft Windows 7 Professional 64-bit
 
 
PnP USB 3.0 Hub Doesn't Work!

The title says it all, I'm not too sure what happened. I know now that it's definitely a software issue.
I had bought a new USB hub thinking my old USB hub has finally given up on me but I was wrong.
I'm not too sure how to fix this, I'm at a loss. I don't suppose anybody from this fine community could help me out here? I'd really appreciate it, thanks in advance.


My System SpecsSystem Spec
.
14 Dec 2015   #2
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

In my opinion when one uses a hub its the luck of the draw whether it works or not.
What are you plugging into the hub?
Why would you need a hub? Your motherboard has many usb 2.0 ports and no usb 3.0 ports.

https://www.asus.com/Motherboards/P6...pecifications/


Quote:
USB
14 USB 2.0 ports (6 ports at mid-board, 8 ports at back panel)
My System SpecsSystem Spec
14 Dec 2015   #3
stuckstuck

Microsoft Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by Layback Bear View Post
In my opinion when one uses a hub its the luck of the draw whether it works or not.
What are you plugging into the hub?
Why would you need a hub? Your motherboard has many usb 2.0 ports and no usb 3.0 ports.

https://www.asus.com/Motherboards/P6...pecifications/


Quote:
USB
14 USB 2.0 ports (6 ports at mid-board, 8 ports at back panel)
my bad, my profile on here hasn't been updated since forever.
the motherboard I have now has USB 3.0 ports on it.
I mostly have external hard drives plugged into it, and it's been working fine up until now.
As of this moment I'm trying to figure out what went wrong, again, my old USB hub has been working fine up until now, bought a new USB hub and it's the same issue. Now I'm pretty confident it's software-related.
My System SpecsSystem Spec
.

14 Dec 2015   #4
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Please complete your My System Specs to match your computer.
We need to know what we are working with.

Also you could you post a site showing which hub you are using?

Did you install manually your usb 3.0 drivers?
My System SpecsSystem Spec
14 Dec 2015   #5
stuckstuck

Microsoft Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by Layback Bear View Post
Please complete your My System Specs to match your computer.
We need to know what we are working with.

Also you could you post a site showing which hub you are using?

Did you install manually your usb 3.0 drivers?
Way ahead of you, I had just updated my specs just now.
The USB hubs I buy are PnP, the ones I have now are PnP.
Anker® 60W 7-Port USB 3.0 Data Hub with 3 PowerIQ: Amazon.co.uk: Electronics
My System SpecsSystem Spec
14 Dec 2015   #6
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Still need this answered.

Quote:
Did you install manually your usb 3.0 drivers?
Do your usb 3.0 ports work with out using the hub?

Does your usb 2.0 ports work with the hub?
My System SpecsSystem Spec
14 Dec 2015   #7
stuckstuck

Microsoft Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by Layback Bear View Post
Still need this answered.

Quote:
Did you install manually your usb 3.0 drivers?
Do your usb 3.0 ports work with out using the hub?
Yes.
My System SpecsSystem Spec
14 Dec 2015   #8
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Quote   Quote: Originally Posted by stuckstuck View Post
Quote   Quote: Originally Posted by Layback Bear View Post
Still need this answered.

Quote:
Did you install manually your usb 3.0 drivers?
Do your usb 3.0 ports work with out using the hub?
Yes.
You have installed the drivers and the usb ports work without the adapter makes me think it is the adapter.
Tell us in some detail what exactly you are using this hub for and how?
My System SpecsSystem Spec
14 Dec 2015   #9
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Check the Anker support site for your model. I noticed they have firmware upgrades for some of their USB 3.0 hubs

Also check if any BIOS update available for your m/b
My System SpecsSystem Spec
14 Dec 2015   #10
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Good call ComputerGeek.

My System SpecsSystem Spec
Reply

 PnP USB 3.0 Hub Doesn't Work!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
acer aspire 4738' s bluetooth doesn't work but wifi work?
Acer aspire's Bluetooth doesn't work since I bought it I've installed drivers too but it doesn't work what should I do. In its specs it has Bluetooth . But there is no Bluetooth device found in device manager how to repair this. Please HELP!!
Hardware & Devices
USB doesn't work in WDS
I am currently trying to get a base image of windows 7 on some HP Deskpro 600 G1 SFF. My issue is once I get into WDS, the USB ports do not work for mouse or keyboard. I have to revert back to PS/2 keyboard and mouse to get the computers to work, it is quite inconvenient. To summarize, I have...
Hardware & Devices
My bluetooth doesn't work. bttray doesn't open.
Hello. I am quite new here, but I've been wanting to get this problem solved for a long time, and I haven't seemed to get any answer. So here's my problem: I bought my Asus N53SV for around a year ago, and it worked great. But for some reason something changed. When I try to open bluetooth,...
Software
HELP: power option doesn't work - screen saver doesn't start!
I have an ASUS notebook running windows 7 64-bit. I am using the QuietOffice power profile, however the screensaver won't kick in no matter what I do, and the display does not turn off even though I set it to be after 5-minutes of inactivity. I don't know if there is something running in the...
General Discussion
LIBusb, USB ports doesn't work. Safe mode also no work
After I install LIBusb I could work futher. But after I put him off en reboot an hour later my wired mouse en keyboard didn't work anymore. When I restart in safe mode both still doesnt work. OS: W7 Home Premium 64b Computer: HP Pavilion p6250 Please Help!!
Drivers
DWM Doesn´t work
Hey guys, If you think that this is the first thing i´m doing to solve this problem, well no. I tried almost every solution i could find on youtube, but still DWM won´t work and i hate the ugly standard theme. But the part where i always get stuck is this, when i go to services to check if DWM...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App