Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB 3.0 hub disappearing after resuming standby

10 Jan 2016   #1
Lister Of Smeg

Windows 7 Ultimate x64 SP1
 
 
USB 3.0 hub disappearing after resuming standby

I am experiencing problems with my USB 3.0 ports on a Delock 89359 PCI-e x4 card which is a combined SATA 6Gb 2 port and 2 external USB 3.0 ports card which I have installed to a PCI-e x16 v2 slot.

The problem is that when I put my system into standby, after resuming from sleep, the two hubs USB 2.0 and USB 3.0 disappear which means the ports do not function. The only two devices left installed after resuming are Etron USB 3.0 Extensible Host Controller and Etron USB 3.0 Extensible Root Hub but there should be two additional hubs which makes any devices accessible. I will update after a reboot with their exact names but one is a USB 2.0 and the other is a USB 3.0 hub.

I use a USB 3.0 Startech dual docking bay SDOCK2U33HFW which I use to plug in a number of drives as needed. However after standby when the USB hubs disappear, the drives cannot be accessed until a reboot which is proving very annoying.

I have tried scan for hardware changes in device manager without success. I have tried uninstalling the Etron application drivers and unplugging the docking station and reinstalling the drivers, which only installs the two devices that I listed above and not the two hubs. I have also tried v1.0.0.118 and v1.0.0.119 Etron drivers with no improvement.

This windows 7 x64 SP1 install is newly done less than 2 weeks ago and the majority of windows updates have been installed which in itself was a challenge with updates not downloading, not installing and spending hours checking. I did finally solve this but I guess that the updates are what might be causing these USB problems but that is only a wild guess.

Therefore I would appreciate some help to stop the devices disappearing after resuming from standby.

BTW the PC system is marked [2] in my system specs


My System SpecsSystem Spec
.
10 Jan 2016   #2
Lister Of Smeg

Windows 7 Ultimate x64 SP1
 
 

The two hubs are Etron USB3 (SS) Hub and Etron USB2 (HS) Hub.

Does anyone have any ideas on how to solve this and prevent the hubs disappearing when using standby?
My System SpecsSystem Spec
10 Jan 2016   #3
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

With little problems like this a reboot usually helps.
My System SpecsSystem Spec
.

10 Jan 2016   #4
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

could also depend on your power settings for USB and PCI.

Roy
My System SpecsSystem Spec
10 Jan 2016   #5
Lister Of Smeg

Windows 7 Ultimate x64 SP1
 
 

It's not such a little problem when it prevents my PC being used effectively. I do not want to have to keep rebooting just to restore a device because it should not be necessary.

Something must be causing the devices to vanish and I would like to rectify the problem and it's cause. I use standby a considerable amount, putting my system asleep when I am working on something but need to do other things and I go back to it when I have time. It is very inconvenient if I have to close everything and reboot all the time.
My System SpecsSystem Spec
10 Jan 2016   #6
Lister Of Smeg

Windows 7 Ultimate x64 SP1
 
 

Quote   Quote: Originally Posted by torchwood View Post
could also depend on your power settings for USB and PCI.

Roy
USB setting is set to selective suspend: disabled, whereas PCI-e Link state power management is set to off. I don't think that either of those should adversely affect USB devices.
My System SpecsSystem Spec
11 Jan 2016   #7
maxseven

Windows 7 Home Premium 64bit 6.1 Build 7601 (SP1)
 
 

Quote   Quote: Originally Posted by Lister Of Smeg View Post
Quote   Quote: Originally Posted by torchwood View Post
could also depend on your power settings for USB and PCI.

Roy
USB setting is set to selective suspend: disabled, whereas PCI-e Link state power management is set to off. I don't think that either of those should adversely affect USB devices.
Well the obvious thing to try of course is alternate settings for these, and another place to look is BIOS. Make a careful note of where you start of course and then try ever other combo of settings--I've been there and done that and you can end-up confusing yourself.



It does sound like a driver incompatibility, but if you've tried all the mfr drivers for your hardware and need to t-shoot some more you might go to Uwe Sieber's Homepage and look at his Drive Tools link. I've used DriveCleanup to fix odd problems and UsbTreeView to ID how my devices connect & run.
My System SpecsSystem Spec
Reply

 USB 3.0 hub disappearing after resuming standby




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BSOD/Garbled BSOD when resuming from standby, 0x3B and others
Hi all, I've been having issues with my new Thinkpad T440s - it will intermittently (maybe 50% of the time) BSOD upon resuming from standby, and VERY occasionally at random times, like browsing the internet. Often, the BSOD screen will be completely garbled, and I am unable to read anything. ...
BSOD Help and Support
WU fixed but random shut-downs and standby not resuming?
Hi guys, So after resolving my WU problems (thanks again Noel) my laptop has some standby issues; It rarely comes out of standby now, Fans roar but screen stays blank, only option is power off. And when in standby sometimes I return to it and it has turned off. Where to start?
BSOD Help and Support
Windows crash while resuming from standby window's says it was a BSOD
Been having some strange crashes recently. When I resume my netbook from standby it restarts. Windows error report thingy said it had a BSOD and had to restart. A few months ago I had an even stranger problem where I was unable to load windows because of some windows update... It just launched...
BSOD Help and Support
Errors in Event Log On Booting and Resuming From Standby
Hey guys, My computer took a little while longer booting tonight so I checked the error log and found the following: - System - Provider Name] Microsoft-Windows-Diagnostics-Performance
BSOD Help and Support
Icons and Other graphics Streaking after resuming from Standby
I have a Dell Studio 1537 computer that came with Vista. After I upgrade to Windows 7 Ultimate, I noticed that whenever the system resumes from standby, all the graphics have streaking over them. Any ideas what is happening here and how I can resolve it? ...
General Discussion
Sporadic Problems Resuming from Standby - Two Restarts Required
Hi - I have occasional problems resuming from standby. It doesn't happen all the time; there seems to be no rhyme or reason to it. When I try to resume from standby, I will see a bright back lit monitor. I then have to turn the computer off manually via the power button. When the computer...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App