Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: hardware lost in new WIN7 installation

19 Nov 2009   #11

Windows 7 Pro & Vista Home Premium

A 20 GB drive must be very old, maybe Windows can't idetify it

for the Unknow device try downloading this freeware utikity:
Unknown Device Identifier 6.01 Download - Freeware - Utilities Category

My System SpecsSystem Spec
19 Nov 2009   #12

Windows 7 Ultimate x64 RTM

All he needs to do is install the drivers bobkn posted...
My System SpecsSystem Spec
20 Nov 2009   #13

windows 7 build 7600

Thank you so much for all the input you;ve given, its helped loads! This place is great!

I've fnally got W7 recognising my 20gb barracuda drive and I've also got my dvd drive up and running. Those nVidia drivers also worked for my IS working, BUT....

I have to say, my pc seems like its juttering a lot. I mean, when i move my mouse about it feels like its druching itself through something thick and hard (if that makes sense) and now that the machine recognises the audio drivers the audio plays real bad, with crackling in the background and the speed fluctuates like it were being played from a record player!

For the time being im happy that its all roughly working though...but has anyone else had problems like the ones im describing?

A reasonably content Squareeyes
My System SpecsSystem Spec


 hardware lost in new WIN7 installation

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Installation Hardware Trouble
I just Reset my Gateway LT2802u to factory settings and it restart --------- **The Problem** When the "Setup is Starting Services" an error pops up saying , Windows Could Not Complete the installation. To instal Windows on this computer restart the installation. Now after I press ok the...
Hardware & Devices
after xp installation i lost windows 7!!
Hi all ,,, I'm new to windows 7 forums , I hope I can help and you can help me also. I installed windows XP professional on my Toshiba laptop which contains windows 7 Home Prem. when I finished installation the Default OS changed to XP and I tried to boot to windows 7 but I can't. now I...
BSOD Help and Support
Windows 7 fresh installation on new hardware
Let me start off by saying that I have seen several similar posts in these and other forums, but none have exactly the same symptoms as I have with this problem. Backstory : I previously had windows 7 dualbooting with Ubuntu on my barebones computer kit (with a Nvidia GeForce 9500 GT video...
Installation & Setup
Hardware error while windows 7 installation
We have got the error as listed below at the time of installation of windows 7 in Dell 520 Laptop. We have diagnose the memory too but couldn’t find any error in that. Please check what could be the issue and if you have faced the same issue there. Please provide some solution for PM too that...
Installation & Setup
windows 7 lost after duo installation
I've had Windows 7 OS 64 Bit pre installed on my HP desktop, with one HD. I created the new partition on HD. And reboot from my Server 2003 and installed it. Installation was perfect until I discovered that my PC reboot and only server 2003 load up. Win Server 2003 is limited edition for 120...
Installation & Setup
Installation - Feeling Lost
Hi everyone, So my school burned me an installation DVD of Windows 7. I want to install it on my DVD-drive-less PC. I have a DVD drive & USB drives on my laptop. I scoured the internet for tutorials on how to do the DVD to USB thing, finding out I need a .iso file. My installation DVD has no...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:17.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App