Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: some usb ports not functioning.

17 Jun 2016   #1
khimvillama

Windows 7 Ultimate 32-bit SP1
 
 
some usb ports not functioning.

I'm using acer desktop windows 7 32-bit. I don't know why out of my 6 usb ports, only two (at the back) are functioning (which i use for mouse and keyboard ofcourse). whenever i plug my printer in those nonfunctional 4 ports, my printer says communication error. my flash drives won't run too, my mouse and keyboard also doesn't work if i plug it there. but when i tried the speaker, it works fine. so i guess the power is ok.

i tried running device manager. the only ones with the yellow flag is bluetooth peripheral device. is this somehow connected? i didn't update my drivers so there's nothing to restore. i also tried unplugging all devices and wires, rebooting. nothing. it's the same.

i tried updating driver software of one of the bluetooth peripheral device with standard serial over bluetooth link (COM3) so there's only one left. a preview of my device manager is attached here.

i also tried uninstalling Universal Serial Bus controllers and rebooting after. nothing works.

anyone who knows what is going on? i'm confused and i'm working with this problem since last night. help me please.

thanks ahead!

i'm starting to get disappointed. so here is the problem.

i have a total 0f 6 usb ports. only two are functional which i use for my mouse and keyboard. i tried to boot in safe mode and all ports work fine. i tried uninstalling USB controllers and rebooting. nothing works.

also there is nothing to restore because all dates available are dates that my pc had been a nuisance.

i already tried regedit.

all usb controllers are good. i mean there are no yellow flags. well, i don't know if something's missing. is it normal to not have usb mass storage device listed there? if no, please tell notify me asap.

another thing is that i got two "bluetooth peripheral device" with yellow flags listed under "other devices" it says code 28 (no driver installed). is this somehow the reason? i tried updating it and failed. i uninstalled it and reboot. just the same.

is this a work of a virus or i dunno. i'm confused. i'm no technician but i do understand some. so please, anyone, help? thanks!




Attached Thumbnails
some usb ports not functioning.-device-manager.png  
My System SpecsSystem Spec
.
Reply

 some usb ports not functioning.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
USB Ports not functioning properly
Hi there, I have a Toshiba Laptop 1.86Ghz with Windows 7, 32-bit with 2 GB ram. I recently had a new CPU installed in my computer. When I got my PC back, my 2 USB ports don’t function properly anymore. The main problem seems to be with my USB Internet modem. (HUWAEI Mobile Connect) ...
Hardware & Devices
ICS - No longer functioning.
My setup: Windows 7 Home 64bit - quad CPU - 8GB ram - Available Virtual memory 14GB NIC 1 Internet - trying to re-setup ICS NIC 2 XBOX360 What happened recently: Everything worked fine with ICS, however I wanted a router with wire + wireless connections so I could use the wii and DS...
Network & Sharing
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
USB 3.0 ports refuse to work as USB 3.0 ports
A few days ago I installed a USB 3.0 card (to be precise, this one: 2-Port USB 3.0 SuperSpeed PCI-E Controller Card - Free Shipping - DealExtreme). It uses the very common NEC µPD720200 USB 3.0 controller. I installed the required drivers for Windows 7, and the card worked fine for the first...
Hardware & Devices
Homegroup is not functioning
We have 3 pc's, 2 laptops on our homegroup. I recently upgraded one of the pc's and couldn't get it connected again to the homegroup. Since then, I've tried the suggestions on the forums, and still get errors. I'm unable to leave/remove the homegroup on the host pc. I can't view/print the...
Network & Sharing
CD Drives Not Functioning
I installed Win 7 Home Premium and I am having trouble spinning up my CD Drives (both of them). They were working under Win XP... If I attempt to install a game, the CD does not spin up. HELP!!! Dell Computer XPS 400 2.83 GHz Dual Processors 3.00 GB Ram Nvidea GeForce GTX 500TI Video Card
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App