Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Backup Drive Looses Connection

03 Jul 2016   #1
artmanphoto

Windows 7 Professional 64 Bit
 
 
USB Backup Drive Looses Connection

I am using a Windows 7 32 bit PC with an external USB backup drive. Every couple of weeks the backup drive "looses connection" and no longer appears in My Computer. When I pull the power plug from the back of the external USB backup drive for a couple of minutes and plug it back into the drive the computer then recognizes and sees the backup drive again.

Does anyone know why this is happening and how I can fix this problem. Could my external USB backup drive be going bad?

Thanks very much.


My System SpecsSystem Spec
.
Reply

 USB Backup Drive Looses Connection




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Computer lags and looses internet connection daily
I have a pretty good computer, as computers go but every day between 5-30 minutes after start-up, it begins to experience lag spikes, sharp sounds loops, and looses the internet connection regardless of how much RAM I am using. I can postpone dealing with it by restarting my computer, but it is...
Performance & Maintenance
external backup drive connection
My external backup drive is a SimpleTech StorageSync unit used with an XP OS. I recently purchased a Dell 64 bit desktop. Can I just connect the backup drive to the new PC or should I make other adjustments?
Backup and Restore
Unable to backup hard drive with Backup Program
I keep getting an error when I try to use the Backup Program. As far as I can tell there are no hidden partitions. Using the Administrator tools -> Computer Management -> Disk Management tool, I deleted all the partitions on my external ESATA drive which is larger than my boot drive. Then I...
Backup and Restore
Local Device Name Problem, Looses connection to Shared.
Running Win 7 Professional 64-bit and trying to connect to a shared RAID-5 array on my HomeServer (running Vista Ultimate 64-bit) over my LAN. On start up, my HomeServer shows up as part of the network and it allows me to connect to it. I can access the shared drive just as before and log into my...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:09.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App