Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Razer Mamba not detected (experienced user, tried everything on google

06 Jul 2016   #1
anarchoi

win7 64bits
 
 
Razer Mamba not detected (experienced user, tried everything on google

I'm an experienced user and tried all solutions found on google, but this problem is really hard to fix.

I just bought a brand new Razer Mamba mouse. The mouse is not faulty, it is working on another computer, but not on mine. I used different logitech mice before trying this one, it is the first time i have a problem installing a mouse in 20 years of working with computers...

The weird thing is that the mouse is detected and working (i can move it) in the BIOS, but not after booting Windows

- The mouse lights up, but is not detected anywhere
- Razer Synapse 2.0 is installed, but it is not detecting the mouse
- In Device Manager "Razer Mamba Dock" is not correctly installed (labeled as Unknown Device)
- I tried installing older drivers, but it's still not detecting the mouse
- I tried updating the firmware, doesn't work

- Tried wireless or wired, same problem
- I tried 6 different USB ports, USB2 and USB3
- All USB ports power settings are configured correctly (Windows is set to NOT turn off USB to save power)
- Old drivers of the old logitech mouse is uninstalled
- I tried using the safe mode, didn't help
- Tried using only 1 mouse at time and booting Windows with only the mouse in USB ports
- Uninstalled and reinstalled drivers countless of times, and also tried without drivers
- Tried forcing windows to manually install the drivers of the Unknown Device, but it won't let me
- Tried with a different Windows user
- All drivers are up to date, same for BIOS
- Mouse is fully charged

Config:
Windows 7 64bits
Motherboard MSI Z87-G45
Core i7 4970k
980SC
Alienware Keyboard


My System SpecsSystem Spec
.
06 Jul 2016   #2
HAVOC

Windows 7 Professional 64bit
 
 

Have you tried using the mouse without Razer Synapse? (I've had nothing but issues with Synapse, I now use Corsair keyboards and mice with no added software)
Make sure the mouse is plugged into a USB2 port.
My System SpecsSystem Spec
06 Jul 2016   #3
anarchoi

win7 64bits
 
 

Yep, i tried without Synapse. I even tried the old Mamba drivers. Also tested with USB2 ports and USB3.
It really looks like a driver issue or a conflict with something on this particular computer, since it works in 3 other computers except mine. The mouse also works in my BIOS but not after booting windows.

I have read on different forums that a lot of people are having problems with Synapse... So disappointing for a $200 mouse...
My System SpecsSystem Spec
.

06 Jul 2016   #4
HAVOC

Windows 7 Professional 64bit
 
 

Synapse is the reason I no longer use Razer products. Had a Razer gaming keyboard and mouse.

This is copy/pasted from Razer's support site:

I am getting a "No Mamba Mouse Detected" when I try to open the configuration software. Why?
When you see the "No Mamba Mouse Detected" screen, please open up device manager and check whether firmware driver is installed correctly as follows:
1. Right click on My Computer.
2. Select the "Manage" option.
3. Click "Device Manager" at the left menu selection.
4. Expand the last item which is "Universal Serial Bus controllers". If the driver is installed correctly, you should see a ""Freescale JM60 Bootloader"" device inside. If you do not see this device in device manager, please unplug your Razer Mamba. Check that the power switch is in the OFF position. Then, press and hold the pairing button and plug in the Razer Mamba again. This should make the ""Freescale JM60 Bootloader"" device entry appear and you should be able to update firmware using the application. Please let us know if the above steps did not manage to solve your problem.
My System SpecsSystem Spec
06 Jul 2016   #5
anarchoi

win7 64bits
 
 

Thanks for the reply,

I have seen this information from Razer website, in device manager there is nothing like that under USB controllers.
Only Razer Mamba Dock is listed under "unknown devices".
This mouse doesn't seem to have a pairing button like other models. There is no button under the mouse, i looked everywhere. Some website said the pairing button was holding down the 3 mouse buttons at the same time (left, right and mousewheel buttons). I tried it multiple times but it does nothing, and i haven't found official confirmation that this is the correct way to put this mouse in pairing mode.

Here's a screenshot of device managers: https://gyazo.com/d97152359133c68f931131a6cb86fd79

And here's a picture of the bottom of my mouse : https://gyazo.com/6eb652e7073285ba7ad741c348040352
My System SpecsSystem Spec
06 Jul 2016   #6
HAVOC

Windows 7 Professional 64bit
 
 

Can you scroll down and post the rest of the device manager? What motherboard are you using?
My System SpecsSystem Spec
07 Jul 2016   #7
anarchoi

win7 64bits
 
 

Motherboard MSI Z87-G45

What do you want to see in the device manager ?
Here's another screenshot with a couple of options expended: https://gyazo.com/8c0b0bdff8d1672a30be9525a1bd1d74
If you need any other information just ask me

Thanks
My System SpecsSystem Spec
08 Jul 2016   #8
HAVOC

Windows 7 Professional 64bit
 
 

Do you have anything listed under "Human Interface Devices" (like what I have in my device management)? I think that you have a driver issue some where.

Do you have another mouse to use for troubleshooting? I would disconnect the Mamba, uninstall Synapse, plug in your test mouse and restart the computer. Unplug any USB2 devices except for the keyboard and mouse. Have a look in the device manager and try to find/install drivers for the items with ? or ! next to the name. Even the one that says USB3.

Found this after a little searching. Looks like some other people have the same issue.

Regarding the firmware update, try the following:

Open the firmware update program
Connect the USB cable direct to the mouse, don't plug in yet
Hold the 2 mouse buttons and the wheel button in together and plug the mouse in
(helps if you have a 2nd mouse installed as the mamba will stop working)
Hold for 5 secs and then release. You should see the drivers load again as well as the bootloader
Click next on the firmware updater and it should now update
After the mouse firmware is updated, it will try and update the dock.
Remove the USB cable from the mouse and connect to the dock
Unplug the USB cable from the computer, hold the wifi button down and reconnect. hold form 5s and release. The same thing should happen as with the mouse.
Click next and the firmware should then upload to the dock


Attached Images
Razer Mamba not detected (experienced user, tried everything on google-dev-mgmt.png 
My System SpecsSystem Spec
Reply

 Razer Mamba not detected (experienced user, tried everything on google




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Google Chrome / Chromium help with user profiles
Hello, I have a few problems that I have with regards to Google Chrome. Specifically with user profiles. I have two laptops and they both used to run Google Chrome, until this new update came along. Think it was version 45.0.something, but I'm not sure. It wiped out my list of plugins, thus...
Browsers & Mail
Google Chrome keeps crashing for 1 user but ok for other
On my desktop I have 2 users on Win 7 Pro. (All up to date) I had to uninstall Google Chrome due to crashing. Had to use Safe Mode to re-install, there was a problem with the Application file. Now Chrome works fine for one of the users but crashes instantly with the other user. I can't even find...
Browsers & Mail
Where is User Dictionary for Google Toolbar Spellcheck?
Hello, I have been trying to collect all of my back-up necessary files into my "My Documents" folder, so I don't have to maintain a list or archive of all the different locations of them. I can just backup or copy the Documents folder regularly and as needed. I would like to know where the...
Browsers & Mail
Google Chrome usable by only ONE user
On this laptop's Win-7 system, I have two (both privileged) user-accts. While logged in as one user, I installed Google's Chrome browser. It put itself in the menu-system, so it can be started by that user, and it works perfectly normally, as one would expect. But, I EXPECTED that...
Browsers & Mail
Razer DeathAdder and Razer Tarantula Windows7 64bit
I wonder if anyone knows if DeathAdder and Tarantula going to function if I install Windows7 64bit?
Drivers
Google user or Guru?
Hey, I was wondering these days, if the Gurus of the site are real Gurus or just google users! Please dont take it wrong but everytime I ask a question that I dont find on the net or the forum, noone has an answer for me. Ok, searching google is fun, but isnt knowledge that matters? I am somehow...
Chillout Room


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App