Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External Hard drive, computer does not recognise and I/0 device error

23 Oct 2016   #1
Koolman511

Windows 7 Home Premium 64 bit
 
 
External Hard drive, computer does not recognise and I/0 device error

Hello, I believe last week I had the similar problem with my Memory card but I could still gain access and now my External HDD is acting up. I am not sure if I downloaded a file which may have caused a virus and damaged it.

Basically I don't even know if it is possible for me to data recover my files as I tried with 2 different machines and still displaying I/0 device error

I forgot to mention the drive makes a ticking noise


My System SpecsSystem Spec
.
23 Oct 2016   #2
Megahertz07

Windows 7 HP
 
 

Please edit your profile and add all specs about your computer.

Open disk manager, expand the columns so we can read them, and, with sniping tool, take a snapshot.
Post the image as an attachment (open Go advanced, at the bottom open Manage Attachments, browse for the image, upload)

Ticking noise may be saying: I'm Dead
My System SpecsSystem Spec
23 Oct 2016   #3
Eric3742

Windows 7 x64
 
 

Quote   Quote: Originally Posted by Koolman511 View Post
Hello, I believe last week I had the similar problem with my Memory card but I could still gain access and now my External HDD is acting up. I am not sure if I downloaded a file which may have caused a virus and damaged it.

Basically I don't even know if it is possible for me to data recover my files as I tried with 2 different machines and still displaying I/0 device error

I forgot to mention the drive makes a ticking noise

The HDD may have failed.
My System SpecsSystem Spec
.

23 Oct 2016   #4
Koolman511

Windows 7 Home Premium 64 bit
 
 



I tried to initialised it but keeps throwing the same error or anything I do even using CMD
My System SpecsSystem Spec
23 Oct 2016   #5
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Its using the wrong format
should be NTFS NOT FAT32,
Have you reformatted it lately, if not been using any tune up utilities, reg cleaners etc??

Roy
My System SpecsSystem Spec
23 Oct 2016   #6
Megahertz07

Windows 7 HP
 
 

As an external drive, it can be formatted as Fat 32 for compatibility.
It's small for today disks (29G). How old is your disk?
What kind of case it's installed? Is it a SATA to USB?
IO error means a hardware failure to communicate.
Go to device manager and see if there is no yellow alert mark.
My System SpecsSystem Spec
23 Oct 2016   #7
Koolman511

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by torchwood View Post
Its using the wrong format
should be NTFS NOT FAT32,
Have you reformatted it lately, if not been using any tune up utilities, reg cleaners etc??

Roy
Quote   Quote: Originally Posted by Megahertz07 View Post
As an external drive, it can be formatted as Fat 32 for compatibility.
It's small for today disks (29G). How old is your disk?
What kind of case it's installed? Is it a SATA to USB?
IO error means a hardware failure to communicate.
Go to device manager and see if there is no yellow alert mark.

Sorry Disk 1 is my memory card which I am using as a temporary storage and Disk 2 (500gb) is the external hard drive
My System SpecsSystem Spec
23 Oct 2016   #8
Megahertz07

Windows 7 HP
 
 

Give us all information from Disk 2 (500G). Type, size (3.5 or 2.5"), enclosure, brand etc.
Did it fall when on? Even from vertical to flat?
Go to device manager and see if there is no yellow alert mark.

As it has ticking noise I would say it has died.
My System SpecsSystem Spec
23 Oct 2016   #9
Koolman511

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
Give us all information from Disk 2 (500G). Type, size (3.5 or 2.5"), enclosure, brand etc.
Did it fall when on? Even from vertical to flat?
Go to device manager and see if there is no yellow alert mark.

As it has ticking noise I would say it has died.

It is a Western Digital 500gb my passport external hard drive. I am not sure what size it is but I guess it is 2.5 from reading. There is no exclamation mark in device manager.
My System SpecsSystem Spec
23 Oct 2016   #10
Megahertz07

Windows 7 HP
 
 

Don't try to fix it, or you may loose all data on it.
Ask Jumanji for help. He is the disk guru. Send him a private message.
http://www.sevenforums.com/member.php?u=163641
My System SpecsSystem Spec
Reply

 External Hard drive, computer does not recognise and I/0 device error




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
My computer is not see my External Hard drive
At first part of my hard drive was "not allocated" so I downloaded Test Disk to try to fix it. However instead of fixing it now the whole storage device is not being seen by my laptop. I'm sure it is because on test disk I clicked on no partition for the device. Can somebody help me please-I'm...
Hardware & Devices
i/o device error external hard drive please help me anyone
can anyone please help me? I divided 1TB WB Element to 4 part but they're not showing up on 'my computer' but i can safely remove the hardware, still the partition doesn't show up as usual just 'eject elements 1042'. can it get repair without losing the files?
Hardware & Devices
External hard drive not recognized on anything other than device mgr
My WD Elements external hard drive was working great until one day it failed to be recognized in explorer. I've tried it on multiple PC's and it does the exact same thing. It shows up in device manager as properly working and also even shows up in devices and Printers and BIOS and Windows will...
Hardware & Devices
Windows will not recognise microphone input from external sound device
Hi, I'm running Windows 7 Home N SP1 x64. I'm using an M-Audio Fast-Track Pro device to record audio into a music sequencer (Cubase 5), through a Shure SM58 Microphone. The M-Audio box is connected to the computer via USB. I've been using this set-up for about a year now and it hadn't caused me...
Sound & Audio
External hard drive found as unknown device
I have a LaCie external hard drive which works fine on other pc's running Windows 7 Ultimate, but on this one it is an "unknown device". I have tried it in different ports but with the same result. I've checked with Windows Compatability and the exact model is listed there as being compatible. I've...
Hardware & Devices
Windows will not recognise my backup image on external hard drive?
Hey guys, I restored my computer from the windows 7 CD that came with my computer and when I went to restore my computer to a backup that I had put on my external hard drive, windows will say that it cannot find any backups. Is there anyway I can fix this? I know my backup works because I first...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App