Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB ports not working on clean install of windows 7. How to fix?

25 Oct 2016   #11
EJGlass

Win 7 64bit
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
Glad you've done it.
Just to know, was the drivers I've attached on post nș4?
Those drivers worked from the 64bit dir.

Thanks again!


My System SpecsSystem Spec
.
Reply

 USB ports not working on clean install of windows 7. How to fix?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
After new motherboard install - usb ports - dvd drive; ect not working
I am an absolute newby at this , so my apologies in advance, if I did stupid things - I google and do what people had found to work in the past. FYI: got all the drivers from the Acer website and installed them - there is no exclamation marks in device manager, all drivers installed and working...
Drivers
Clean Install Win7 x86. Windows Updates not working :-(
Thank you for reading through these for me. I hope you can help me get this working. I appreciate it so much!
Windows Updates & Activation
USB ports (3.0) no longer working after Windows 7 Re-Install.
Before I begin sorry if this is in the wrong part of the forum, please direct me if this is the case or there is a similar thread. I have been looking online and although people have had similar situations I feel a tailored answer would be ideal if possible. I purchased an Asus N56VM laptop...
Hardware & Devices
Sound not working at all after clean install of Windows 7
I got a new computer custom built a few months ago, but it came with Windows 7 32 bit, so I decided to wipe it clean and install 64 bit, for gaming purposes. It installed fine, games ran a lot smoother etc, sound was working at this point. The sound still worked up until a few days ago, when...
Sound & Audio
Boot config not working, tried clean install, can't install windows 7
My spouses pc all of a sudden wouldn't boot, not into safe mode or anything (vista), and so we were going to upgrade anyways to windows 7, so i bought the upgrade windows 7 and attempted to do a clean install and reformatted the c: drive which has 250gb, and each time i start the install it bogs...
Installation & Setup
after clean install my pcs ethernet ports and wireless card wont work
i did a clean install on my pc useing my windows 7 retail disk and now i cant connect to the internet useing my laptops ethernet ports or the built in network card i just bought the pc yesterday and now the ethernet ports are not functioning neither is the wirelesscard before i did the clean...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App