Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB ports not working on clean install of windows 7. How to fix?

24 Oct 2016   #1
EJGlass

Win 7 64bit
 
 
USB ports not working on clean install of windows 7. How to fix?

asus rog g751jy-vs71(wx) "one drive, dual boot" windows 10 Home Premium 64bit, and 7 Pro 64bit

In W7, When Booting the USB works fine and I have a mouse, but when it gets to the login screen the keyboard and mouse just go black and do not function at all in W7. W10 works fine all the time.

I installed W7 after W10 and got everything loaded for SP2 and so on(using the pad/keys on the laptop), all drivers install fine and W7 updates are all in.

In order to even get into W7 though I must go into BIOS and turn off security settings and turn on CSM. Also must turn off Fast boot function. Not doing these things just locks the W7 load screen where the color dots are in mostion then lock.

Is there a way to get the USB to be working on W7 from login screen and into desktop?

Am using the W10 Dual boot selection screen after install of W7 used "bcdboot %windir%" to set that up.

Will I need to redo the W7 install? (Hope not)

Any suggestions?

Robert


My System SpecsSystem Spec
.
24 Oct 2016   #2
georgeks

Windows 10 Pro x64
 
 

W7 had no support from USB3.0 out-of-the-box.
Use USB 2.0 ports (black) and after log-on install the drivers.
My System SpecsSystem Spec
24 Oct 2016   #3
EJGlass

Win 7 64bit
 
 

Quote   Quote: Originally Posted by georgeks View Post
W7 had no support from USB3.0 out-of-the-box.
Use USB 2.0 ports (black) and after log-on install the drivers.
I only have 3.0 ports (4) on the laptop. Will this machine then never run win 7Pro? (My disk version of Pro does have all support OOB)
My System SpecsSystem Spec
.

24 Oct 2016   #4
Megahertz07

Windows 7 HP
 
 

Try the one attached


Attached Files
File Type: zip USB3.zip (4.03 MB, 3 views)
My System SpecsSystem Spec
24 Oct 2016   #5
EJGlass

Win 7 64bit
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
Try the one attached
I attempted to install by right clicking on the .inf files and they come up with "this file does not support this type of installation"

Thanks anyways though!
My System SpecsSystem Spec
24 Oct 2016   #6
Megahertz07

Windows 7 HP
 
 

You have to install them with Device Manager.
You're going to see a Missing driver - Make it search for the drive on the folder with drivers.
My System SpecsSystem Spec
24 Oct 2016   #7
EJGlass

Win 7 64bit
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
You have to install them with Device Manager.
You're going to see a Missing driver - Make it search for the drive on the folder with drivers.
OK I will get back to this tomorrow when I have time.

Thanks!

Let you know if it works then.
My System SpecsSystem Spec
24 Oct 2016   #8
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Just use Asus EZ Installer software to create a usb installer, you need a working PC, a Windows 7 install disc or iso on that same computer, a flash drive and of course the software from Asus.

It`s a piece of cake.

ASUS USA

The software walks you through step b step.

Scroll down to method 2

[ Desktop PC/All-in-One] Windows 7 and USB 3.0 driver installation for Skylake(H110/H170/Z170/B150/Q150/Q170) and Braswell platform


Attached Thumbnails
USB ports not working on clean install of windows 7. How to fix?-capture.jpg  
My System SpecsSystem Spec
25 Oct 2016   #9
EJGlass

Win 7 64bit
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
You have to install them with Device Manager.
You're going to see a Missing driver - Make it search for the drive on the folder with drivers.

OK I have installed the 64 bit versions and they are working fine now.

Thank You VERY much!!!!

This was becoming a headache the size of Texas(if you know what I mean)

I am closing this thread now since it is solved for me at least.
My System SpecsSystem Spec
25 Oct 2016   #10
Megahertz07

Windows 7 HP
 
 

Glad you've done it.
Just to know, were the drivers I've attached on post nș4?
My System SpecsSystem Spec
Reply

 USB ports not working on clean install of windows 7. How to fix?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
After new motherboard install - usb ports - dvd drive; ect not working
I am an absolute newby at this , so my apologies in advance, if I did stupid things - I google and do what people had found to work in the past. FYI: got all the drivers from the Acer website and installed them - there is no exclamation marks in device manager, all drivers installed and working...
Drivers
Clean Install Win7 x86. Windows Updates not working :-(
Thank you for reading through these for me. I hope you can help me get this working. I appreciate it so much!
Windows Updates & Activation
USB ports (3.0) no longer working after Windows 7 Re-Install.
Before I begin sorry if this is in the wrong part of the forum, please direct me if this is the case or there is a similar thread. I have been looking online and although people have had similar situations I feel a tailored answer would be ideal if possible. I purchased an Asus N56VM laptop...
Hardware & Devices
Sound not working at all after clean install of Windows 7
I got a new computer custom built a few months ago, but it came with Windows 7 32 bit, so I decided to wipe it clean and install 64 bit, for gaming purposes. It installed fine, games ran a lot smoother etc, sound was working at this point. The sound still worked up until a few days ago, when...
Sound & Audio
Boot config not working, tried clean install, can't install windows 7
My spouses pc all of a sudden wouldn't boot, not into safe mode or anything (vista), and so we were going to upgrade anyways to windows 7, so i bought the upgrade windows 7 and attempted to do a clean install and reformatted the c: drive which has 250gb, and each time i start the install it bogs...
Installation & Setup
after clean install my pcs ethernet ports and wireless card wont work
i did a clean install on my pc useing my windows 7 retail disk and now i cant connect to the internet useing my laptops ethernet ports or the built in network card i just bought the pc yesterday and now the ethernet ports are not functioning neither is the wirelesscard before i did the clean...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App