Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 3 GB visible of 4 GB Ram on 64-bit Windows

2 Weeks Ago   #11
matharoo

windows 7 32bit
 
 

Quote   Quote: Originally Posted by samuria View Post
If the video is showings extra memory and you add the extra to what Windows is reporting that seems to account for it all
Okay but how do I fix it? How do I reduce the extra memory used by video and assign it to the main memory?


My System SpecsSystem Spec
.
2 Weeks Ago   #12
Megahertz07

Windows 7 HP
 
 

Try Shared Memory on BIOS settings.
My System SpecsSystem Spec
2 Weeks Ago   #13
matharoo

windows 7 32bit
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
Try Shared Memory on BIOS settings.
There is no such option.
My BIOS is similar to this one: Phoenix - Award BIOS simulation and help

And here are all the screens, have a look and see what can be tried:





















img
My System SpecsSystem Spec
.

2 Weeks Ago   #14
Megahertz07

Windows 7 HP
 
 

What you have under Advanced Chipset - VGA settings - PEG - Onchip VGA control?
My System SpecsSystem Spec
2 Weeks Ago   #15
matharoo

windows 7 32bit
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
What you have under Advanced Chipset - VGA settings - PEG - Onchip VGA control?
Okay I'll see tomorrow if that works
My System SpecsSystem Spec
2 Weeks Ago   #16
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

According to Resource Monitor you have NO memory dedicated to video (nothing is showing as hardware reserved)

But, you only have 3070 MB of memory showing up, something is definitely wrong.

Although you said CPU`z shows the correct amount.

That`s 1026 MB not showing up in Resource Monitor, where is it

Maybe it`s just a glitch, take the memory out, start the PC without memory, let it give you the beeps, shut it down and reinstall the memory.

Then restart the PC, give us the results.
My System SpecsSystem Spec
2 Weeks Ago   #17
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Having the complete System Specs would be helpful.

Any way check the motherboard manual and see what the default is for Gate A-20.
My System SpecsSystem Spec
2 Weeks Ago   #18
mjf

Windows 7x64 Home Premium SP1
 
 

Apparently you haven't bothered checking the msconfig boot settings.
My System SpecsSystem Spec
2 Weeks Ago   #19
matharoo

windows 7 32bit
 
 

Quote   Quote: Originally Posted by Layback Bear View Post
Having the complete System Specs would be helpful.

Any way check the motherboard manual and see what the default is for Gate A-20.


Quote   Quote: Originally Posted by mjf View Post
Apparently you haven't bothered checking the msconfig boot settings.
What else do I need to check? The current settings are Normal Startup and the Maximum Memory option is unchecked. I have even tried setting the Maximum Memory to 4096, but to no avail.

Quote   Quote: Originally Posted by AddRAM View Post
According to Resource Monitor you have NO memory dedicated to video (nothing is showing as hardware reserved)

But, you only have 3070 MB of memory showing up, something is definitely wrong.

Although you said CPU`z shows the correct amount.

That`s 1026 MB not showing up in Resource Monitor, where is it

Maybe it`s just a glitch, take the memory out, start the PC without memory, let it give you the beeps, shut it down and reinstall the memory.

Then restart the PC, give us the results.
Doesn't make any difference... I even swapped the RAM sticks..

-----------
What could this be? It is kind of weird that where programs like HWMonitor/CPU-Z show the correct amount of RAM, even the BIOS shows wrong RAM (3GB).
My System SpecsSystem Spec
2 Weeks Ago   #20
matharoo

windows 7 32bit
 
 

I just read a similar thread on Tom's Hardware and the OP's issue was solved by updating their BIOS. My BIOS is a Pheonix-Award BIOS version 6.00PG and MB is Intel AWRDACPI. Any help on how to update would be great. Meanwhile I'm searching too.

sorry for the double post, i don't use forums much

EDIT: I just read on many sites that updating the BIOS can be a dangerous task and can even brick the computer. I think I will just live with 3 GB Ram, however, I read somewhere that still having 2x2 RAM instead of 2x1 is better for a PC. Is that true?
My System SpecsSystem Spec
Reply

 3 GB visible of 4 GB Ram on 64-bit Windows




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows Explorer [+] [-] boxes always visible
Windows Explorer boxes always visible In Ultimate 7 Windows Explorer among the many crimes I have solved without resorting to the very fine helper Classic Shell is the mystery of the boxes in the left explorer windows pane remaining visible after cursor departure. I do NOT want Triangles in...
Installation & Setup
Bitlocker drives/partitions are not visible in windows 8
Hi, I was using windows 7 with 3 partitions and had made bitlocker ON to my 2 partitions. Now after upgrading it to windows 8, my 2 drives (those with bitlocker) are not visible. If i try to install Win 7 again then it is showing a single partition. I am afraid if i install Win 7 again, all...
System Security
How to make startup password visible windows 7??
Hi. My uncle is new to computers. The password he used when he first started up his laptop would show as he typed it but now it does not. It only shows dots as he calls them when he types. He wants it to show. Is there a setting that can be changed? I have been unable to locate that setting on my...
General Discussion
Windows XP Machine not visible on Network
I just set up my home network (from scratch) so I could have all my devices in communication with each other. I have 2 PCs running Win 7 x64, an XBOX 360, and one PC with Win XP/SP3. I reset the router and recreated the network, and the win 7 machines can see each other perfectly, but I still cant...
Network & Sharing
IDE HDD not found by Windows 7; visible in Bios
I recently recieved some used computer parts from a friend. These parts are Window7 compatable as he was running the RC on them before he sent them to me. When I got them, I added my Power supply, Case, IDE Hard Drives and CD/DVD Burners. When I had everything wired up and in the case, I was...
Hardware & Devices
Contents of CD/DVD not visible in Windows Explorer
I'm using 7057. Not sure when this problem started as I don't use CDs or DVDs that much. The drive works fine, ImgBurn works fine, all other programs seem to see the files on a disk fine, they just don't show up in Windows Explorer. I click on the drive in the "Navigation Pane" and nothing happens....
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App