Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem with ZTE MF637 on Windows7


04 Dec 2009   #1

Windows 7
 
 
Problem with ZTE MF637 on Windows7

Hello everyone,

Two weeks ago I bought a 3G modem ZTE MF637 HUSPA, it works fine on Windows XP and Vista, but it doesn't work on Windows 7.

Windows 7 just won't recognize it, I couldn't find solution for that.

Please help me.


My System SpecsSystem Spec
.

25 Dec 2009   #2

windows 7
 
 

I want to help after
My System SpecsSystem Spec
28 Dec 2009   #3

windows 7
 
 

I want to help after
My System SpecsSystem Spec
.


Reply

 Problem with ZTE MF637 on Windows7




Thread Tools



Similar help and support threads for2: Problem with ZTE MF637 on Windows7
Thread Forum
I have Problem with windows7 at setup Installation & Setup
I have Problem with windows7 at setup Hardware & Devices
Windows7 and xp networking problem Network & Sharing
Windows7 Mouse Problem Hardware & Devices
Another windows7 update problem.. Windows Updates & Activation
xp32 to windows7 x64 problem ! Installation & Setup
Problem installing Windows7 RC1 Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:37 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33