Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: LG optical drive won't burn DVD in AHCI mode

19 Dec 2009   #1

Windows 7 Home Premium 64 bit
LG optical drive won't burn DVD in AHCI mode

My LG optical drive, model GH22NS40, popularly called "Super Multi DVD Rewriter", running on Windows 7 64 bit, will not burn a DVD-R if the SATA controller is in AHCI mode. All other optical drive functions work OK -- reads and burns CD-R, reads DVD. Attempting to burn DVD using Windows 7 Explorer gives this error:

Dialog name: Burn to Disc
Insert a disc
"There is no disc in the CD or DVD burner.
Please insert a writable disc into drive d:."

Switching to IDE mode in motherboard BIOS solves the problem. However this causes all SATA devices to work in IDE mode. I have several SATA hard drives, so would prefer running them in AHCI mode.

Other config details:

Driver date: 6/21/2006

cdrom.sys: 6.1.7600.1385 (win7_rtm.090713-1255)
PxHLpa64.sys: 3.00.67a

EVGA P55 FTW, i7-860 @ 3.78Ghz, 8GB Mushkin Enhanced DS1600-6G HP3-12800
Windows 7 Home Premium 64-bit
300GB SATA WD Velociraptor WD3000HLFS-01G6U0
2 x SATA Seagate Barracuda ST31500341AS

My System SpecsSystem Spec
19 Dec 2009   #2

Windows 7 Professional x64

Hello joema,

Can you go into Device Manager and verify that your optical drive drivers are up-to-date?

My System SpecsSystem Spec
19 Dec 2009   #3

Windows 7 Home Premium 64 bit

Yes, it says "Windows has determined the driver software for your device is up to date."

I have an updated firmware file for the optical drive, but LG says don't install it to solve this problem. Unfortunately I don't know how to inspect the current firmware version.
My System SpecsSystem Spec

19 Dec 2009   #4

Windows 7 Professional x64

Neither do I, to be honest. Can you find drivers on LG's support section?
My System SpecsSystem Spec
19 Dec 2009   #5

XP, Vista, W7 64bit Home Premium

Something I did when i was first confronted with AHCI was to contact seagate and they told me todays sata drives are made to work independently, and dont need AHCI enabled, so they work the same in IDE mode as they do with AHCI enabled, and the only real advantage of AHCI is having Hotswapping enabled if you have external hard drives.
So to confirm this, if you want, just look at your hard drive score in windows performance index, it should be the same and hence you havent a problem Merry Christmas.

On a gloomy note I m not sure about the raptor drive, but it if you have the OS on that drive just check the index score.
My System SpecsSystem Spec
20 Dec 2009   #6

Linux CENTOS 7 / various Windows OS'es and servers

Hi there

Can't understand the problem as I've got an "almost" identical device.

Just ensure you haven't got any "jumpers" incorrectly set (Slave / Master etc). Also ensure cleanly inserted into SATA slot -- try changing the cables.

Here's my hardware list (pic enc)


Attached Images
LG optical drive won't burn DVD in AHCI mode-dvds.png 
My System SpecsSystem Spec
20 Dec 2009   #7

Windows 7 Home Premium 64 bit

Quote   Quote: Originally Posted by whest View Post
...seagate...told me todays sata the same in IDE mode as they do with AHCI enabled, and the only real advantage of AHCI is having Hotswapping enabled if you have external hard drives....
I did some basic perf. tests with HDTach, PC Passmark, and xcopy. Performance for both Velociraptor and Barracuda seemed the same in IDE as AHCI mode, so it's not hurting performance. I have some external eSATA drives I'd ideally like to hot swap, but that's a minor thing -- I could live with IDE. Just wanted to report the situation for reference.

LG doesn't have any updated drivers for the optical drive -- they say use the Windows driver.

I'll try the updated LG firmware...
My System SpecsSystem Spec
07 Dec 2010   #8

win7 U

I have a LG GH22NS30 with firmware 2.00 , noticed that DVD burns suddenly became less reliable so I investigated. The issue seems to be the AHCI mode of the SATA controller. When I return to "enhanced IDE" mode the drive works perfectly, again .

I'm using Verbatim DVD-Rs and ImgBurn.
My System SpecsSystem Spec

 LG optical drive won't burn DVD in AHCI mode

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
SATA Mode IDE or AHCI when you have a SSD drive?
Hi I bought a ASUS P8H61-M LX Mother board for core i3 processor and a ADATA S510 6GB/s 60GB SSD currently i have maxtor 250GB Hard disk and BIOS SATA mode is set to IDE. To get maximum performance should i install windows on SSD ? which SATA mode should i use in BIOS settings?
Hardware & Devices
IDE mode to AHCI mode - can I change it on an OS drive?
Hello, I have bought a new SSD which I plan on using as a program drive, though not as OS drive (will reinstall Windows in the next few months). Currently I am running Windows 7 Pro 64bit. My OS is installed on a Western Digital 2TB drive. It is set to run in IDE Mode currently. My...
Hardware & Devices
Should I run my optical drive on AHCI or IDE?
Hiya Today I'll be building my computer and my mobo runs the SATA port(the one for the optical drive) in AHCI mode by default, was wondering would you guys recommend running it in AHCI or IDE for my blu ray drive? If AHCI should be used, will I need to install any drivers or set up anything...
Hardware & Devices
can't boot from cd/dvd sata drive/AHCI mode
Is it just plain not possible to boot from a CD/DVD drive that is set in BIOS as SATA/AHCI mode? I can acces the drive & read/write from it, it just won't boot to it. Yes I have CD/DVD drive set as 1st boot drive. I have "Googled" the earth & can't seem to find a straight answer to this. Can anyone...
Hardware & Devices
AHCI mode stopped reconizing Hard Drive
Yesterday my Wife's laptop stopped booting for her so I started to troubleshoot it. What I've discovered is: - If the BIOS setting for the hard drive controller is AHCI it will not recognize the drive. (This was the default setting in the BIOS) - If changed to IDE mode it recognizes...
Hardware & Devices
AHCI mode no boot from sata optical drives
A strange problem, nothing critical, but I found it annoying that my optical sata drives will not boot from a bootable disk when in AHCI mode in Bios. If I switch the drive mode to native IDE then I can boot just fine from either of the Opitcal Sata drives. I have done some searching and found...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:15.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App