Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: usb ports have stopped working


01 Jan 2010   #1

windows 7
 
 
usb ports have stopped working

usb ports were working fine for my headset and wireless mouse/keyboard receiver just two days ago. today first my headset wouldnt work when i plugged it into the one outlet, then i tried in the other outlet and got no luck, and my wireless reciever wouldnt work after i plugged it back in either. and the usb ports have not worked since. usually it gives me no indication that it found something is plugged in but sometimes it will give me a message in a little pop-up bubble saying
" USB Device Not Recognized"
one of the usb devices attached to this computer has malfunctioned, and windows does not recognize it. for assistance in solving this problem, click this message

clicking the message brings us a screen that shows the 3 available usb ports, with an unknown device in one of them. at the bottom it says a recommendation to try reconnecting it and if windows still doesnt recognize it, replace the device.

this device has always worked without any problems for the 3 months ive owned this computer and so has the headset so im pretty convinced the devices arent the problem.


My System SpecsSystem Spec
.

01 Jan 2010   #2

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by obadagibidaz View Post
usb ports were working fine for my headset and wireless mouse/keyboard receiver just two days ago. today first my headset wouldnt work when i plugged it into the one outlet, then i tried in the other outlet and got no luck, and my wireless reciever wouldnt work after i plugged it back in either. and the usb ports have not worked since. usually it gives me no indication that it found something is plugged in but sometimes it will give me a message in a little pop-up bubble saying
" USB Device Not Recognized"
one of the usb devices attached to this computer has malfunctioned, and windows does not recognize it. for assistance in solving this problem, click this message

clicking the message brings us a screen that shows the 3 available usb ports, with an unknown device in one of them. at the bottom it says a recommendation to try reconnecting it and if windows still doesnt recognize it, replace the device.

this device has always worked without any problems for the 3 months ive owned this computer and so has the headset so im pretty convinced the devices arent the problem.
Have you updated drivers or downloaded any programs in the last 2-3 days?

Can you see them in your device manager? computer>system properties>device manager (left)>Universial serial bus controllers (usb)
Any yellow triangles?

A system restore would more than likely fix it if your really stuck.
My System SpecsSystem Spec
02 Jan 2010   #3

XP, Vista, W7 64bit Home Premium
 
 

Have you been to your driver page for the latest Windows 7 drivers? There is a ATI chipset driver that maybe of help - select desktop model / your version of Windows 7 :
Service & Support
My System SpecsSystem Spec
.


02 Jan 2010   #4

microsoft windows 7
 
 

hey there,

my mouse stopped working aswell several weeks after i installed Win 7.
This is caused by the mouse driver.
also a lot of other drivers start causing trouble after some weeks.
most drivers aren't compatible with Windows 7 and have to be updated.
many of these updates are not yet downloadable at this moment.
My System SpecsSystem Spec
02 Jan 2010   #5

windows 7
 
 

The wireless mouse and keyboard are actually microsoft products and i did go to the microsoft page to try and find new drivers for them. i downloaded the driver for this product but im not sure if it was even an update i think it was just the regular driver for it. Anyhow it made no difference, and i searched for updates for my usb drivers manually through the device manager, that also didnt help. Apparently microsoft products arent even compatible with windows 7.

not sure what u mean by the driver page whest but i couldnt find that download youre referring to

sometimes my device manager will recognize that there's something plugged in and it show a yellow triangle
on the usb port saying unknown device, sometimes it doesnt recognize that anything is even plugged in.
I have this comp configured to automatically search for updates so i dont know if there were any recent changes made.

i've since tried pluggin in my ipod and a mini usb storage device, which have always worked on this but i havent used them for a while, and they also get no response. my ipod will blink on when i plug it in, but no response from the computer, no response on itunes.
My System SpecsSystem Spec
02 Jan 2010   #6

microsoft windows 7
 
 

I have just updated the usb drivers with a Windows 7 compatible update (says the site).
it didn't stop the problems and at other forums is everyone still trying aswell.

I just don't understand that it works perfectly in the beginning and suddenly it starts giving trouble.
so, i've tried today to get the correct drivers for all hardware but, could only find 2 drivers that were win 7 compatible. and there are 23 drivers who are old or possibly not-compatible.

just keep searching, it can't take very long till someone finds the selution.

if i find something i'll let you know.

greatzz
My System SpecsSystem Spec
02 Jan 2010   #7

XP, Vista, W7 64bit Home Premium
 
 

Click on the link in my last post - in the select product family select desktop - in the select product line select aspire - in the select product model select aspire m3203 - NOW YOUR ON YOUR DRIVER PAGE - the page defaults to windows vista basic 32 bit, so in the operating system drop down list select your version of Windows 7. Then you will see the ATI Chipset driver - download and install.
Post back if this doesnt work I have one other idea.
My System SpecsSystem Spec
02 Jan 2010   #8

Windows 7 x86
 
 

Shut down and then switch off the power on the back of the PC. wait a couple minutes then turn back on, boot computer. Should reset the ports.

USB hubs are always alive even after a shutdown, if they error in any way they will not recover until all power is removed from the MoBo.
My System SpecsSystem Spec
03 Jan 2010   #9

windows 7
 
 

I tried turning off my comp and unplugging it for 5 or 10 mins ( there's no power switch on the back) and that changed nothing.

downloadaed the ATI chipset and that didnt help either
My System SpecsSystem Spec
03 Jan 2010   #10

XP, Vista, W7 64bit Home Premium
 
 

Can you go into device manager - right click Computer - select properties - device manager - expand
1 IDE ATI/ATIPI controllers
2 Universal Serial Bus Controllers
and take a screen shot, and attach it to your next post.
My System SpecsSystem Spec
Reply

 usb ports have stopped working




Thread Tools



Similar help and support threads for2: usb ports have stopped working
Thread Forum
Suddenly all USB ports stopped working on win 7 Hardware & Devices
USB Ports Stopped working after an Internal Power Jack is replaced. Hardware & Devices
Both USB ports on laptop suddenly stopped working Hardware & Devices
USB ports stopped working Drivers
USB ports stopped working right... Hardware & Devices
All USB ports stopped working Drivers
USB Ports Stopped Working Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:28 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33