Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Rosewill RC-200 raid card issues with Windows 7

03 Jan 2010   #1

Rosewill RC-200 raid card issues with Windows 7


First post.. I just installed Windows 7 and for the most part all went ok. The only issue I seem to be having concerns my Rosewill RC-200 IDE raid card. Card works fine as an IDE card. However, I cannot get the raid functions to work.

The card uses a “Silicon Image SiI 0680 ATA-133 Medley Raid Controller” chipset. The only thing I found a bit odd about the install was that W7 recognized the card and installed its own drivers instead of asking for drivers supplied by the manufacture. Not sure if this is an issue or not, but I have had to remove the raid set for now until I figure out what is wrong

Most of my hardware is new, MSI 770-C45 mobo, EVGA 9500GT video, Rosewill RC-200 PCI card.
I plan on calling the manufacture on Monday but thought I would check to see if anyone else has had this particular problem.

My System SpecsSystem Spec
29 Jan 2010   #2


Bump... Anyone... I noticed that the driver version reported by W7 is while the manufacture shows only as being the latest.

Any thoughts...

My System SpecsSystem Spec
29 Jan 2010   #3

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE

Update the driver. Even with the discrepancy in version numbers, I would try what the manufacturer shows. The worst that would happen is that the raid still won't work.
My System SpecsSystem Spec


 Rosewill RC-200 raid card issues with Windows 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Issues with RAID and AHCI
So when I first got my SSD I set my motherboard from IDE or AHCI. For a while it ran great. However, now I want to start experimenting with RAID. I picked up a few drives and they are all recognized. However, now I cannot switch from AHCI to RAID on that specific setting without my windows...
PC Custom Builds and Overclocking
Rosewill N300 PCI Wireless Card Broke my Realtek HD Audio
To start off, I'll tell how it all happened. First, almost 3 months ago I bought a PCI Wireless card from newegg, it came in a week later and it was defective. I returned it for a new one and got it another two weeks later (Very slow shipping). It was working, but when I installed what was on the...
Sound & Audio
Poor SSD performance: AMD RAID and AHCI Issues. WEI 5.9
I recently upgraded to an SSD. I moved windows 7 over to the new SSD and re-aligned the partition properly The drive setup is as follows: 2x 500GB WD Black drives in RAID 0 1x 120GB ADATA S510 SSD In BIOS, RAID mode is enabled. You cannot enable RAID for one pair of drives and AHCI...
Performance & Maintenance
Rosewill RX-358 ext. hardrive. Safe to operate with fan off? - Rosewill RX-358 V2 SLV (Silver) 3.5" SATA to USB & eSATA External Enclosure w/Int.80mm Fan Here's a link to my product. I've got a 2 TB WD green drive in it. I'm wondering if I can turn the fan switch off on this when this is hooked up to my popbox media player which reads my 1080p...
Hardware & Devices
Booting issues after moving RAID from one mobo to another.
This is a bit unusual, and I've not anyone discussing this before. I changed my older MSI motherboard to a newer one. I had RAID on the old one using an expansion card; but the new mobo has a built-in RAID, so I hooked up the drives (SATA) directly to it. AFter establishing the RAID, it looks...
Installation & Setup
Audio Card Issues: Windows 7 32-Bit
I have Windows 7 32-Bit installed onto a Dell Studio 1535 laptop, with an Intel hi-def sound card. The OS recognized the card on boot, but won't let me install the Intel IDT drivers and doesn't recognize the mic port. The sound card is such that the rear output changes to a microphone input when...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:43.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App