Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IDE (PATA) DVD drive not working


08 Jan 2010   #1

win7 32bit
 
 
IDE (PATA) DVD drive not working

My LH-20A1H (ll0dh) dvd drive is not working in Windows 7. It works fine in XP and ubuntu. However after the very first part of the windows 7 RTM install (both for 32 and 64 bit RTM versions..i tried both) it gets stuck at 0% of expanding files. So, in XP I copied Windows 7 to a usb drive and installed it that way. But the dvd drive still isn't working.

It spins-up and the read light does not come on, and somehow with no read light, it will copy a few bits of data after a very very long time.. but nothing after that. Though if i eject the dvd, windows lets me know that it's missing it! SO if it knows its missing, why can't it read it?

This is what i have tested and found out:
I CAN do:
Audio CD's - Play, skip..etc
Video DVD - able to copy a copy to hdd
MP3 Data CD - was able to play mp3, was able to copy to hdd. However it took a few min before it started, and then the actual file transfer was fast. It started copying faster if an mp3 was bing played from it before i tried to copy.. weird? Afterwards playing mp3's from the cd is hit or miss.. it partialy works.

I CAN'T copy files from:
Microsoft Windows 7 - RTM, - it will copy a few small files and then, leaving the dvd spinning without copying anything else.
Microsoft Windows XP MCE 2005 - RTM - same as above.

It's almost seemes as if Windows 7 is tring to buffer 100% before it does anything. Causing lengthy delays. And i did notice that playing an mp3 did not turn on t he read light of the dvd drive.
SOO Frustrating

Windows 7 is installed on sata HDD with AHCI. Could it be that a mix of AHCI SATA drives with a PATA DVD is confusing the software??
I do have the latest chipset driver for the 975x, found it here


My System SpecsSystem Spec
.

09 Jan 2010   #2

XP, Vista, W7 64bit Home Premium
 
 

You may need to download and install the latest intel matrix storage manager software/driver because AHCI is enabled in your bios, and what happens during installation of Windows 7 is Windows 7 installs the Intel driver, but for correct functionality you need to install the intel matrix storage manager after installation is complete if you dont it will cause the problems with DVD & hard Drives.

You will find it at the intel site - http://downloadcenter.intel.com/default.aspx
Select chipsets - desktop chipsets - select chipset (express 975)- skip OS - select drivers(10) - select intel(R) matrix storage manager 8.9.0.1023 - download and install.

There is a mix up with download site so you need to skip OS to get to it now - once there you will see it supports Windows 7.
My System SpecsSystem Spec
09 Jan 2010   #3

win7 32bit
 
 

Thanks, at first that solved everything!?! But after i've shut down the computer a couple of times it has gone back to being the same problem. Is there something about the matrix driver like a service that might not be auto loading?

update: the "Intel(r) matrix storage event monitor" service says its started.. but restarting it hasn't fixed it like just after it was installed
My System SpecsSystem Spec
.


09 Jan 2010   #4

XP, Vista, W7 64bit Home Premium
 
 

Perhaps its booting to ubunta i dont know - i do know if you boot to xp it will delete restore points in vista or Windows 7 and they wont be available when you reboot to either of them. This is what I would suggest - dont boot to ubunta and boot to Windows 7 and see if it works again if that doesnt work reinstall the matrix driver, and see if it works again, once that is established shut down or reboot to Windows 7, and see if its still working - ok i m not sure you havent already considered this, but it has me baffled, and I dont know if you still have ubunta - but thats all i can think of. Maybe you can come up with something if you get it to work again. Also if it did work you would be limited to Windows 7 if there is anything in my guess.

My only other suggestion is to reinstall the OS - firstly disable AHCI, and use sata as IDE in the bios. If you try just changing it to IDE, and try to boot it could BSOD, if it does your options are limited to reinstalling the OS or change it back.

Fortunately there is a fix if you install Windows 7 when you have it set to IDE in the bios, so you could have more leverage if you do it this way having both options without having to reinstall the OS. If you read the fix you will get the picture - the AHCI driver microsoft installs works fine without the matrix driver so you wouldnt have to install it.

But no guarantees this will work, and IDE maybe the best choice - when i was fiddling with this with one of my copies of the Windows 7 rc back a bit (i used the microsoft fix method as outlined in the link below) after a few weeks i turned AHCI off and enabled IDE in the bios and Windows 7 could still locate the IDE driver, and it booted. I tried it with vista and no go.

* There is a major downside to this if you have other OS'S on the PC which have been installed with AHCI enabled, and you change it to IDE - they probably wont boot unless you switch in the bios firstly.

http://support.microsoft.com/kb/922976

I hope you can get it to work without having to try any of this is - its a lot of work and no guarantees it will work.
My System SpecsSystem Spec
09 Jan 2010   #5

win7 32bit
 
 

Ubuntu is gone. The XP and Windows 7 installs are completly seperate from one another, I have to choose which one i want to boot to from the bios (each thinks its the only OS) and obviously are on seperate drives. Prior to installing them I changed the bios hardrive boot sequence around, so each thought it was installing to the main HDD.
I tried uninstalling all the drives from the device manager in Windows 7 and deleted the drivers, and then reinstalled the intel chipset software and then the intel matrix software. Reboot/shutdown..still won't let me copy files off the dvd drive, and this prob is only in Windows 7.
My System SpecsSystem Spec
10 Jan 2010   #6

XP, Vista, W7 64bit Home Premium
 
 

Have you tried deleting filters this has worked for a lot of people with dvd drive issues (backup the registry folder they are in firstly - export to desktop), or create a system restore point- check to see if the filters are there firstly. It seems like it's more to do with the storage controller though, so dont get your hopes up. I would consider sata as IDE myself - i have read some threads with this when combining sata and pata. If you have a recent sata drive with NCQ the AHCI doesnt speed it up any, only with the older pata drive would there be a performance difference.
My other thought s are you messed it up somehow before or when you installed the matrix manager, and its corrupted now - you could run this to see -
Right click command prompt select run as an administrator and type this in the window: SFC /scannow

Your CD drive or DVD drive is missing or is not recognized by Windows or other programs

There is something weird going on with your motherboard - ive been to asus site and found xp supports the intel matrix driver but vista only has drivers for the j-micron controller - i dont know what this means - if you could try the j-micron controller you might get somewhere - Im not sure how this works ie, whether it automatically disables the intel controller when its enabled or not or whether you have to change cables or whether they are redirected- check your manual - click downloads - do this as a last resort.
http://www.asus.com/product.aspx?P_I...tQa&templete=2

Note there are no Windows 7 drivers - this is a bad sign that suggests there is an issue of some sort, probably the one you have found. XP might be the best option .

I've typed your motherboard into the forum search - there is a lot of results and the first 2 pages I've found the exact same problem your having but no fix as of yet - can you update your bios to the latest version that will remove that possibilty.
I wll put up the result link and you can search thru it also - ill keep looking for a while and do another one to try and narrow it down.

http://www.sevenforums.com/gtsearch....sa=Search#1026

Narrowed down
http://www.sevenforums.com/gtsearch....sa=Search#1074

Found someone fixing it with a firmware update for dvd (different to yours though but it seems to be related to which dvd/cdrom you use):
http://us.liteonit.com/us/index.php?...1&limitstart=2

Please post back if you find anything that works.
My System SpecsSystem Spec
12 Jan 2010   #7

win7 32bit
 
 

Thanks for all the help. I broke the dvd drive somehow. Possibly by leaving it run and try to read forever.. because it no loger works in XP either. Now it's giving me a I/O error.
Soo, I swaped it with a LG and not the Lite-On brand i had. Not its working.
And I'm also happy to report that Windows 7 64bit RTM is working so far without any issues on the Asus p5w-dh motherboard w/ bios 2801. It may be that i downloaded the 64bit intel chipset software for the floppy drive and loaded that driver in the very beginning of the OS install. I don't have the matrix driver loaded yet, but all seemed to be working.
My System SpecsSystem Spec
12 Jan 2010   #8

XP, Vista, W7 64bit Home Premium
 
 

You will notice a slowing down of data flow when transferring large amounts of data between the dvd rom and the hard drive if there is a problem caused by no matrix or it dissappearing altogether - good to see your got it fixed though - i bet you feel good now.
My System SpecsSystem Spec
Reply

 IDE (PATA) DVD drive not working




Thread Tools



Similar help and support threads for2: IDE (PATA) DVD drive not working
Thread Forum
Solved Wiping Old Pata Drives before Disposal ? General Discussion
Is there still an issue with using IDE/Pata devices? Hardware & Devices
PATA>ZIF For Laptop P7230 Hardware & Devices
Solved SATA VS PATA Optical Drives Hardware & Devices
Can I boot from a drive attached to a PATA to IDE converter? Hardware & Devices
SATA vs. PATA HDD's Hardware & Devices
pata install issue Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:04 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33