Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Problem with Sandisk USB

11 Jan 2010   #1

Win 7 Ultimate x64
 
 
Problem with Sandisk USB

I have a Sandisk Cruzer Titanium 4GB U3 usb-key, but after I insert it on my Win 7 machine, I see the following message:


However, I can still access all my files on it (at most of the times that I insert it, sometimes I can't). On XP machines it works fine. I have also tried formatting, as it keeps asking, but it asks again and again even after I had foramtted it. What the..?

My System SpecsSystem Spec
.

11 Jan 2010   #2

Windows 7 Professional x64
 
 

If you remove and reinsert the drive, does it sometimes go away?

I had a thumb drive once that did that. It was a sign that the drive was going. Sometimes it worked, sometimes it didn't.
My System SpecsSystem Spec
12 Jan 2010   #3

Win 7 Ultimate x64
 
 

Well I dunno, but as far as I remeber, I see the suggestion of formatting every time- I have also tried re-isnsering it about 5-10 times just a couple of seconds ago. But the U3 lauchpad and my files are still accessible even with that message.
Also, what do you mean by saying 'It was a sign that the drive was going.' ?
My System SpecsSystem Spec
.


12 Jan 2010   #4

Windows 7 Professional x64
 
 

I had to replace the drive soon after that. It was recognized less and less, until finally I got sick of it and threw it away.
My System SpecsSystem Spec
22 Mar 2010   #5

win 7
 
 

the problem, in some cases Win 7 does not check the Sandisk Cruzer micro 8 GB, i used three of it, all works very fine under win xp, one of these had problem by reconizigne them, it should be formatted

must be a problem in production , made in China !!!!
My System SpecsSystem Spec
22 Mar 2010   #6

Windows 7 Professional x64
 
 

Welcome Eddy!

Could it be a problem with your USB port rather than Windows 7? Try updating your USB and chipset drivers.
My System SpecsSystem Spec
29 Jan 2011   #7

Win 7 Ultimate x64
 
 

It's been a long time, but I think I fixed that. Hope this helps to anyone else, too:

Sandisk has released an update for U3 sticks to work flawlessly on Windows 7. It's instructed in detail there: U3 Launchpad update for Windows 7

You can find the Removal Tool and Lauchpad there: SanDisk Support (first remove the U3 soft that you have (remember to back up files) then install new version. You may need to do it twice, as noted on the link).
My System SpecsSystem Spec
29 Jan 2011   #8

Windows 7 Professional x64, SP1
 
 

I removed U3 right after I bought my 8GB Cruzer & never have had an issue. I just prefer using it without U3.
My System SpecsSystem Spec
Reply

 Problem with Sandisk USB





Thread Tools



Similar help and support threads for2: Problem with Sandisk USB
Thread Forum
Solved Samsung SSD vs. Sandisk Hardware & Devices
Club SanDisk Application Hardware & Devices
one problem with two sandisk drives Drivers
Backing up to a sandisk 8 gb cruzer Performance & Maintenance
Solved SanDisk Cruzer Flash Drive-AUTOPLAY problem Hardware & Devices
SanDisk SDCZ6 Not Working Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33