Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 reports wrong cpu speed?

14 Jan 2010   #1
Spot UK

XP Media center / Win 7 64bit
 
 
Windows 7 reports wrong cpu speed?

Iíve been running my CPU (Q9400) overclocked at 3.2 Ghz since I put windows 7 in, I have just changed my RAM and can now get my CPU to 3.3Ghz, only a little more I know but Windows reports the CPU at 3.2 Ghz still, CPUz is reporting 3.3Ghz, same as bios.

No big deal but does anyone know why it might do this?




Attached Images
 
My System SpecsSystem Spec
.

14 Jan 2010   #2
nate42nd

Windows 7 Professional x64
 
 

I have seen Windows do this before. It's so close, Windows is not a precision tool. Trust the BIOS and CPUZ when it comes to CPU frequency.
My System SpecsSystem Spec
14 Jan 2010   #3
Spot UK

XP Media center / Win 7 64bit
 
 

I see, so the latest state of the art version of Windows is not a precision tool

Sounds quite funny, but I see what you mean nate42nd, thanks for the reply.
My System SpecsSystem Spec
.


14 Jan 2010   #4
nate42nd

Windows 7 Professional x64
 
 

You would think it would be more "precise" but I have seen it wrong too many times.

I overclock too and I have seen it wrong a lot. i just look at the BIOS if I need to know.

Good luck.
My System SpecsSystem Spec
14 Jan 2010   #5
Mercurial

Windows 7 32bit RTM
 
 

UPDATE ur WIE
My System SpecsSystem Spec
14 Jan 2010   #6
Spot UK

XP Media center / Win 7 64bit
 
 

Run the WEI again but still reports as 3.2GHz, CPU has gone up from 7.3 to 7.4, so I know the extra MHz and faster RAM are doing something.
My System SpecsSystem Spec
19 Dec 2010   #7
sinvelikogmajst

Windows 7 home basic 32bit
 
 

what do you think about this? it doesn't show OC at all...


Attached Thumbnails
-prntccrn.jpg  
My System SpecsSystem Spec
19 Dec 2010   #8
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64
 
 

I don't believe that particular system window shows the processors actual speed but only what the manufacturers specified speed is.

It also doesn't show any downclocking done by power saving that CPUID will show.
My System SpecsSystem Spec
19 Dec 2010   #9
sinvelikogmajst

Windows 7 home basic 32bit
 
 

it shows oc corectly on my phenom ll x4 965
My System SpecsSystem Spec
19 Dec 2010   #10
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

Some of the older CPU's internal firmware including Intels don't send that info to Windows OS. Depends on the CPU and the version of Windows.

Your Phenom II x4 is a newer generation with newer firmware.

Mike
My System SpecsSystem Spec
Reply

 Windows 7 reports wrong cpu speed?




Thread Tools





Similar help and support threads
Thread Forum
BIOS reports wrong values in RAM, crashing AMD video card
Lately, I have installed 2x 4 GB RAM sticks into my HP Slimline s5-1200z a few hours ago, however, upon doing this, my graphics for my games have been messing up, and sometimes my AMD video driver will crash, causing major annoyance when trying to play any games I intend to play. :picnic: When I...
Hardware & Devices
Windows reports wrong graphics card
This has been a problem I had for a while now, my GPU is Ati 5850 but windows thinks is 3870, I go into dxdiag or a game for ex Deus Ex HR and there it is, it's not that big of a problem pretty much things work fine like DX11 but in DE:HR I can't select the advanced DX11 options because the system...
Graphic Cards
DIR 615 reports link at 300Mbps, windows reports 150Mbps
Hello there, Recently setup my home wifi network, i had been noticing that my link speed to any device through my Dlink DIR 615 router, was always 65Mbps (as reported by the device), i searched around that i should set the channel width to 'auto 20/40mhz' to gain speed; however now that i did...
Network & Sharing
Wrong clock speed!
Hi, I have a Q8400 @3.3GHz, but in My computer > Properties It only says 2.66, This was working some time ago, but now it wont, whats the problem? can i change some registry files to make it correct? please help!!
Hardware & Devices
Windows 7 showing wrong CPU speed.
I recently upgraded to Windows 7, and in Xp my overclock showed correctly. As 333X10.5=3500 but even though my bios settings are still the same and all c1e is turned off, windows 7 is showing that i have 266x10.5=2800. cpu-z shows this aswell, including asus utility (every program i've tried has...
Performance & Maintenance
Wrong Memory speed
I just finished building my new christmas pc :). It runs great, but the only problem is that my memory is supposed to be DDR3 1600, but when I boot my pc on the black screen ( BIOS post? Something like that ) it says something like DRAM 800. My Motherboard supports up to DDR3 1333. So my...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App