Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 4gb RAM. 2gb Usable. Win7 64bit.

22 Jan 2010   #1
zelink

Windows 7 64bit
 
 
4gb RAM. 2gb Usable. Win7 64bit.

Hi guys i've had this problem for a while now and haven't been able to find a solution and wondering if anyone can help.


my motherboard is a ga-p55-ud3 and i was told to upgrade the bios but the current one for my motherboard is beta and i'm a bit weary.

i had a friend build his new pc yesterday with exact same specs basically and his one is fine but i don't know where mine went wrong.

and the processor saying 2.67GHz and then 2.79GHz is that normal?


thanks for any help, much appreciated.


My System SpecsSystem Spec
.
22 Jan 2010   #2
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Do you happen to have OCZ Dimms?
My System SpecsSystem Spec
22 Jan 2010   #3
zelink

Windows 7 64bit
 
 

nope i have g.skill ripjaws i believe
My System SpecsSystem Spec
.

22 Jan 2010   #4
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Hmm, I was asking because the other day someone had exactly the same problem with OCZ Dimms. We all suspected it had something to do with the Dimms. He was going to exchange them for Crucial Dimms. No news since.
It could also be that the Dimms do not get enough power so that not all 4GBs show up. Maybe a slight increase of power would help.
At the time, we exercised all Windows7 possibilities, but nothing on the software side seemed to cure the problem.
My System SpecsSystem Spec
22 Jan 2010   #5
zelink

Windows 7 64bit
 
 

so what are my options? i read in the beta patch notes for my bios it says "enhanced memory capability" maybe thats got something to do with it? considering 2gb usable is an even number unlike the others i see around here like 2.75 gb usable and whatnot.
My System SpecsSystem Spec
22 Jan 2010   #6
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

The uneven numbers is a different problem. That is for 32bit systems where some of the address space was taken by other functions - e.g. video cards, etc. But you have a 64bit OS, so that does not apply.
For your problem I suspect it is somewhere between the BIOS and the Dimms. But I am not really an expert in that area. So I have to defer to someone else for specific actions.
My System SpecsSystem Spec
Reply

 4gb RAM. 2gb Usable. Win7 64bit.




Thread Tools




Similar help and support threads
Thread Forum
8gb memory installed - only 3.25gb usable Win7 64bit
8gb memory installed - only 3.25gb usable Win7 home premium 64bit. MSI MS-7358 mobo has no memory mapping facility. No on-board graphics. I have un-checked maximum memory in msconfig. Mobo states 8gb. Resmon shows 4gb reserved. All 4 x 2gb sticks are identical (crucial). Any ideas where to go next?
General Discussion
W7 64bit 8GB installed, 6.01 usable
This is my system: Lenovo H535 Processor: AMD A10-5700k Trinity APU @ 3.4ghz Allocated RAM: 8gb (6.01 usable) GPU: Integrated ATI Radeon 7660d Motherboard Chipset AMD A75 4MB L2 Cache What I'm asking is basically how do I force Windows 7 to use all 8gb worth of memory? Where's the other...
Hardware & Devices
64bit win7 4gb installed, 1.7gb usable
hey guys i have a problem about the memory i used to have win7 32bit, 4gb installed 1.7gb usable. people suggested to upgrade my OS to 64bit so i purchased a 64bit win7 ultimate OS same thing is showing
Hardware & Devices
On Windows 7 64bit only 1.99 of usable ram?
Hi, I've just installed Windows 7 Professional today (64bit) and I noticed that it only shows and uses 1.99 GB of ram, it used to show that too in 32 bit which I've been using until today, but I wanted to have a little bit more of useful ram, but nothing.. What should I do, because you can see...
Performance & Maintenance
64bit 4gb installed 3.12 usable?
Hi all, I have w7 installed with 4gb, but only 3.12 is usable. How come? Any ideas out there?
Hardware & Devices
Win 7 64Bit 6GB (3GB usable)
i am having some problems my win 7 64 bit is using only 3GB but i have 6GB my System: CPU: i7 920 Motherboard: GA-EX58-UD3R (rev. 1.0) F9 bios GPU: HD4850 Visiontek Ram: 3 x 2GB Corsair (cm3x2g1333c) Please i need any help.
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:51.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App