Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: usb Mass storage device is not working properly.

27 Jan 2010   #1
fuzz

windows 7 ultimate 64 bit
 
 
usb Mass storage device is not working properly.

Hello guys ...i am new one here ...
I have a serius problem .When i try to unplug or safe removal a device and especially wd passport essentials , or kingston data traveler , i get this error usb Mass storage device is not working properly.I cant find a solution for this problem ....See the picture


the light of the removable storages are on and i cant safely remove them .Is this a windows bug or this is a problem that i only have .,...

Thank you for the support .


My System SpecsSystem Spec
.
27 Jan 2010   #2
Jonathan_King

Windows 7 Professional x64
 
 

Welcome!

I can't think of a solution off the top of my head, so this will be trial-and-error.

Okay, so you plug in the drive, and what happens? Does the drive work properly?

Then you want to remove the drive. You click Safely Remove Hardware, and then it gives the error?

At what point did you take the screenshot above?
My System SpecsSystem Spec
27 Jan 2010   #3
fuzz

windows 7 ultimate 64 bit
 
 
the steps

ok i tell you the steps .....
First i plug the external drive .The drive work properly without a problem
When i finish my work , i go to safely remove from the taskbar .and i have this picture .
The external drive still works i hear the sound .I try this with all my external drives (3).
In xo i dodnt have that problem .When i was safely remove the external the disk was turn of .No sound , and no light .....Is that a problem ...
Tell me if someone have the same problem ...

Thank you so much ...for the help
My System SpecsSystem Spec
.

27 Jan 2010   #4
Jonathan_King

Windows 7 Professional x64
 
 

Tell me, are the drives still recognized in Windows after you try to eject them?

Go into Device Manager and find your drive. Right-click and select Properties. Go to the Policies tab, and select Adjust for quick removal.

See if that works.
My System SpecsSystem Spec
27 Jan 2010   #5
fuzz

windows 7 ultimate 64 bit
 
 

yes the drives stil regognized .... and worked very well
The adjust for quick removal is the default option ....i have this one ...
the error told me that .
Windows cannot use this hardware device because it has been prepared for "safe removal", but it has not been removed from the computer. (Code 47)

To fix this problem, unplug this device from your computer and then plug it in again.
My System SpecsSystem Spec
05 May 2010   #6
klinssman

windows 7
 
 

i have the same problem like Fuzz. is there any solution for this? its driving me crazy
My System SpecsSystem Spec
05 May 2010   #7
Jonathan_King

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by klinssman View Post
i have the same problem like Fuzz. is there any solution for this? its driving me crazy
First, does this problem happen with many devices, or just one?

Have you set the policy to Quick Removal?

Try updating your USB hub drivers, just on a hunch.
My System SpecsSystem Spec
05 May 2010   #8
klinssman

windows 7
 
 

Quote   Quote: Originally Posted by Jonathan_King View Post
Quote   Quote: Originally Posted by klinssman View Post
i have the same problem like Fuzz. is there any solution for this? its driving me crazy
First, does this problem happen with many devices, or just one?

Have you set the policy to Quick Removal?

Try updating your USB hub drivers, just on a hunch.

its the same with all of my usb things = (
yeah, i set to quick removal, i tried the update as well, but nothing changed
My System SpecsSystem Spec
08 May 2010   #9
fuzz

windows 7 ultimate 64 bit
 
 

is this a bug of windows 7 ?Anyone with this problem ?
My System SpecsSystem Spec
08 May 2010   #10
Redzombie22

MS Windows 7 Ultimate 32-bit
 
 

its only you guys. I could put USB plugs into my PC just fine
My System SpecsSystem Spec
Reply

 usb Mass storage device is not working properly.




Thread Tools




Similar help and support threads
Thread Forum
Mass Storage Device error
Hello everyone. I have a PC with Windows 7 Professional 64-bit installed. My problem is that with some usb devices I get an error 28. These devices are working on other PC. For example I have 2 usb sticks 16gb. The one is working fine, and the other has an error 28. I searched for viruses with...
Hardware & Devices
USB Mass Storage Device Problems
Hello People I need help pretty bad i tried alot of things and took me 4 hrs just attempting every single fix i find. OK lets get started Problem is i can't connect any kind of Portable Hard Drive in this laptop, i am able to connect in a different computer actually 4 different computers except...
Drivers
USB Mass Storage Device/Unknown Device
In Device Manager, there is a USB Mass Storage Device or an Unknown Device, even when there isn't anything plugged in. This is occurring on a Dell Dimension 5100. This is not the pc in my system specs. How do I fix this? Here are some Device Manager screenshots:
Hardware & Devices
Mass storage device usb driver
Hello. I do have a problem with Mass storage device usb driver and precisely with an iPod Classic 80Go.I tried everything but I always have the problem only on my computer;It detects the iPod as an amovible disk but iTunes doesn't detect it and its content is unreachable.
Drivers
USB Mass Storage Device
Hi All, Been using the new Windows 7 for a week or so now, everything is great! But i have one big issue. Every time i plug in a USB pen drive or my tomtom device, a window appears with a message saying that the device drivers can not be installed. When i click on the ballon message it just...
Drivers
Mass Storage Device
i have a Gateway 7803u notebook WIndows 7 64-bit specs are i hook up my external HD and it will not show up Mass Storage Controller with the yellow ! driver properties say
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:12.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App