Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems adding devices in Windows 7

28 Jan 2010   #1
sillycat41

Windows XP Pro
 
 
Problems adding devices in Windows 7

Can't figure this one out... nothing appears on the "add a device" screen where Windows 7 is supposed to be looking for new devices. No matter how long I wait.... never. No printer, no camera and no PDA. The computer makes a noise confirming attachment of the devices and also when I unplug them, so it knows that something has been plugged in but won't display the device so I can install it. What am I doing wrong???

Windows 7
New Toshiba laptop


My System SpecsSystem Spec
.
28 Jan 2010   #2
FZ21Z

Windows 7 Ultimate x64 ®™
 
 

It should automatically install them unless you've set it not to. Do they not show up in device management or devices and printers?
My System SpecsSystem Spec
01 Feb 2010   #3
sillycat41

Windows XP Pro
 
 
Problem adding devices to Windows 7

No, settings are okay for automatic installation and administrator, etc. but Win 7 does not detect ANY new USB devices that are plugged in. Have done all the troubleshooting features in Windows and the Automated Services online. No help at all. Very frustrating!!


Any ideas are welcome.
My System SpecsSystem Spec
.

02 Feb 2010   #4
FZ21Z

Windows 7 Ultimate x64 ®™
 
 

What is the model number of the laptop?
My System SpecsSystem Spec
02 Feb 2010   #5
sillycat41

Windows XP Pro
 
 

Toshiba Satellite L505D-S5983
  • AMD Athlon™ II Dual-Core Processor M300
  • Genuine Windows 7 Home Premium (32-bit)
  • 3GB DDR2 memory
  • 320GB HDD (5400rpm)
Does the computer manufacturer make a different? I thought it was a Windows problem.
My System SpecsSystem Spec
02 Feb 2010   #6
FZ21Z

Windows 7 Ultimate x64 ®™
 
 

Quote   Quote: Originally Posted by sillycat41 View Post
I thought it was a Windows problem.
Could be a user problem also, as you say it's making a noise when you connect things, but can't see them displayed. Plug something in, and screen shot your device manager and devices and printers and post them here.
My System SpecsSystem Spec
02 Feb 2010   #7
baron75mk2

 

if you get the noise when you plug the device in then try installing the drivers for the device after (you may have to search around for a win7 driver) its just that some devices windows 7 doesn't have the pre-installed drivers for - same thing used to be the case in xp - with some radeon video cards you had to install the drivers before installing the card etc - may be something similar with your particular usb equipment
My System SpecsSystem Spec
05 Feb 2010   #8
sillycat41

Windows XP Pro
 
 
Problem adding devices to Windows 7

He's not computer illiterate and tried every which way to install the devices in Windows 7 to no avail. Gave up on Windows and installed Ubuntu and was able to install both of his Canon cameras with no problems. I don't understand why this didn't work in Windows.

Thanks anyway.
My System SpecsSystem Spec
Reply

 Problems adding devices in Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Problems with devices and drivers after moving my PC
So a week ago I had my PC in my living room and decided to move it back to my bedroom, but after I moved it and set it up, I suddenly had alot of driver problems. When I went to check device manager almost evey device had a yellow exclemation mark above it. Picture: Gyazo -...
Hardware & Devices
ICS Connection Problems. iOS Devices cannot connect?
So I am having an issue with ICS. I set everything up correctly and it does say that the network I am sharing does have internet access. In fact I had it working for about 2 hours yesterday, and then it decided to stop working... When I go to an iOS device and I connect to it, it does say it's...
Network & Sharing
[Q] Problems resuming from sleep with wireless devices.
I have a Toshiba media center ir remote, logitech wireless keyboard, two logitech mice(MX anywhere, and M515) and a Rii non bluetooth wireless keyboard. When I first set the computer up I had no problems waking from sleep(S3/S4 hybrid) with the ir remote. I could put it in, and take it out of...
Hardware & Devices
Problems Adding Shared Printer
I am new to this forum and have been searching the Internet for awhile now to try and solve this problem. I did search on here but didn’t seem to find a solution. I have a HP PSC 1610V All-In-One printer that is shared on the network. It is cabled via USB to one of the work stations that is...
Hardware & Devices
Adding Windows Live Mail created endless problems
Win 7 Pro/64 has been perfect since new. I have used Hotmail forever. No problems. The other day, I clicked on a news site to send mail and a menu appeared stating that Windows Live was not my default mail, so would I like to update that. I clicked yes, and it proceeded with no problems....
Browsers & Mail
USB Devices in Windows 7 Problems (video)
Hello everybody! By now (if you have seen my other threads) you are getting tired of me looking for help :P but I still have not fixed this problem. USB devices are making my computer freeze and I will list below. I am uploading a video onto youtube as I am typing this. Also I tested all these...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App