Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External Hard drive doesn't show up!

04 Feb 2010   #31
Ch@n

 

^^ buddy, welcome!

scroll thru all 3 pages and try the soultions provided. in the mean time, lets hope selakos post his solution.

Al the very best.


My System SpecsSystem Spec
.
04 Feb 2010   #32
dyboc

Windows 7 x64
 
 

Thanks for the welcome!
As I mentioned, I already tried all of the suggested solutions; Disk management doesn't show the HDD in question amd starting the system in Safe mode is also not sucessfull. I guess I'll just have to wait for the OP's revelation :/
My System SpecsSystem Spec
04 Feb 2010   #33
Szaki

windows 7
 
 

Same problem here. I have a WD Passport (external HDD) and my laptop running Win7 does not detect it at all.
The lamp of the HDD is on so it gets power, but there is no trace of it on the machine. Other flash drives seem to be working fine from the same USB port.

Also, when I plug the WD into my other laptop running Vista there it starts up normally.

Strange thing is, about every 60 seconds Windows 7 gives me a kind of "trumpet sound" when the WD is plugged in. I have no idea what that means, but the sound is gone when I pull the HDD out.

I've read through the thread here but no solutions worked. The device does not even show up in the Disk management panel, but I do seem to have something unrecognized connected to one of the USB ports.

I would love to use this drive on this computer as copying everything from my other machine file by file with a flash drive seems ridiculous.

Any help is greatly appreciated!
My System SpecsSystem Spec
.

15 Aug 2013   #34
Jimmcwibb

Windows 7 64 bit
 
 

Hi guys, I know this is an old thread but I have a solution that works for me, and rather than piss off with my working hard drive I'm going to actually post my solution. Also this thread is the top result in google.

I bought a new 3TB external USB 3.0 drive (Seagate "Expansion"). Plugged it in to a USB 2.0 port, windows saw it and installed it. It showed up in device manager under "disk drives" as "Seagate Exapansion Desk USB device", so that all seems fine. However, it didn't show up or appear in explorer.

It did appear in Computer Management (Disk management) as a new disk, in the lower pane only. But it didn't appear to have a file system, and it wasn't assigned a drive letter. This is similar to other posts in this thread. I tried to assign it a drive letter, but it just threw up an error. I tried to reformat it, and again it just threw up another error. I tried different USB ports, I tried USB 3.0 ports, with the same results.

However, it was easily fixed. All I did was uninstall the device in device manager (right click, uninstall). Then I unplugged the USB cable, reinserted the USB cable into the same port, windows found it and installed it again (this process seemed identical to the first time round) but this time it showed up in explorer straight away and has a drive letter.

So I'm guessing something went wrong with the original installation, giving windows a second chance solved the issue. Good old windows....
My System SpecsSystem Spec
05 Sep 2015   #35
nick4onelove

Windows 8 64-bit
 
 

I know this is ancient and I'm actually on Windows 8, but this thread is the first thing that pops up when I googled this problem, and I've figured it out. I tried every solution here to no avail.

What you have to do is delete every separate partition volume on the drive. This will leave one large unallocated partition volume that you can now right-click and choose New Simple Drive. This let me format it, choose a letter, and it popped up in explorer immediately after!
My System SpecsSystem Spec
Reply

 External Hard drive doesn't show up!




Thread Tools




Similar help and support threads
Thread Forum
External hard drive does not show up
Hello everybody, I am using an asus X52JE with windows home premium *64bit. I have an external hard drive (Lacie, 1TB) that is not recognised by this computer but works perfectly on others. I have checked every other usb port, and used another usb key that my computer recognised (so my usb ports...
Hardware & Devices
external Hard Drives doesn't show in 'My computer'
I recently noticed an issue when trying to connect to external hard drives. Initially noted that it wasn't showing in 'my computer' and so assumed I had driver issues and sought to update them from Dell's site. After doing so there was still no change, but noted that It was appearing in 'device...
Hardware & Devices
Second Hard Drive doesn't show up in BIOS...(again)
hello everyone ^^ i have a problem with my second hard drive. my main/master hdd is a MAXTOR STM380215AS ATA with windows 7 and my second/slave it's a ST3250319AS ATA 250GB (i think T.T) windows XP Professional My second HDD it's newer then my maxtor(3-4 years) but the Seagate sometimes will...
Hardware & Devices
external hard drive doesn't show up on pc
I have a Seagate External Hard drive, Desk Goflex 3 TB. I'm using it for sevral mounth in windows 7 and it's working fine. Now, I bought a new latop using windows 7 as well, and it's not recognizing my hard drive. The hard drive doesn't appear in the Disk Management at all. The computer does...
Hardware & Devices
Second Hard Drive Doesn't Show Up
I just built a computer and I have a 64GB Crucial M4 SSD as my primary drive and a 500GB WD Caviar Blue as my secondary drive. The issue is that Windows 7 doesn't recognize the WD Caviar Blue, only the SSD. Both the BIOS and the Device Manager recognize the WD Hard Drive it just doesn't show up in...
Hardware & Devices
Doesn't show external drive anymore but visible in the disk management
I have a 2,5" 500GB external hard-drive with a single partition (NTFS). I can see it in the disk management utility (see attached screenshot) but it doesn't have a drive letter nor can't I assign one. Attached to another PC running Windows XP it says "unknown partition" but also error-free and...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App