Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: External HDD not found

28 Mar 2009   #1

Windows 7RC 64bit build710
External HDD not found

I have my External HDD setup through a rear firewire port on my 750 EVGA mobo. It's not showing up using the usb firewire cable. I don't think downloading drivers would work since A it should be a plug and play device and B it's just not being seen at all....

My System SpecsSystem Spec
28 Mar 2009   #2

64-bit Windows 10 Pro

Hello ZeRo,

You might double check in your BIOS settings to make sure that the firewire and USB ports are enabled to see if that is the issue. Also try different ports to see if it may be a issue with just that one.

Hope this helps,
My System SpecsSystem Spec
28 Mar 2009   #3

Windows 7RC 64bit build710

A it's XeRo and 2 BIOS is corrent...The USB port will accept a flash drive but not this external hdd. But the external HDD will work on my Vista laptop.
My System SpecsSystem Spec

28 Mar 2009   #4

64-bit Windows 10 Pro

If you have the ports enabled in the BIOS, then you might see if you have the latest motherboard chipset drivers installed as well.
My System SpecsSystem Spec
28 Mar 2009   #5

Windows 7RC 64bit build710

Everything is up to date.
My System SpecsSystem Spec
28 Mar 2009   #6

7600.20510 x86

At any time, did you reverse one of the connections by putting it in backwards or upside down? Some cheaper cables and/or ports could potentially allow this despite the shape. If done, it would cross the data and power lines making either the device or ports unusable until repair.

Probably you didn't do this, but had to ask.
My System SpecsSystem Spec
28 Mar 2009   #7

Windows 7RC 64bit build710 can't reverse them. They only go in one way. It's a large External hard drive not an iPod.
My System SpecsSystem Spec
28 Mar 2009   #8

7600.20510 x86

Thousands of people have done it if you search the net on various firewire devices. An example explaining: Camcorder Repair Specialists - AV Repair

"Something else about firewire you won't hear from the manufacturers is something you should take seriously: The firewire cables. It is all too easy to inadvertently insert a 6 pin firewire cable backwards, wreaking serious damage to your DV deck. In some cases thousands of dollars worth of damage can be done to equipment in this fashion. This is becoming a serious issue, that has not, and probably will not be addressed, as IEEE1394 IS the standard... Your advised to use caution when inserting the 6 pin cables to standard DV ports on your computer."
My System SpecsSystem Spec
19 Aug 2009   #9

Windows 7 x32

Hi Guys

Have read through this post, I have similar problem though I'm more confused now.
I have 3 External HD and one Semi-External (backup unit HP). None of them works through USB ports (none of my 8 ports).
Not even the four Mem sticks I have tried works.

W7 says unknown devices.
1. I have tried all ports.
2. I have tried on Vista and XP on other machines (no problems).
3. I have had these units working on this hardware before (in vista).
4. I have the latest of everything as it seems.. (i think).
5. I have reinstalled with them plugged in and not like 4 times..
6. I have tried several updates and even tried with old USB drivers..
7. I found a writing on a 4 step check and did that to (power management, uninstall, checking power etc.. )
8. tried different cables
9. ...

What the H...

My keyboard works (W-less).. My Camera works.. ? on all ports..

Any one have similar problems ?
This is driving me crazy ..

Best Regards
My System SpecsSystem Spec
19 Aug 2009   #10
Atomic Shark

Windows 7 RTM (My daddy installed it for me)

There are some steps that might get it going...
  • Plug the USB hardware into ANY USB slot
  • Wait till Windows finds it as 'Unknown Device'
  • Access 'Device Manager' and uninstall the device
  • Allow Windows to search for new drivers
doing this will force Windows to check Windows Update for drivers and the search parameters seem to be greater too.

Hope this helps

My System SpecsSystem Spec

 External HDD not found

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
External HD FOUND.000 folder won't display in Windows, will on Mac
I hope this is the right forum for this question. I have an exFAT-formatted external hard drive I use with computers both Mac OS X and Windows 7. Although the Mac has never had any issues, Windows 7 became upset a few days ago, started scolding me that the disk was dirty, and didn't let me...
General Discussion
install.exe found on external drive - how do I find out what it is?
Can anyone help? My computer was accessed via remote access scammer 2 nights ago and although my computer has been checked any appears to be safe - (microsoft checked) - my partner has a computer on the same home network and her computer now has (2) 'install.exe' files that have appeared on her...
System Security
External hard drive found as unknown device
I have a LaCie external hard drive which works fine on other pc's running Windows 7 Ultimate, but on this one it is an "unknown device". I have tried it in different ports but with the same result. I've checked with Windows Compatability and the exact model is listed there as being compatible. I've...
Hardware & Devices
external hdd not found :(
I have 3 USB ports. When I use one for mouse.. it works fine.. but when i plugged in my External HDD it wont recognize it.. this started just now after i got home from school (i have a feel my brother is trying to sabotage my laptop) anyway.. im not knowledgeable in terms on computer stuff but i...
Hardware & Devices
External HDD found but unable to open
I connected my Seagate hdd (Windows Vista installed) to my new laptop with Windows 7 (64) bit operating system. It recognizes the partitions but when I try to access them, it got stuck when loading. Can anyone help? thanks.
Hardware & Devices
Usb external drive not found - but thumbdrive is
Okay so my clean W7 x64 went off without a hitch... at least at first. Now that I am reinstalling stuff - I have a Thermaltake Max-4 external drive enclosure and connected it to the USB. But to my surprise W7 did not check for drivers when I connected. I shut off the power to the drive...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:43.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App