Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Missing optical drive... none of the fixes work

20 Feb 2010   #11
JonM33

Windows 7 Home Premium x64
 
 

Did you try replacing the optical drive? Seriously, those things do wear out over time. Over the past 10 years (starting with a 4X CD burner) I have gone through at least 20-25 optical drives. At least they are only $30 now where they were $100+ in the past.


My System SpecsSystem Spec
.

21 Feb 2010   #12
CreeDo

Windows 7 Ultimate 64 bit
 
 

I'll end up replacing it for sure, but I remain convinced it's not the hardware because it worked great in XP up to the day I installed 7. And it worked great today when I burned my DVD. Hours later I come back to my PC and it's disappeared as usual.

I guess I haven't bitten the bullet yet on a new drive because I keep hoping someone will come up with the miracle fix... like memorex support will respond to my emails asking for the firmware update, or a windows update will improve the cdrom.sys driver, or someone on the forum will say "did you try this obscure registry tweak?" or "did you try wiggling the sata cord just so?".
My System SpecsSystem Spec
21 Feb 2010   #13
Frostmourne

Windows 7 Ultimate x86-64
 
 

Download Autoruns and look through the tabs to find an entry for the cd-rom.sys driver. Enable it and restart. Then, uninstall any cd-burning apps such as Nero and reboot. Lastly triple check the connections and status in the BIOS.
My System SpecsSystem Spec
.


25 Feb 2010   #14
CreeDo

Windows 7 Ultimate 64 bit
 
 

Frost - found it in the services section of autoruns, and it's enabled already... I uninstalled nero and restarted... no luck. Drive is always there when I reboot, both in bios and in windows. Always goes away after a few hours.

found some registry keys for the cdrom.sys driver at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\cdrom but I can't see anything useful that might do anything :/
My System SpecsSystem Spec
26 Feb 2010   #15
Frostmourne

Windows 7 Ultimate x86-64
 
 

Update the firmware if you can too.
My System SpecsSystem Spec
04 Mar 2010   #16
CreeDo

Windows 7 Ultimate 64 bit
 
 

So tech support provided a firmware update but it was either the wrong update or failed to work with the drive (even though the drive was currently showing).

I realized I was only using one of my two IDE connections, so using the IDE-to-sata adapter was pointless. I disconnected it from the optical drive and plugged it into my IDE cable, jumpering it to be a slave to the other IDE drive. Now it's been working fine all day and I think it's safe to say the problem is solved, though it woulda been nice to know why it had problems connecting via sata.
My System SpecsSystem Spec
05 Mar 2010   #17
Frostmourne

Windows 7 Ultimate x86-64
 
 

Quote   Quote: Originally Posted by CreeDo View Post
So tech support provided a firmware update but it was either the wrong update or failed to work with the drive (even though the drive was currently showing).

I realized I was only using one of my two IDE connections, so using the IDE-to-sata adapter was pointless. I disconnected it from the optical drive and plugged it into my IDE cable, jumpering it to be a slave to the other IDE drive. Now it's been working fine all day and I think it's safe to say the problem is solved, though it woulda been nice to know why it had problems connecting via sata.
Didn't you connect to IDE before?
My System SpecsSystem Spec
06 Mar 2010   #18
CreeDo

Windows 7 Ultimate 64 bit
 
 

The last time I had this drive connected via IDE was with windows XP. I switched to connecting via sata (also under XP) to make room for a new IDE drive. If you ask me why I didn't get a new sata drive, or why the optical drive is the one I chose to use with the sata adapter... all I can tell you is that I was ignorant.

I removed that new IDE drive when I noticed how crowded my tower was getting and never thought to reconnect the optical drive to the IDE cable. Until installing win. 7 forced me to.
My System SpecsSystem Spec
06 Mar 2010   #19
bobsch

Windows 7 Pro 64
 
 
Reading CD Crashes Windows Explorer

I also have a problem with my PATA DVD/CD drives being "missing." I know the drives are OK because I used the master drive to install Windows 7, but when I try to install software from either drive Windows Explorer crashes and I have to turn off the computer with the power switch.

With no CD in the drive, I get the normal right click options. When I insert a CD, I get a constant hour-glass and have no control.

I tried switching autoplay between on and off, but that didn't help.

Any ideas?
My System SpecsSystem Spec
06 Mar 2010   #20
whest

XP, Vista, W7 64bit Home Premium
 
 

Post your system specs bobsch
My System SpecsSystem Spec
Reply

 Missing optical drive... none of the fixes work




Thread Tools





Similar help and support threads
Thread Forum
Optical Drive doesn't work after reboot.
I have an ASUS BC-12B1ST SATA combo drive that works great from a cold boot, but never comes online after a reboot. It's done this since install a year or so ago, and it's not bothered me much because I was leaving the machine on 24/7 for BOINC anyways. I had a MB & processor fry out lately,...
Hardware & Devices
Windows Update broken. Multiple fixes didn't work.
Greetings, I've got a doozy of a Toshiba here. Originally, it had the beginnings of a failed hard drive, so we cloned it over. After that, we ran BleachBit, AdwCleaner, and JRT as a basic cleanup, not finding anything significant. HitmanPro also found nothing of note. Finishing up, we started...
Windows Updates & Activation
Installation Won't Work - Tried All Suggested Fixes
Hi everyone. I am trying to install Windows 7 on my PC, having successfully done so without issue on my laptop. I have tried to burn the ISO file onto various DVD's, all of which have failed. This is not helped by my DVD drive in my PC being dated, IDE. However, I burn the ISO image to...
Installation & Setup
OS INSTALL FAILS - Optical Drive Driver Missing! Huh?
I'm doing a new OS install, using my the same Win7 64 install disk as before. I do have new drives, but they are just newer versions of my old drives (which died) - and they are pretty standard HP slim drives. For some reason, the OS install will not complete. It's saying that an optical drive...
Drivers
Internet missing after system reboot: all attempted fixes failed
Hello I am hoping someone can help me with a little internet problem on a Windows 7 professional system. Essentially, last week after an Update, I could not get back onto my driver (the hard drive is partitioned so I have a section and my other half has another). A system restore to the...
Browsers & Mail
I can't get to work Microsoft's Basic Optical Mouse v2.1 at Win7 x64
Hello guys, This is my first thread on this forum so forgive for any kind of mistakes. Well, Recenlty a friend of mine gave me a Microsoft Basic Optical Mouse v2.1 because mine broke and I was in need of another mouse.The first day I used it everything was ok but then Windows 7 started giving...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:40.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App