Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Missing optical drive... none of the fixes work

03 Feb 2010   #1
CreeDo

Windows 7 Ultimate 64 bit
 
 
Missing optical drive... none of the fixes work

I have an Acer Power FH system with a Memorex CD/DVD optical drive.
Was using Windows XP and just did a clean install of 7 on a new drive.

The drive doesn't show up in my computer, or in device manager. It was available in XP and shows in BIOS. It showed briefly the first time I booted into windows 7, but when I double clicked it, it disappeared and never came back.

Maybe relevant: - it's a PATA drive and I'm using an adapter to connect it to one of the SATA slots on the motherboard. Dunno if it matters but it's set as a slave on channel 3, with the win7 boot drive being the master on channel 3. My other drives, both PATA and SATA, are showing up ok.

---

Fixes I've googled that don't work:

Removing upperlimit and lowerlimit registry entries at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

Disabling driver signing verification under the windows 7 boot options

Manually disabling via command line with bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS

Downloading windows updates, including
Download details: Update for Windows 7 for x64-based Systems (KB974332)

Showing hidden devices in device manager, scanning for new hardware, useless windows troubleshooter.

---

Am I hosed or what? Time to buy a new drive? Maybe rearranging things so the drive is connected via IDE cable?



My System SpecsSystem Spec
.

03 Feb 2010   #2
garysgold

Vista Ult 64 bit Seven Ult RTM x64
 
 

Hello CreeDo,

Welcome to Seven Forums.

There may be a setting in bios to activate the sata port.

Hope this helps.

Gary
My System SpecsSystem Spec
03 Feb 2010   #3
Pauly

Win7 Ultimate X64
 
 

Check disk management to see if drive is showing up
Right click my computer>manage>disk management

Or from a command prompt type, diskpart, list disk and see what comes up should show you drive and tell you drive status ie online/offline/error

Hope this helps
My System SpecsSystem Spec
.


03 Feb 2010   #4
CreeDo

Windows 7 Ultimate 64 bit
 
 

Thanks for the ideas so far...

gary - Does that mean enabling the particular sata slot I've got it plugged into? I know that sata slot works... also sometimes I've seen the drive appear on a couple of occasions for just a few seconds. If activating the port can still work, where is that in bios usually?

Pauly - it's not in disk management. Since my original post I installed some windows updates, and on the next reboot the drive showed up twice... once as an unknown drive type, and on the next boot as a CD/DVD drive. In both cases, the drive disappeared after a few seconds. In the second case it actually let me copy a couple of files then disappeared in the middle of the copy, causing an error.
My System SpecsSystem Spec
03 Feb 2010   #5
Pauly

Win7 Ultimate X64
 
 

Generally in bios sata ports can be set to work in different modes normally raid/ide/ahci try changing between achi and ide see if it helps, have you doubled check the drive is connected properly all plugs are pushed fully home, try unplugging and replugging nothing to lose
My System SpecsSystem Spec
03 Feb 2010   #6
Frostmourne

Windows 7 Ultimate x86-64
 
 

Change the channel. It appears your motherboard doesn't support 2 devices on the same channel. Either that or buy a new optical drive with a SATA interface.
My System SpecsSystem Spec
04 Feb 2010   #7
CreeDo

Windows 7 Ultimate 64 bit
 
 

WHOA. Frostmourne. You are THE MAN. Seriously. You are definitely my hero for at least the next week.

This problem is so common and so few good fixes are posted. I just swapped two of the sata connections so that they're on different channels and it's golden. All other drives are still there. Hopefully it sticks. Thanks so much! Was driving me nuts. Thanks also to the other posters in this thread.
My System SpecsSystem Spec
18 Feb 2010   #8
CreeDo

Windows 7 Ultimate 64 bit
 
 

AGHHH bump :/

It isn't fixed. It consistently disappears shortly after boot.

Memorex support sucks for the drive... after lots of digging I found links to firmware updates for my drive. Every link is 404. I searched google for the filenames of these drivers and found only one out of 4. That one failed to work (an error about the drive not being found).

In short, the drivers are either impossible to find or suck, and without them I can't seem to keep this drive from disappearing in windows 7. It will appear and work for a short time. I don't know what changes to make it disappear. It's gone in device manager too.

Help?
My System SpecsSystem Spec
19 Feb 2010   #9
Frostmourne

Windows 7 Ultimate x86-64
 
 

I'd replace the drive with a brand new SATA model - the one I bought is a GH 22 series, and no it does not have Bluebird.
My System SpecsSystem Spec
20 Feb 2010   #10
CreeDo

Windows 7 Ultimate 64 bit
 
 

Frost, thanks for checking back in on it. I'm probably going to have to end up doing that. It kills me though, throwing away a perfectly good drive. It's just a software issue, it worked (and still works) great in XP.

Right this second, it's working fine. It just stops after a little while and disappears.

Is there any use knowing this bit of info? In event viewer I can see when it disappears. There's an error from the service control manager. The error isn't helpful, just says "The following boot-start or system-start drivers failed to load: cd-rom"
My System SpecsSystem Spec
Reply

 Missing optical drive... none of the fixes work




Thread Tools





Similar help and support threads
Thread Forum
Optical Drive doesn't work after reboot.
I have an ASUS BC-12B1ST SATA combo drive that works great from a cold boot, but never comes online after a reboot. It's done this since install a year or so ago, and it's not bothered me much because I was leaving the machine on 24/7 for BOINC anyways. I had a MB & processor fry out lately,...
Hardware & Devices
Windows Update broken. Multiple fixes didn't work.
Greetings, I've got a doozy of a Toshiba here. Originally, it had the beginnings of a failed hard drive, so we cloned it over. After that, we ran BleachBit, AdwCleaner, and JRT as a basic cleanup, not finding anything significant. HitmanPro also found nothing of note. Finishing up, we started...
Windows Updates & Activation
Installation Won't Work - Tried All Suggested Fixes
Hi everyone. I am trying to install Windows 7 on my PC, having successfully done so without issue on my laptop. I have tried to burn the ISO file onto various DVD's, all of which have failed. This is not helped by my DVD drive in my PC being dated, IDE. However, I burn the ISO image to...
Installation & Setup
OS INSTALL FAILS - Optical Drive Driver Missing! Huh?
I'm doing a new OS install, using my the same Win7 64 install disk as before. I do have new drives, but they are just newer versions of my old drives (which died) - and they are pretty standard HP slim drives. For some reason, the OS install will not complete. It's saying that an optical drive...
Drivers
Internet missing after system reboot: all attempted fixes failed
Hello I am hoping someone can help me with a little internet problem on a Windows 7 professional system. Essentially, last week after an Update, I could not get back onto my driver (the hard drive is partitioned so I have a section and my other half has another). A system restore to the...
Browsers & Mail
I can't get to work Microsoft's Basic Optical Mouse v2.1 at Win7 x64
Hello guys, This is my first thread on this forum so forgive for any kind of mistakes. Well, Recenlty a friend of mine gave me a Microsoft Basic Optical Mouse v2.1 because mine broke and I was in need of another mouse.The first day I used it everything was ok but then Windows 7 started giving...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App