Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Laptop: No ethernet card detected?

03 Feb 2010   #1
jwalk

Windows 7 Home Premium
 
 
Laptop: No ethernet card detected?

I have a Toshiba Satellite a135-s4527. It has a Realtek 10/100 ethernet card in it, and an Atheros wireless card.

My ethernet card doesn't show up in device manager, but the wireless card does.

I went to Toshiba.com and downloaded the appropriate drivers for Windows 7 and my model of computer and installed them, but the ethernet card still doesn't show up in device manager and I'm limited to wireless connections.

Can someone tell me how to get my wired connection up and running?


My System SpecsSystem Spec
.

03 Feb 2010   #2
ashvin

Vista/ xp/ windows server 2003/ small business server
 
 

the ethernet card might be faulty.. you can look at the option of running a hard ware test or just use usb converter for internet connection
My System SpecsSystem Spec
03 Feb 2010   #3
jwalk

Windows 7 Home Premium
 
 

The device itself is good and I can make it work in the Linux install I have on the same computer.
My System SpecsSystem Spec
.


03 Feb 2010   #4
Frostmourne

Windows 7 Ultimate x86-64
 
 

Does the Ethernet device have an exclamation mark on the device? Have you tried right-clicking and selecting update?
My System SpecsSystem Spec
04 Feb 2010   #5
jwalk

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by Frostmourne View Post
Does the Ethernet device have an exclamation mark on the device? Have you tried right-clicking and selecting update?
No - it's just not there.

The only device listed under network adapters is my Atheros wireless card.
My System SpecsSystem Spec
04 Feb 2010   #6
jwalk

Windows 7 Home Premium
 
 

Anyone?

Bueller?
My System SpecsSystem Spec
04 Feb 2010   #7
aem

Windows 7 Ultimate 64Bit
 
 

My System SpecsSystem Spec
04 Feb 2010   #8
jwalk

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by aem View Post
Try updating your chipset drivers.
Did that (see OP).
My System SpecsSystem Spec
04 Feb 2010   #9
aem

Windows 7 Ultimate 64Bit
 
 

Is this a new machine? or you are just replacing an adapter in it?

Go into the BIOS and see if it's listed in there. Some system requires some sort BIOS initiation.
My System SpecsSystem Spec
04 Feb 2010   #10
jwalk

Windows 7 Home Premium
 
 

Nope, it's like a 3yr old computer. Same old ethernet card that's always been in it.

When I plug a cable into the port, the little light blinks and does it's thing. The card does work in Linux, and is enabled in BIOS, which is also the latest version.
My System SpecsSystem Spec
Reply

 Laptop: No ethernet card detected?




Thread Tools





Similar help and support threads
Thread Forum
Ethernet Lan Cable not detected
Ethernet Lan Cable not detected on my computer . last week it was working and now its not idk why . my friend told me to reset the bios setting so i removed the cmos and reseted the settings still not working and i also installed the latest driver for my 82579V Gigabit Network . Help pls i cant...
Network & Sharing
Ethernet cable not detected!!
Hey everyone, Since I'm on a campus, I'd like to download shit with a real nice speed, but the only problem is, when I connect my ehternet cable, it won't connect or something. If I go to the adapter settings, it says that the wireless network connection is fine, but the local area connection...
Network & Sharing
Ethernet cable not detected
One of my Windows 7 computer has been getting an error for 24 hours that the ethernet cable is not detected and it can not connect to the internet. Other Windows 7 computers on the same router/internet connection work fine. I have already tried the following all of which were not successful....
Network & Sharing
Ethernet not detected
Hello all! I know there have been some threads about this issue before, but I couldnt find a solution to my problem there: Until today I had Windows XP running on my new system, which consists of: Mainboard: Asus M4A87TD Athlon X2 Ram and other hardware. The network adapter is a onboard...
Network & Sharing
HELP! ethernet cable not being detected
Hi, I am using windows 7. i have upgraded from vista recently. My internet connection has been cutting out infrequently over the past month, but now it has cut out completely. windows is detecting the problem as a either a faulty ethernet cable or as a cable not being connected. I have tried; ...
Network & Sharing
Ethernet cord not detected
Hey guys, I just installed Windows 7 on a new computer, and I can't get it to detect my ethernet cord. The light on the card that the cord plugs into lights up, and I could access the internet when running a Knoppix live CD, so I don't think it's a hardware problem. I'm fairly inexperienced...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:03.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App