Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Trying to get my camera installed

05 Feb 2010   #1

Trying to get my camera installed

I think I've tried everything you've suggested to Repair my WIN7 install (to get my camera installed). It's supposed to be driverless and does install in 5 seconds flat on my friend 's near-identical system, and HIS working camera won't function on my system. The four attached images show what I'm getting (even after the SFC /SCANNOW in an elevated CMD box). Image 1: I start the upgrade (repair WIN7) and it tells me to restart the computer . Image 2: after copying the temp files, it copies the regular Windows files to 100%. Image 3: it stalls at 0% during "gathering". Image 4: it tells me that setup cannot continue, and that I should reboot, restart setup and check for upgrades (done it literally a dozen times or more now). When it was working on my friend's computer, it had two driver files "something-THUNK.dll" and an .ax file. Both are missing off of both computers but I bet they would re-appear if I plugged into his computer again... There isn't any software IN the camera. It's just a little CMOS number that is supposed to be UVC, and IS in my friend's computer. I've unplugged everything but the keyboard and mouse, uninstalled or disabled half a dozen things (SuperAntiSPyware, Spybot S&D, AVAST, KXdriver (to run my SB Live 5.0) and anything that I could imagine was interfering. Any clues or hints? I'm slowly going insane here...

Attached Images
Trying to get my camera installed-1.jpg Trying to get my camera installed-2.jpg Trying to get my camera installed-3.jpg Trying to get my camera installed-4.jpg 
My System SpecsSystem Spec
05 Feb 2010   #2

64-bit Windows 10 Pro

Hello SFwriter,

Does the camera have a memory card in it? If so, you should be able to just plug it into a memory card reader instead to upload the images into the computer.

Hope this helps,
My System SpecsSystem Spec
05 Feb 2010   #3

Linux CENTOS 7 / various Windows OS'es and servers

Hi there
what's the camera -- and a lot of them will need to be SWITCHED ON when connected to the computer as well.

Normally typical cameras are just "Bog standard" USB devices.

My System SpecsSystem Spec

05 Feb 2010   #4


Sadly, I'm afraid it's not a simple solution like turning it on. It's not a digital photo camera, but a webcam (MSG923 MYSHOW 16 M/p 640x480 30fps), so no memory card. The other is a Microsoft Lifecam. Both need additional software to do "fancy" things but are plug'n'play for basic functions. Both are BOG-standard (I like that -- toilet standard -- hilarious) USB devices.

I think it's safe to forget the camera issue altogether, hence my placing it in the other forum. If I could just get past the point where W7 Setup says it "cannot continue with the install" (over and over again), and get it to "allow" me to repair my installation of W7, I think the camera issue would amend itself. It's surely just a case of missing DLLs, OCX, AX, et cetera, which a repair-install would likely sort out. If only I could get it to do the install instead of failing and telling me to restart after getting updates which I've already done innumerable times.

Attached Images
Trying to get my camera installed-camera.jpg 
My System SpecsSystem Spec

 Trying to get my camera installed

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
installed HD 2600 pro card, installed AMS driver, but no ccc software?
I was wondering if this would help? I see no evidence that the AMD driver installed at all. Right click desktop does not show ccc, and ccc is not in the lower right panel. Windows...
Graphic Cards
New Vid Camera
i got a new vid cam for my bday and xmass, so now i can finally do some cool things! lol i got a canon vixia hf r400 shoots 1080p @60fps 1/3" cmos sensor heres a pic i shot with it today. i dident correctly focus, however, its still looks good imo ...
Chillout Room
I am using HP intel i5 laptop with windows7 with 64 bit operating system. My webcam is not working. when I tried to on it, a warning is displaying "No Webcam detected". My webcam is CyberLink Youcam. Plz give me a solution.
Hardware & Devices
pc usb camera
I can't camera audio to work with w7 64 bit video works great but no audio
Well I bought a camera last year for recordings and it's pretty cool. But it required a disk for it(the size of a gamecube disk). I record on it and I put it in my PC Computer > D drive - Never loads. I'm pretty sure it's the CD itself but not understanding why. It fits in the slot fine,...
Hardware & Devices
525 USB PC Camera
Hey guys. I have Canyon webcam model CNR-WCAM43 but the drivers i have don't work in windows 7. In windows vista i have no problem with it but in windows 7 its just don't work. Any tip for solve this problem. Thanks

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:54.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App