Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: EXTREME lag on Windows

15 Feb 2010   #1

Windows 7 Ultimate 64bit
EXTREME lag on Windows

Hey everyone,

I'm running on Windows 7 Ultimate x64 at the moment, and has been smooth sailing for a while now. But I've hit big trouble. I installed first Resident Evil 5 (from an .iso), then Fraps, then Bioshock 2 (from an .iso). After Bioshock 2 had finished installing, I noticed a LOT of lag. Almost as though my CPU was spiking. So I Ctrl+Alt+Del'ed. There was a bit of lag before the screen showed up and I selected Task Manager. From then, it went to a black screen which usually shows for a part of a second, and it sat on that black screen for a good couple of minutes until I decided to just push the restart button on my computer.
I started up again, and I am not kidding, it spent about 10 minutes on the Windows logo as it loaded, and then another 10 on a blank screen with only my cursor showing. It took about 30 minutes before it even displayed my wallpaper and the superbar. I opened Task Manager when I had nothing open, and the CPU was sitting between 1-3%. I finally got the start menu up and selected System Restore. Everything on my computer was going incredibly slow, however the mouse moved smoothly across the screen. System Restore finally opened, and I selected a restore point which was well before my problems started. It got as far as the loading box that says 'Preparing for system restore' or something similar. It stayed on that for just over 15 minutes before a dialogue box came up saying that System Restore could not go ahead because it was taking too long.

So here I am, on a library computer trying to solve the issue. I'm going to get a keyboard that isn't USB from my friend so that I am able to select Safe Mode when I start up. I will try a System Restore from there.

Has anyone else experienced a similar issue or have any idea what could have caused this? Because I am sure that it was one of the installs that has completely f****d my computer.

Any help is greatly appreciated. Thank you all.

My System SpecsSystem Spec
15 Feb 2010   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install


If it were my computer, the first thing that I would try is safe mode and try using system restore from the point prior to all the installs. If you must have those games, install one at a time and use it for a week, before installing the next. You will know the cause of the problem and not install it.
My System SpecsSystem Spec
15 Feb 2010   #3

Windows 7 Ultimate x86-64

.ISO? Are these legal installs? What imaging software are you using? Then go through the troubleshooting guide in my sig.
My System SpecsSystem Spec


 EXTREME lag on Windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
EPSON R280-Windows 7- Apple Airport Extreme
Hello to all, I hope someone can help with this major printer problem. If this is not the correct area for this post, I apologize in advance please point me to where I should be, Thanks. Here is my problem: Ive got a Windows 7 Acer Aspire Laptop, 64 bit, Epson R280 printer, Apple Airport...
Hardware & Devices
Windows 7 Ultimate X64 extreme lag
Hello, I've been having a problem ever since I installed my W7 2months ago. My configuration is: MOBO: Intel DH55TC CPU: Intel Core i3 540M RAM: 2GB Kingmax DDR3 @1333MHz GPU: nVidia 250 GTS HDD: 80GB Seagate Barracuda (1 year old)
Performance & Maintenance
Windows 7 to AirPort Extreme via Ethernet Cable Issues
I just built a new computer and have Windows 7 Home Premium 64bit installed on it and it is connected via ethernet cable to AirPort Extreme but my computer says there are no network connections, does anyone know how to fix this? If it matters this is my build: Intel Core i7-950 Bloomfield...
Network & Sharing
Windows 7 extreme installation
Guys, Ive got a riddle for you. I need to install windows 7 x64, but: -Ive got no DVD drive -No free hard drive that I can use as install media (well ive got but active partition has winXP on it :P so hard to boot install files from it) -1 GB flash drive -booting via PXE works but...
Installation & Setup
Extreme Latency in Windows Setup
I've been running Windows 7 RC quite happily on my Dell Latitude e6500 for the past 6 months. However, since the expiration on the RC is coming up soon, I purchased an upgrade copy of Windows 7 Professional. Also, I recently purchased a larger HD on which I would like to install Win7. So, I am...
Installation & Setup
Windows Media Player EXTREME CPU and Memory consumption
I have Windows 7 64 bit here. Windows Media Player has been behaving very badly and I'm desperate for help. I want to uninstall the damn appliation but cant' even see a way to do so in Uninstall programs. Here is what it is doing now. right now in taskmanger wmplayer32 is eating up...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:01.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App