Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB ports work only once until shut off

15 Feb 2010   #1

Windows 7
USB ports work only once until shut off

I recently upgraded to 7. I have 3 USB ports on my HP Pavillion dv6 laptop. I find that after booting up windows, I can plug something into my USB port (like a wireless mouse receiver), but after I remove the device from the port, all USB ports stop reading any USB devices, regardless of whether it is the same as the first device I plugged in or not. Any help would be greatly appreciated. Thanks!

My System SpecsSystem Spec
15 Feb 2010   #2

Windows 7 Professional x64


Try going here to download the latest chipset drivers for your machine.

Hopefully that will solve the problem.

Good luck!
My System SpecsSystem Spec
15 Feb 2010   #3

XP, Vista, W7 64bit Home Premium

Need more details on your dv6 as there are a few models if it uses the nforce chipset this fix might work - set up a restore point firstly:
You encounter problems when you move data over USB from a Windows 7 or Windows Server 2008 R2-based computer that has an NVIDIA USB EHCI chipset and at least 4GB of RAM
If it uses intel - the intel chipset installation utility, and also you might need to install the intel matrix storage manager :

Intel(R) Matrix Storage Manager
My System SpecsSystem Spec

01 Jan 2015   #4

Toshiba Satellite C855D - 16V running Windows 8.1 64 bit with the latest updates 01.01.2015

A simple fix is to check your Power Options:

Control Panel --> Hardware and Sound --> Power Options --> Change plan settings --> Change advanced power settings --> USB Settings --> USB Selective Suspend Settings:

Set both options to disabled. Do the same for all your power options (change at the top: Balanced/ High Performance/ Eco.. etc. )

Just changing the registry did not do it because the power settings kept changing it back so this fix should do.
My System SpecsSystem Spec
01 Jan 2015   #5

Toshiba Satellite C855D - 16V running Windows 8.1 64 bit with the latest updates 01.01.2015

I realize this thread is infinitely old but it came up when I was googling my issue so hopefully someone will benefit from this (tried everything before I stumbled upon this)
My System SpecsSystem Spec

 USB ports work only once until shut off

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
USB 3 ports do not work
Confession: I bought an HP ENVY laptop with WIN-8. I hated it and replaced it with WIN-7 PRO Service Pack 1. The single USB2 port still works fine. The three USB3 ports do not work. I did not check them out before I replaced the operating system but I suppose they were supported with 8 but not 7....
Hardware & Devices
Is it possible ALL 6 USB ports to not work ?
I have plugged in a device into all 6 ports and none work, even after a start up...
Hardware & Devices
USB ports don't work
A few minutes ago my TOSHIBA C655 USB ports were working fine not any of the two of them work now. I have tried many cords too. Can someone PLEASE help me?!
Hardware & Devices
USB 3.0 ports refuse to work as USB 3.0 ports
A few days ago I installed a USB 3.0 card (to be precise, this one: 2-Port USB 3.0 SuperSpeed PCI-E Controller Card - Free Shipping - DealExtreme). It uses the very common NEC µPD720200 USB 3.0 controller. I installed the required drivers for Windows 7, and the card worked fine for the first...
Hardware & Devices
LIBusb, USB ports doesn't work. Safe mode also no work
After I install LIBusb I could work futher. But after I put him off en reboot an hour later my wired mouse en keyboard didn't work anymore. When I restart in safe mode both still doesnt work. OS: W7 Home Premium 64b Computer: HP Pavilion p6250 Please Help!!

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:39.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App