Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: external device issues since upgrading

01 Mar 2010   #1
Adamv2

windows 7
 
 
external device issues since upgrading

Hi, i'm not sure this is the right forum. If not, I apologize.

Anyway I have 3 external harddrives I often connect to my HP Pavilion. They connect fine, and I have no issues accessing data. However whenever I tranfer large amounts of data either way, the drive will just go dead. If I try to access any file on the external HD afterwards it simply can't find it. If I unplug the usb, it still shows as being plugged it. If i try to use the safely remove hardware it will tell me something is in use, and I can't. Basically I have to restart the computer inorder to plug the external HD back in and use it.

Its not just external drives either. Basically anything when tranfering large amounts of data. Recently when updating my iphone it went dead, which resulted in me havning to restore my iphone back to its original settings, which inturn resulted in me havning to tranfer all my music, and videos back onto it. I think I had to restart my computer 20 times before I got everything on it. My little memory stick slots also go dead.

Anyway, I never had this issue until after I upgrading from vista to windows 7. So i'm sure its related. Does anyone know whats wrong, and how I can fix it? I havn't been able to backup my computer in 2 months because of this issue. Any help would be much appreciated.

Here's my computer info.
OS Name Microsoft Windows 7 Home Premium
Version 6.1.7600 Build 7600
System Manufacturer HP-Pavilion
System Model KT334AA-ABA m8530f
System Type x64-based PC
Processor AMD Phenom(tm) 9550 Quad-Core Processor, 2200 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 5.24, 6/23/2008
SMBIOS Version 2.5

and incase its important the external HD I have are all seagate, but like I said its happened with my iphone, and even my sony memory stick. So i don't think this part matters.

Thanks in advance.


My System SpecsSystem Spec
.
01 Mar 2010   #2
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Check whether "Write Caching" is enabled. Go to Device Manager > double click on Disk Drives > Right click on the disks in question and go to Properties > Policies Tab. If caching is not enabled, you should enable it. But from then on always use "safely remove" before you disconnect a disk.
My System SpecsSystem Spec
02 Mar 2010   #3
whest

XP, Vista, W7 64bit Home Premium
 
 

Quote   Quote: Originally Posted by Adamv2 View Post
Hi, i'm not sure this is the right forum. If not, I apologize.

Anyway I have 3 external harddrives I often connect to my HP Pavilion. They connect fine, and I have no issues accessing data. However whenever I tranfer large amounts of data either way, the drive will just go dead. If I try to access any file on the external HD afterwards it simply can't find it. If I unplug the usb, it still shows as being plugged it. If i try to use the safely remove hardware it will tell me something is in use, and I can't. Basically I have to restart the computer inorder to plug the external HD back in and use it.

Its not just external drives either. Basically anything when tranfering large amounts of data. Recently when updating my iphone it went dead, which resulted in me havning to restore my iphone back to its original settings, which inturn resulted in me havning to tranfer all my music, and videos back onto it. I think I had to restart my computer 20 times before I got everything on it. My little memory stick slots also go dead.

Anyway, I never had this issue until after I upgrading from vista to windows 7. So i'm sure its related. Does anyone know whats wrong, and how I can fix it? I havn't been able to backup my computer in 2 months because of this issue. Any help would be much appreciated.

Here's my computer info.
OS Name Microsoft Windows 7 Home Premium
Version 6.1.7600 Build 7600
System Manufacturer HP-Pavilion
System Model KT334AA-ABA m8530f
System Type x64-based PC
Processor AMD Phenom(tm) 9550 Quad-Core Processor, 2200 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 5.24, 6/23/2008
SMBIOS Version 2.5

and incase its important the external HD I have are all seagate, but like I said its happened with my iphone, and even my sony memory stick. So i don't think this part matters.

Thanks in advance.
Try this fix if you have a NVIDIA USB Enhanced Host Controller Interface (EHCI) chipset -
You encounter problems when you move data over USB from a Windows 7 or Windows Server 2008 R2-based computer that has an NVIDIA USB EHCI chipset and at least 4GB of RAM
My System SpecsSystem Spec
.

03 Mar 2010   #4
Adamv2

windows 7
 
 

Thanks. Both those seemed to do the trick.
My System SpecsSystem Spec
Reply

 external device issues since upgrading




Thread Tools






Similar help and support threads
Thread Forum
Upgrading ATI driver issues
Hi all, I recently updated the driver for my ATI HD7950, since i have done this I keep getting BSOD compaining about ATI. I have seen in the past a thread on here detailing how to properly update the drivers by removing the previous version and using Driver Sweeper but couldnt find it, and...
Graphic Cards
Latency Issues after upgrading to Windows 7.
Hey guys, I've been having some issues with latency issues recently. It all started after upgrading from Vista to Windows 7. I have tried upgrading all my drivers, and even downgrading my Network driver thinking it might fix the problem, but to no avail. I am a big online gamer, so you can...
Performance & Maintenance
Another External H Drive is Not Accessible After Upgrading to Win 7
I have just upgraded to Win 7 and want to use old hard drive (Seagate 500 gb) as external usb drive. Other drives work just fine in the caddy. However, when I connect this Seagate drive it does not show up in disk management. In device management it does show as USB Mass Storage Device. ...
Hardware & Devices
Lost external display after upgrading
Apologies if the answer to this has already been posted but I've searched and can't find an answer. Using standard VGA graphics adapter on an acer aspire 5920G, I've been able to connect my laptop to tv and use dual monitors without a problem for a while. However, I've just upgraded to...
Graphic Cards
Upgrading - Device Incompatibility
While trying to upgrade to Windows 7, I get this message: Upgrading Windows will affect the following devices and/or programs: These devices might not work properly after the upgrade. Before upgrading, we recommend updating the drivers for these devices. Cancel the upgrade, open...
Drivers
Lost external display after upgrading
Upgraded a Lenovo Thinkpad T60 notebook with ATI x1300 integrated graphics (CPU: Core2Duo 2Ghz; Memory: 3 GB). After the upgrade the system won't display any image any external monitor. System does recognize the monitor (displaying model and manufacturer info), but the screen just remains black. ...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App