Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No HDMI Input option for Sound!! AHHH!!!


26 Mar 2010   #1

7 x64/ Back-Track 4
 
 
No HDMI Input option for Sound!! AHHH!!!

Ooookay - so heres how it goes.

1. I wanted to hook up my laptop to my Sony Bravia 52' HDTV.(phew )
2. I got a HDMI cable - and hooked it up to my receiver - so it would work with my surround sound( i checked to make sure that was right /w the Best Buy folks)(and its the right way to do it, as HDMI cables do HD Sound/Audio.)
3. I plugged in to HDMI cable into the HDMI slot in my laptop and the other end goes into the one in my Onkyo Receiver.
4. I got the "video" to work-out fine. - my computer screen shows up on the tv.
4.5 PS. I wanted to hook up my laptop to my tv so i could watch blu-rays - i cannot afford a blu-ray player of high quality yet.
5. So i see my mouse moving on the screen and everything - but when i go to play a sound file - no sound!
6. I looked around on Google and people said that i had to set the HDMI Input as Default in my sound manager(accessed through ctrl panel -> Hardware/Devices -> Sound -> Manage Audio Devices.)
7. Under the "Playback" tab - it shows my sound things - Speakers(underneath it in small font) Realtek High Def. Audio. Default Device.) And under that(a completly new set) Realtek Digital Output.(it says its ready.)
8. I've tried setting the second one to Default to check if any sound will come through the receiver - but nothing happens - and when thats set as default - no sound from my laptop at all and no sound from the surround sound system.
9. When i have the Speakers(the normal version) set as default - i can see video on the tv but the sound is through my laptop speakers.

Well thats about it guys - i've hit a dead end. I went over to hp.com and looked for drivers but my laptop -> HP Pavilion dv6700t CTO Entertainment Notebook PC -> has only drivers listed for Vista x64. Nothing for windows 7.

I also went over to the realtek website and downloaded sound drivers(ones for 7/vista x64 latest) and still nothing. So i'm in a total jam!

And to top it all off - i cannot take screens of these things to show you guys because my Sniping Tool has somehow(?wtff??) disappeared!!. AHhhh! Lol

Thanks all And i REALLY hope that this thread will help alot of the other people on the 'net, because the results displayed in google are horrible. and i mean... HORRIBLE.
Thanks nd GL!

My System SpecsSystem Spec
.

26 Mar 2010   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by DarkDavil View Post
Ooookay - so heres how it goes.

1. I wanted to hook up my laptop to my Sony Bravia 52' HDTV.(phew )
2. I got a HDMI cable - and hooked it up to my receiver - so it would work with my surround sound( i checked to make sure that was right /w the Best Buy folks)(and its the right way to do it, as HDMI cables do HD Sound/Audio.)
3. I plugged in to HDMI cable into the HDMI slot in my laptop and the other end goes into the one in my Onkyo Receiver.
4. I got the "video" to work-out fine. - my computer screen shows up on the tv.
4.5 PS. I wanted to hook up my laptop to my tv so i could watch blu-rays - i cannot afford a blu-ray player of high quality yet.
5. So i see my mouse moving on the screen and everything - but when i go to play a sound file - no sound!
6. I looked around on Google and people said that i had to set the HDMI Input as Default in my sound manager(accessed through ctrl panel -> Hardware/Devices -> Sound -> Manage Audio Devices.)
7. Under the "Playback" tab - it shows my sound things - Speakers(underneath it in small font) Realtek High Def. Audio. Default Device.) And under that(a completly new set) Realtek Digital Output.(it says its ready.)
8. I've tried setting the second one to Default to check if any sound will come through the receiver - but nothing happens - and when thats set as default - no sound from my laptop at all and no sound from the surround sound system.
9. When i have the Speakers(the normal version) set as default - i can see video on the tv but the sound is through my laptop speakers.

Well thats about it guys - i've hit a dead end. I went over to hp.com and looked for drivers but my laptop -> HP Pavilion dv6700t CTO Entertainment Notebook PC -> has only drivers listed for Vista x64. Nothing for windows 7.

I also went over to the realtek website and downloaded sound drivers(ones for 7/vista x64 latest) and still nothing. So i'm in a total jam!

And to top it all off - i cannot take screens of these things to show you guys because my Sniping Tool has somehow(?wtff??) disappeared!!. AHhhh! Lol

Thanks all And i REALLY hope that this thread will help alot of the other people on the 'net, because the results displayed in google are horrible. and i mean... HORRIBLE.
Thanks nd GL!
You can use the vista driver if you install it in compatibility mode. to do so right click the installer>properties>compatibility mode>check vista.

Re: snipping search for snipping.exe to see if present. If not someone with 64 bit can upload a copy.

Hope this helps

Ken
My System SpecsSystem Spec
26 Mar 2010   #3

Windows 7 Ultimate x64
 
 

Hi.

It's the graphics driver that needs to be updated, as that is what controls the HDMI connection. Which driver are you currently using?
My System SpecsSystem Spec
.


26 Mar 2010   #4

7 x64/ Back-Track 4
 
 

Quote   Quote: Originally Posted by FZ21Z View Post
Hi.

It's the graphics driver that needs to be updated, as that is what controls the HDMI connection. Which driver are you currently using?
Okay - i just went to nvidia and got the latest driver: NVIDIA - Download Drivers

@Ken
The snipping tool has truly disappeared! I don't know how that even happened.... o.O. Maybe my sfc \ scannow messed up? I recently ran one.

Edit: I'll write if my cable worked yet or not tmrw I'm going to sleep now
My System SpecsSystem Spec
27 Mar 2010   #5

7 x64/ Back-Track 4
 
 

Nope - it still doesnt show anything for HDMI in my sound manager Any other ways to route the sound to the cable...? Or should i go over to best buy and ask Geek Squad or something .....

-DD
My System SpecsSystem Spec
27 Mar 2010   #6

Windows 7 Ultimate x64
 
 

Have you tried the original driver in compatibility mode?

NVIDIA GeForce Series Video Driver HP Pavilion dv6000t
My System SpecsSystem Spec
27 Mar 2010   #7

7 x64/ Back-Track 4
 
 

Quote   Quote: Originally Posted by FZ21Z View Post
Have you tried the original driver in compatibility mode?

NVIDIA GeForce Series Video Driver HP Pavilion dv6000t
Should i try that? :P
What i'm trying out now is I'm going to be trying it in XP OS and also in my original os, Vista Home Prem. x64. I'll try the Nvidia driver in compatibility mode later. Thanks
My System SpecsSystem Spec
27 Mar 2010   #8

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by DarkDavil View Post
Should i try that?
It's worth a try for nothing.
My System SpecsSystem Spec
27 Mar 2010   #9

7 x64/ Back-Track 4
 
 

Quote   Quote: Originally Posted by FZ21Z View Post
Quote   Quote: Originally Posted by DarkDavil View Post
Should i try that?
It's worth a try for nothing.
Hah! You're right - in a sense.. !
Look here -->This is How to get HDMI Audio YAYY!!

I havent tested it yet - because i couldnt find the driver yet lol.

OPEN REQUEST: Where can i find the driver for my video card( GeForce 8400M GS) but in version 182.50(which is for Vista x64)
- Thanks !
My System SpecsSystem Spec
27 Mar 2010   #10

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by DarkDavil View Post
OPEN REQUEST: Where can i find the driver for my video card( GeForce 8400M GS) but in version 182.50(which is for Vista x64)
- Thanks !
Here - laptopvideo2go.com/topic/23568-v18250-windows-vista-64bit-nvidia, along with the inf.
My System SpecsSystem Spec
Reply

 No HDMI Input option for Sound!! AHHH!!!




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:00 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33