Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: X-Fi Elite Pro remote not working

02 Apr 2010   #1

W7
 
 
X-Fi Elite Pro remote not working

Hi guys,

I'm on windows 7 64 bit. Just got the creative x-fi elite pro today and I can't make the remote work with windows 7. I have installed the latest driver for windows 7 on their site. I even reformated and freshly installed the drivers to verify there was no conflict without any success.

I'm wondering if there are any other Windows 7 64 users with this soundcard that experienced a familiar issue?

Thanks.

My System SpecsSystem Spec
.

02 Apr 2010   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Silencio View Post
Hi guys,

I'm on windows 7 64 bit. Just got the creative x-fi elite pro today and I can't make the remote work with windows 7. I have installed the latest driver for windows 7 on their site. I even reformated and freshly installed the drivers to verify there was no conflict without any success.

I'm wondering if there are any other Windows 7 64 users with this soundcard that experienced a familiar issue?

Thanks.
What driver are you using?
My System SpecsSystem Spec
02 Apr 2010   #3

W7
 
 

Creative Sound Blaster X-Fi series driver 2.18.0013
My System SpecsSystem Spec
.


02 Apr 2010   #4

W7
 
 

I take it from the lack of responses that absolutely no one else here uses this sound card
My System SpecsSystem Spec
03 Apr 2010   #5

Windows 7 Enterprise x64
 
 

The first, and most obvious question would be, do you have a new battery in the remote? I know, stupid question, but hey, you never know.

Looks like you have the most recent driver available. So if you have a new battery in it, chances are it was dead on arrival. Your only logical next step would be an RMA.
My System SpecsSystem Spec
03 Apr 2010   #6

W7
 
 

Thanks for your response max.

Yes the remote is functional. The box unit has an IR receive light that flashes to confirm the functionality of the remote. I got an email from Creative saying that there are only Windows 7 compatible drivers at the moment, however no software is available for Windows 7 with this card at the moment.

So from this I conclude that the remote must require software to function through the box? Never would have guessed that. Still open to responses from Windows 7 users with this card! Just want to make sure I'm on the right page with everyone else.
My System SpecsSystem Spec
03 Apr 2010   #7

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

silencio, have you tried the vista drivers in compatibility mode ? Compatibility Mode
My System SpecsSystem Spec
04 Apr 2010   #8

W7
 
 

Hi pebbly,

Yes I have. I used the vista compatibility mode to install the Vista Creative Entertainment Center that came with the card (it wouldnt work trying to install it w/o compatibility mode). I still couldn't turn on the Entertainment center using the remote. I even booted the exe up in compatibility mode and had no success navigating through the menus using the remote. I actually had to end up force quiting it because that is solely designed to be used with the remote!

Thanks for the suggestion though. That was my last resort I believe.
My System SpecsSystem Spec
14 Apr 2010   #9

Win 7 x64 Ultimate
 
 

I also have X-Fi elite pro and remote does NOT work in Windows 7 x64 Ultimate, however receiving LED flashes on the external box, same as your case.
I installed both drivers and console launcher, because i like to tweak the equalizer, which i can do only thru CSL.

Idea came to my mind though, to turn off user account control, to see if by any chance administrative rights were required to operate these controls thru remote. As it turns out - no. Then i remembered that i can push these knobs to turn on/off e.g. Crystallizer and they DO work, so now i think it's something with remote support on Windows 7 x64. Tomorrow i'll try to install Vista ultimate 64, and then xp64, just to see if it works on these systems.

If by any chance you'll somehow get it working, please leave me a pm or something with explanation how you did it.
My System SpecsSystem Spec
14 Apr 2010   #10

Win 7 x64 Ultimate
 
 

Okay so i did what someone suggested in other thread, which is to install creative entertainment center. Remote works and displays some useless OSD stuff too. BTW installer said installation not finished and threw some error, ERR-I001 i believe, but i tried to restart computer and it worked nonetheless. EC also works somehow.

Luck to you.
My System SpecsSystem Spec
Reply

 X-Fi Elite Pro remote not working




Thread Tools



Similar help and support threads for2: X-Fi Elite Pro remote not working
Thread Forum
Remote Desktop not working even though everything else is Network & Sharing
Solved Remote desktop is not working Network & Sharing
MCE Remote Not Working Media Center
Creative SB X-FI Elite Pro Not working Sound & Audio
X-fi Elite Pro - remote does not work Sound & Audio
help getting remote desktop working Network & Sharing
Remote Control not working. Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:05 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33